summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-02-26 00:31:13 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-02-26 00:31:13 +0000
commitab4ac3e15c134654b09fd108b4023dac892106b1 (patch)
tree8038060f8e64b65d1577c1ca366741a69c5accd6 /dev-python/PyQt
parentOops, install both binaries and headerfiles. (diff)
downloadhistorical-ab4ac3e15c134654b09fd108b4023dac892106b1.tar.gz
historical-ab4ac3e15c134654b09fd108b4023dac892106b1.tar.bz2
historical-ab4ac3e15c134654b09fd108b4023dac892106b1.zip
Fix qt-3.3 related compile errors.
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/ChangeLog6
-rw-r--r--dev-python/PyQt/Manifest11
-rw-r--r--dev-python/PyQt/PyQt-3.10.ebuild8
-rw-r--r--dev-python/PyQt/files/PyQt-3.10-qt-3.3.patch14
4 files changed, 32 insertions, 7 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index a895ebc684a8..59b6967c1313 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.26 2004/01/18 01:06:05 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.27 2004/02/26 00:31:12 kloeri Exp $
+
+ 26 Feb 2004; <kloeri@gentoo.org> PyQt-3.10.ebuild,
+ files/PyQt-3.10-qt-3.3.patch:
+ Fix qt-3.3 related compile errors.
*PyQt-3.10 (17 Jan 2004)
diff --git a/dev-python/PyQt/Manifest b/dev-python/PyQt/Manifest
index 4ce7fcbc1551..48ff1b152ef0 100644
--- a/dev-python/PyQt/Manifest
+++ b/dev-python/PyQt/Manifest
@@ -1,10 +1,11 @@
-MD5 a5ee80f965b4472fbf3cd8bb5bd73ad0 ChangeLog 3482
+MD5 21cf1cf486764de344fda5365925d29d ChangeLog 3601
MD5 f4317fb0f6ab10575aa8afdd0af7c665 PyQt-3.5.ebuild 1158
-MD5 1faea5dde5928be5726633acf852be18 PyQt-3.8.1.ebuild 1584
+MD5 4b16ddee9695d55a3fa35e377a9b7ed2 PyQt-3.10.ebuild 1690
MD5 811c07ba7510a315382249fc3adb44fc metadata.xml 175
-MD5 24128da09478d0611d72482ce400606c PyQt-3.10.ebuild 1574
+MD5 1faea5dde5928be5726633acf852be18 PyQt-3.8.1.ebuild 1584
+MD5 b7a163cf6c16bcf3dbb9095827bb527f files/PyQt-3.10-qt-3.3.patch 294
+MD5 7323b7d1c141a1f065cb1b8646bec695 files/license-3.8.1.diff 960
+MD5 3fa2049e4d6038c8e02e2069f072cd60 files/digest-PyQt-3.8.1 70
MD5 4bd3f02e83b155d77c50cc023c3d42ba files/digest-PyQt-3.10 69
MD5 cfa5b5c9a44fc587bc3937b2d1335bb9 files/digest-PyQt-3.5 68
-MD5 3fa2049e4d6038c8e02e2069f072cd60 files/digest-PyQt-3.8.1 70
-MD5 7323b7d1c141a1f065cb1b8646bec695 files/license-3.8.1.diff 960
MD5 94164eef52f16b805d3c252c02100d11 files/qt3.1.2-compilation-fix-3.5.diff 2151
diff --git a/dev-python/PyQt/PyQt-3.10.ebuild b/dev-python/PyQt/PyQt-3.10.ebuild
index 3f48658ee6d0..b45d30cea409 100644
--- a/dev-python/PyQt/PyQt-3.10.ebuild
+++ b/dev-python/PyQt/PyQt-3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.10.ebuild,v 1.1 2004/01/18 01:06:05 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.10.ebuild,v 1.2 2004/02/26 00:31:12 kloeri Exp $
inherit distutils
@@ -26,6 +26,12 @@ DEPEND="virtual/glibc
src_compile() {
distutils_python_version
+
+ # fix qt-3.3 compile problem
+ if has_version '=x11-libs/qt-3.3*' ; then
+ epatch "${FILESDIR}/${P}-qt-3.3.patch"
+ fi
+
# standard qt sandbox problem workaround
[ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
dodir /usr/lib/python${PYVER}/site-packages /usr/include/python${PYVER} /usr/bin /usr/share/sip
diff --git a/dev-python/PyQt/files/PyQt-3.10-qt-3.3.patch b/dev-python/PyQt/files/PyQt-3.10-qt-3.3.patch
new file mode 100644
index 000000000000..3299d2daeede
--- /dev/null
+++ b/dev-python/PyQt/files/PyQt-3.10-qt-3.3.patch
@@ -0,0 +1,14 @@
+--- PyQt-x11-gpl-3.10/sip/qttable/qtable.sip~ 2004-02-25 23:13:59.054964424 +0100
++++ PyQt-x11-gpl-3.10/sip/qttable/qtable.sip 2004-02-25 23:14:30.527179920 +0100
+@@ -168,11 +168,6 @@
+
+ virtual int rtti() const;
+ %End
+-
+-protected:
+-%If (Qt_3_2_0 -)
+- QString content() const;
+-%End
+ };
+
+