summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-15 22:22:33 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-15 22:22:33 +0000
commit5806d48388815373508ef041e0981efc18261cc0 (patch)
treef722f7080610a34cf11afc2f9f0df88faaeb0481 /dev-python/Imaging/Imaging-1.1.4.ebuild
parentFixed issue with zapping_setup_fb. Closes #24142 (diff)
downloadhistorical-5806d48388815373508ef041e0981efc18261cc0.tar.gz
historical-5806d48388815373508ef041e0981efc18261cc0.tar.bz2
historical-5806d48388815373508ef041e0981efc18261cc0.zip
bugfix for setup.py
Diffstat (limited to 'dev-python/Imaging/Imaging-1.1.4.ebuild')
-rw-r--r--dev-python/Imaging/Imaging-1.1.4.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-python/Imaging/Imaging-1.1.4.ebuild b/dev-python/Imaging/Imaging-1.1.4.ebuild
index e89d0fb170c2..81249932b8d1 100644
--- a/dev-python/Imaging/Imaging-1.1.4.ebuild
+++ b/dev-python/Imaging/Imaging-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging/Imaging-1.1.4.ebuild,v 1.4 2003/07/12 12:49:25 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging/Imaging-1.1.4.ebuild,v 1.5 2003/07/15 22:22:23 liquidx Exp $
inherit distutils
@@ -18,23 +18,24 @@ DEPEND="virtual/python
>=media-libs/jpeg-6a
>=sys-libs/zlib-0.95
tcltk? ( dev-lang/tk )"
-
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 setup.py < ${FILESDIR}/${P}-setup.py.patch
+}
+
src_compile() {
export OPT=${CFLAGS}
#Build the core imaging library (libImaging.a)
cd ${S}/libImaging
econf
- cp Makefile Makefile.orig
-
#Not configured by configure
- sed \
- -e "s:\(JPEGINCLUDE=[[:blank:]]*/usr/\)local/\(include\).*:\1\2:" \
- Makefile.orig > Makefile
+ sed -e "s:\(JPEGINCLUDE=[[:blank:]]*/usr/\)local/\(include\).*:\1\2:" \
+ -i Makefile
emake || die
cd ${S}; distutils_src_compile
- #cd ${S}
- #CFLAGS="$(CFLAGS) -DUSE_COMPOSITELESS_PHOTO_PUT_BLOCK" distutils_src_compile
}
src_install ()