summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-03 08:27:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-03 08:27:07 +0000
commit9316d866ad653a3e1d54c81e73a009096478fad8 (patch)
tree0b3c3679ed24074247966e7ff4b457925b8dd75d /dev-php
parentqt include configure breakage fixed (diff)
downloadhistorical-9316d866ad653a3e1d54c81e73a009096478fad8.tar.gz
historical-9316d866ad653a3e1d54c81e73a009096478fad8.tar.bz2
historical-9316d866ad653a3e1d54c81e73a009096478fad8.zip
same fixes for -r1
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php/ChangeLog5
-rw-r--r--dev-php/php/php-4.3.1-r1.ebuild16
-rw-r--r--dev-php/php/php-4.3.1.ebuild11
3 files changed, 17 insertions, 15 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 3e23ca956c1d..7c87a2414c43 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-php/php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.38 2003/03/03 07:59:18 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.39 2003/03/03 08:27:07 seemant Exp $
13 Jan 2003; Daniel Ahlberg <aliz@genoto.org> php-4.3.0-r2.ebuild :
Added ppc and sparc keyword becuse this is a security update.
@@ -10,6 +10,9 @@
*php-4.3.1 (24 Feb 2003)
03 Mar 2003; Seemant Kulleen <seemant@gentoo.org> php-4.3.1.ebuild:
+ disabled pcntl support for now
+
+ 03 Mar 2003; Seemant Kulleen <seemant@gentoo.org> php-4.3.1.ebuild:
not hardcoding qt2's include
24 Feb 2003; Ryan Phillips <rphillips@gentoo.org> php-4.3.1-r1.ebuild :
diff --git a/dev-php/php/php-4.3.1-r1.ebuild b/dev-php/php/php-4.3.1-r1.ebuild
index ec3d32a9c192..c9d38366e253 100644
--- a/dev-php/php/php-4.3.1-r1.ebuild
+++ b/dev-php/php/php-4.3.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.1-r1.ebuild,v 1.3 2003/02/24 21:55:22 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.1-r1.ebuild,v 1.4 2003/03/03 08:27:07 seemant Exp $
IUSE="truetype postgres tiff libwww nls jpeg readline ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
@@ -123,10 +123,7 @@ src_compile() {
fi
fi
- use qt && {
- export QTDIR=/usr/qt/2 #hope this helps - danarmak
- myconf="${myconf} --with-qtdom"
- }
+ use qt && myconf="${myconf} --with-qtdom"
if [ "`use imap`" ] ; then
if [ "`use ssl`" ] && [ "`strings ${ROOT}/usr/lib/c-client.a \
@@ -160,8 +157,7 @@ src_compile() {
fi
# --with-gmp \
- ./configure \
- --prefix=/usr \
+ econf \
--with-bz2 \
--enable-ftp \
--enable-dbase \
@@ -171,7 +167,6 @@ src_compile() {
--enable-sysvshm \
--with-gd \
--enable-sockets \
- --enable-pcntl \
--enable-cli \
--disable-cgi \
--enable-calendar \
@@ -181,7 +176,10 @@ src_compile() {
--enable-inline-optimization \
--with-config-file-path=/etc/php4 \
--with-pear \
- --host=${CHOST} ${myconf} || die "bad ./configure"
+ ${myconf} || die "bad ./configure"
+ # Causing breakages -- fork not supported on this architecture
+ # messages, so disabling this option for now.
+ # --enable-pcntl \
make || die "compile problem"
}
diff --git a/dev-php/php/php-4.3.1.ebuild b/dev-php/php/php-4.3.1.ebuild
index 750f9d7d1b79..8c65d65f8da9 100644
--- a/dev-php/php/php-4.3.1.ebuild
+++ b/dev-php/php/php-4.3.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.1.ebuild,v 1.3 2003/03/03 07:59:18 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.1.ebuild,v 1.4 2003/03/03 08:27:07 seemant Exp $
IUSE="truetype postgres tiff libwww nls jpeg readline ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
@@ -159,8 +159,7 @@ src_compile() {
fi
# --with-gmp \
- ./configure \
- --prefix=/usr \
+ econf \
--with-bz2 \
--enable-ftp \
--enable-dbase \
@@ -170,7 +169,6 @@ src_compile() {
--enable-sysvshm \
--with-gd \
--enable-sockets \
- --enable-pcntl \
--enable-cli \
--disable-cgi \
--enable-calendar \
@@ -180,7 +178,10 @@ src_compile() {
--enable-inline-optimization \
--with-config-file-path=/etc/php4 \
--with-pear \
- --host=${CHOST} ${myconf} || die "bad ./configure"
+ ${myconf} || die "bad ./configure"
+ # this b0rks user's machines, so until we can assure this flag is stable,
+ # I'm disabling it -- seemant (march 3 2003)
+ # --enable-pcntl \
make || die "compile problem"
}