summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-05-29 18:39:39 +0000
committerMatti Bickel <mabi@gentoo.org>2010-05-29 18:39:39 +0000
commitd68eb8796e57412107203d951c8f27145a6696fd (patch)
tree6a198ce361a3c224d232cd9d13f242ed417ee76b /dev-php5/phpunit
parentVersion bump. (diff)
downloadhistorical-d68eb8796e57412107203d951c8f27145a6696fd.tar.gz
historical-d68eb8796e57412107203d951c8f27145a6696fd.tar.bz2
historical-d68eb8796e57412107203d951c8f27145a6696fd.zip
version bump
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-php5/phpunit')
-rw-r--r--dev-php5/phpunit/ChangeLog7
-rw-r--r--dev-php5/phpunit/phpunit-3.4.13.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 5b3fb5bdd28b..14d43f05db8f 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.27 2010/04/06 19:22:54 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.28 2010/05/29 18:30:40 mabi Exp $
+
+*phpunit-3.4.13 (29 May 2010)
+
+ 29 May 2010; <mabi@gentoo.org> +phpunit-3.4.13.ebuild:
+ version bump
06 Apr 2010; Maciej Mrozowski <reavertm@gentoo.org> -phpunit-3.2.8.ebuild,
-phpunit-3.2.21.ebuild, -phpunit-3.3.1.ebuild:
diff --git a/dev-php5/phpunit/phpunit-3.4.13.ebuild b/dev-php5/phpunit/phpunit-3.4.13.ebuild
new file mode 100644
index 000000000000..e7aa77a1e82f
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.4.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.4.13.ebuild,v 1.1 2010/05/29 18:30:40 mabi Exp $
+
+EAPI="2"
+inherit php-pear-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+
+DESCRIPTION="Unit testing framework for PHP5"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+minimal"
+
+DEPEND="!dev-php4/phpunit
+ >=dev-php/PEAR-PEAR-1.8.1"
+RDEPEND="${DEPEND}
+ >=dev-lang/php-5.2[simplexml,xml,tokenizer]
+ || ( <dev-lang/php-5.3[pcre,reflection,spl] >=dev-lang/php-5.3 )
+ !minimal? ( >=dev-php5/xdebug-2.0.5
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+need_php_by_category
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+ if use minimal; then
+ elog "You have enabled the minimal USE flag. If you want to use features"
+ elog "from xdebug, PEAR-Log or PEAR-Testing_Selenium disable the"
+ elog "USE flag or emerge the packages manually"
+ fi
+}