summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2005-09-04 16:11:42 +0000
committerStuart Herbert <stuart@gentoo.org>2005-09-04 16:11:42 +0000
commit78838be01988717932d3e962a27a3a0d768a3054 (patch)
treed829875ebca0d877ea4e48fbef1d458798bf2aed /dev-php4/phpdbg
parentInitial import for PHP4 (diff)
downloadhistorical-78838be01988717932d3e962a27a3a0d768a3054.tar.gz
historical-78838be01988717932d3e962a27a3a0d768a3054.tar.bz2
historical-78838be01988717932d3e962a27a3a0d768a3054.zip
Initial import
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-php4/phpdbg')
-rw-r--r--dev-php4/phpdbg/ChangeLog7
-rw-r--r--dev-php4/phpdbg/files/digest-phpdbg-2.11.321
-rw-r--r--dev-php4/phpdbg/metadata.xml5
-rw-r--r--dev-php4/phpdbg/phpdbg-2.11.32.ebuild49
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-php4/phpdbg/ChangeLog b/dev-php4/phpdbg/ChangeLog
new file mode 100644
index 000000000000..ec6365b958cf
--- /dev/null
+++ b/dev-php4/phpdbg/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-php4/phpdbg
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/phpdbg/ChangeLog,v 1.1 2005/09/04 16:11:42 stuart Exp $
+
+ 18 Aug 2005; <stuart@gentoo.org> ChangeLog:
+ Initial version; replaces older dev-php/* packages
+
diff --git a/dev-php4/phpdbg/files/digest-phpdbg-2.11.32 b/dev-php4/phpdbg/files/digest-phpdbg-2.11.32
new file mode 100644
index 000000000000..07041a3b6d71
--- /dev/null
+++ b/dev-php4/phpdbg/files/digest-phpdbg-2.11.32
@@ -0,0 +1 @@
+MD5 1ac7372bfcb4c5e13cad1248e071d70c dbg-2.11.32-src.tar.gz 39369
diff --git a/dev-php4/phpdbg/metadata.xml b/dev-php4/phpdbg/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php4/phpdbg/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php4/phpdbg/phpdbg-2.11.32.ebuild b/dev-php4/phpdbg/phpdbg-2.11.32.ebuild
new file mode 100644
index 000000000000..9874f50517c1
--- /dev/null
+++ b/dev-php4/phpdbg/phpdbg-2.11.32.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/phpdbg/phpdbg-2.11.32.ebuild,v 1.1 2005/09/04 16:11:42 stuart Exp $
+
+PHP_EXT_NAME="dbg"
+PHP_EXT_ZENDEXT="no"
+inherit php-ext-source-r1
+IUSE=""
+S="${WORKDIR}/dbg-${PV}${PL}"
+DESCRIPTION="A PHP debugger useable with some editors like phpedit."
+SRC_URI="mirror://sourceforge/dbg2/dbg-${PV}${PL}-src.tar.gz"
+HOMEPAGE="http://dd.cron.ru/dbg/"
+LICENSE="dbgphp"
+SLOT="0"
+
+KEYWORDS="~ppc ~x86"
+
+need_php_by_category
+
+src_compile() {
+ # phpdbg does not work with Zend Thread Safety (ZTS)
+ # so abort if we are using PHP compiled with ZTS.
+ if has_zts ; then
+ eerror "phpdbg doesn't work with a ZTS enabled PHP."
+ eerror "Please disable ZTS by turning the 'threads'"
+ eerror "USE flag off when you compile dev-lang/php."
+ die "phpdbg does not support ZTS"
+ fi
+
+ my_conf="--enable-dbg=shared --with-dbg-profiler"
+ php-ext-source-r1_src_compile
+}
+
+src_install () {
+ php-ext-source-r1_src_install
+ dodoc AUTHORS COPYING INSTALL
+ php-ext-base-r1_addtoinifiles "[Debugger]"
+ php-ext-base-r1_addtoinifiles "debugger.enabled" "on"
+ php-ext-base-r1_addtoinifiles "debugger.profiler_enabled" "on"
+}
+
+pkg_postinst() {
+ einfo "Please reload Apache to activate the changes"
+}
+
+pkg_postrm() {
+ einfo "You need to remove all lines referring to the debugger, and"
+ einfo "extension=dbg.so. Please reload Apache to activate the changes."
+}