summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-07-27 11:28:00 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-07-27 11:28:00 +0000
commit3e3356d1dab1eee1df6d8a282dd9afc4a25103db (patch)
treec47e11d9dbbc1e804d1fb4ddf73a466cce011e09 /dev-php4/eaccelerator
parent* bump (diff)
downloadhistorical-3e3356d1dab1eee1df6d8a282dd9afc4a25103db.tar.gz
historical-3e3356d1dab1eee1df6d8a282dd9afc4a25103db.tar.bz2
historical-3e3356d1dab1eee1df6d8a282dd9afc4a25103db.zip
* bump
Package-Manager: portage-2.1.1_pre3-r5
Diffstat (limited to 'dev-php4/eaccelerator')
-rw-r--r--dev-php4/eaccelerator/ChangeLog8
-rw-r--r--dev-php4/eaccelerator/eaccelerator-0.9.5_rc1.ebuild102
-rw-r--r--dev-php4/eaccelerator/files/digest-eaccelerator-0.9.32
-rw-r--r--dev-php4/eaccelerator/files/digest-eaccelerator-0.9.5_rc13
4 files changed, 114 insertions, 1 deletions
diff --git a/dev-php4/eaccelerator/ChangeLog b/dev-php4/eaccelerator/ChangeLog
index 9aa6a42fd615..bd5c30fa2cdc 100644
--- a/dev-php4/eaccelerator/ChangeLog
+++ b/dev-php4/eaccelerator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php4/eaccelerator
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/eaccelerator/ChangeLog,v 1.7 2006/05/27 00:43:17 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/eaccelerator/ChangeLog,v 1.8 2006/07/27 11:28:00 voxus Exp $
+
+*eaccelerator-0.9.5_rc1 (27 Jul 2006)
+
+ 27 Jul 2006; Konstantin Arkhipov <voxus@gentoo.org>
+ +eaccelerator-0.9.5_rc1.ebuild:
+ Version bump.
27 May 2006; Luca Longinotti <chtekk@gentoo.org>
eaccelerator-0.9.4.ebuild:
diff --git a/dev-php4/eaccelerator/eaccelerator-0.9.5_rc1.ebuild b/dev-php4/eaccelerator/eaccelerator-0.9.5_rc1.ebuild
new file mode 100644
index 000000000000..a85122bce6de
--- /dev/null
+++ b/dev-php4/eaccelerator/eaccelerator-0.9.5_rc1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/eaccelerator/eaccelerator-0.9.5_rc1.ebuild,v 1.1 2006/07/27 11:28:00 voxus Exp $
+
+PHP_EXT_NAME="eaccelerator"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+[[ -z "${EACCELERATOR_CACHEDIR}" ]] && EACCELERATOR_CACHEDIR="/var/cache/eaccelerator"
+
+inherit php-ext-source-r1
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="A PHP Accelerator & Encoder."
+HOMEPAGE="http://www.eaccelerator.net/"
+SRC_URI="mirror://sourceforge/eaccelerator/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="contentcache disassembler inode session sharedmem"
+
+DEPEND="${DEPEND}
+ !dev-php5/pecl-apc"
+
+# Webserver user and group, here for Apache.
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ require_php_sapi_from cgi apache apache2
+
+ if use session ; then
+ require_php_with_use session zlib
+ else
+ require_php_with_use zlib
+ fi
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-eaccelerator=shared"
+
+ use contentcache && my_conf="${my_conf} --with-eaccelerator-content-caching"
+ use disassembler && my_conf="${my_conf} --with-eaccelerator-disassembler"
+ use session && my_conf="${my_conf} --with-eaccelerator-sessions"
+ use sharedmem && my_conf="${my_conf} --with-eaccelerator-shared-memory"
+ use !inode && my_conf="${my_conf} --without-eaccelerator-use-inode"
+
+ php-ext-source-r1_src_compile
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+
+ keepdir "${EACCELERATOR_CACHEDIR}"
+ fowners ${HTTPD_USER}:${HTTPD_GROUP} "${EACCELERATOR_CACHEDIR}"
+ fperms 750 "${EACCELERATOR_CACHEDIR}"
+
+ insinto "/usr/share/${PN}"
+ doins doc/php/*
+ dodoc-php AUTHORS ChangeLog COPYING NEWS README README.eLoader
+
+ php-ext-base-r1_addtoinifiles "eaccelerator.shm_size" '"28"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.cache_dir" "\"${EACCELERATOR_CACHEDIR}\""
+ php-ext-base-r1_addtoinifiles "eaccelerator.enable" '"1"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.optimizer" '"1"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.check_mtime" '"1"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.debug" '"0"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.filter" '""'
+ php-ext-base-r1_addtoinifiles "eaccelerator.shm_max" '"0"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.shm_ttl" '"0"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.shm_prune_period" '"0"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.shm_only" '"0"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.compress" '"1"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.compress_level" '"9"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.keys" '"shm_and_disk"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.sessions" '"shm_and_disk"'
+ php-ext-base-r1_addtoinifiles "eaccelerator.content" '"shm_and_disk"'
+ php-ext-base-r1_addtoinifiles ";eaccelerator.allowed_admin_path" '"/path/where/admin/files/shall/be/allowed"'
+}
+
+pkg_postinst() {
+ # You only need to restart the webserver if you're using mod_php.
+ if built_with_use =${PHP_PKG} apache || built_with_use =${PHP_PKG} apache2 ; then
+ einfo
+ einfo "You need to restart your Apache webserver to activate eAccelerator."
+ einfo
+ fi
+
+ einfo
+ einfo "A series of PHP function is available to manage eAccelerator."
+ einfo "Please see the files in /usr/share/${PN} for some examples"
+ einfo "and informations on those functions and how to use them."
+ einfo
+}
diff --git a/dev-php4/eaccelerator/files/digest-eaccelerator-0.9.3 b/dev-php4/eaccelerator/files/digest-eaccelerator-0.9.3
index d64d0dc69aef..921092fd7505 100644
--- a/dev-php4/eaccelerator/files/digest-eaccelerator-0.9.3
+++ b/dev-php4/eaccelerator/files/digest-eaccelerator-0.9.3
@@ -1 +1,3 @@
MD5 b17ddf953f18ee6df5c2c24ffccb37d9 eaccelerator-0.9.3.tar.gz 133120
+RMD160 79c2fd6055e3d8a490c9c538dc1a291cd240e9dc eaccelerator-0.9.3.tar.gz 133120
+SHA256 10236ce6e2b46231e5035e0a97055417974e50a734ef258fd638ef8134875aa5 eaccelerator-0.9.3.tar.gz 133120
diff --git a/dev-php4/eaccelerator/files/digest-eaccelerator-0.9.5_rc1 b/dev-php4/eaccelerator/files/digest-eaccelerator-0.9.5_rc1
new file mode 100644
index 000000000000..5a368e3eef60
--- /dev/null
+++ b/dev-php4/eaccelerator/files/digest-eaccelerator-0.9.5_rc1
@@ -0,0 +1,3 @@
+MD5 5d03deb399f8f857d92dd092a2c69a87 eaccelerator-0.9.5-rc1.tar.bz2 120221
+RMD160 7e3b81989052ec0c74d62b4f832673bbfda33f8b eaccelerator-0.9.5-rc1.tar.bz2 120221
+SHA256 7200dad2a96c17b5a4c04744061e56dfa5f98fb071984ba8bf8f178707a72a5f eaccelerator-0.9.5-rc1.tar.bz2 120221