summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-05-08 17:30:55 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-05-08 17:30:55 +0000
commit6a4e43e2b4d3b667c98e294880e57cb0c892f83c (patch)
treecdf48633e8b140df1757283a604365981a41b8d9 /dev-php/xdebug-client
parent2.2.0_alpha102 version bump. This fixes bug #410691 (handle *.py[co] file (diff)
downloadhistorical-6a4e43e2b4d3b667c98e294880e57cb0c892f83c.tar.gz
historical-6a4e43e2b4d3b667c98e294880e57cb0c892f83c.tar.bz2
historical-6a4e43e2b4d3b667c98e294880e57cb0c892f83c.zip
Version bump
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'dev-php/xdebug-client')
-rw-r--r--dev-php/xdebug-client/ChangeLog8
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.2.0.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index 1090ddcb84de..bf440a4a3d51 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.39 2012/05/02 10:03:34 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.40 2012/05/08 17:30:55 olemarkus Exp $
+
+*xdebug-client-2.2.0 (08 May 2012)
+
+ 08 May 2012; Ole Markus With <olemarkus@gentoo.org>
+ +xdebug-client-2.2.0.ebuild:
+ Version bump
*xdebug-client-2.2.0_rc2 (02 May 2012)
diff --git a/dev-php/xdebug-client/xdebug-client-2.2.0.ebuild b/dev-php/xdebug-client/xdebug-client-2.2.0.ebuild
new file mode 100644
index 000000000000..1cac1b89bd84
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.2.0.ebuild,v 1.1 2012/05/08 17:30:55 olemarkus Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}