summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-10-29 02:06:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-10-29 02:06:06 +0000
commite7e8753a47944c333474efc3e47d938dc7439f22 (patch)
treefca5b62e4710e5dacba8a27bbd60e4fffe4c377c /dev-perl
parentVersion bump via perl-bump experimental tool. (diff)
downloadhistorical-e7e8753a47944c333474efc3e47d938dc7439f22.tar.gz
historical-e7e8753a47944c333474efc3e47d938dc7439f22.tar.bz2
historical-e7e8753a47944c333474efc3e47d938dc7439f22.zip
Version bump via perl-bump experimental tool.
Package-Manager: portage-2.2.0_alpha1/cvs/Linux x86_64
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/CPAN-Checksums/CPAN-Checksums-2.06.ebuild33
-rw-r--r--dev-perl/CPAN-Checksums/ChangeLog8
-rw-r--r--dev-perl/MogileFS-Client/ChangeLog8
-rw-r--r--dev-perl/MogileFS-Client/MogileFS-Client-1.13.ebuild22
-rw-r--r--dev-perl/MogileFS-Utils/ChangeLog8
-rw-r--r--dev-perl/MogileFS-Utils/MogileFS-Utils-2.18.ebuild18
-rw-r--r--dev-perl/Net-Patricia/ChangeLog8
-rw-r--r--dev-perl/Net-Patricia/Net-Patricia-1.18.ebuild17
-rw-r--r--dev-perl/Net-Z3950-ZOOM/ChangeLog8
-rw-r--r--dev-perl/Net-Z3950-ZOOM/Net-Z3950-ZOOM-1.28.ebuild19
10 files changed, 144 insertions, 5 deletions
diff --git a/dev-perl/CPAN-Checksums/CPAN-Checksums-2.06.ebuild b/dev-perl/CPAN-Checksums/CPAN-Checksums-2.06.ebuild
new file mode 100644
index 000000000000..d829980f6359
--- /dev/null
+++ b/dev-perl/CPAN-Checksums/CPAN-Checksums-2.06.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/CPAN-Checksums/CPAN-Checksums-2.06.ebuild,v 1.1 2010/10/29 02:04:32 robbat2 Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=ANDK
+inherit perl-module
+
+DESCRIPTION="Write a CHECKSUMS file for a directory as on CPAN"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="virtual/perl-IO-Compress
+ dev-perl/Compress-Bzip2
+ dev-perl/Data-Compare
+ virtual/perl-Digest-SHA
+ virtual/perl-Digest-MD5
+ virtual/perl-File-Temp
+ virtual/perl-IO"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST="do"
+
+src_test() {
+ # online test
+ mv "${S}"/t/00signature.t{,.disable} || die
+ perl-module_src_test
+}
diff --git a/dev-perl/CPAN-Checksums/ChangeLog b/dev-perl/CPAN-Checksums/ChangeLog
index 408f61d4b579..e0b20aef7ee8 100644
--- a/dev-perl/CPAN-Checksums/ChangeLog
+++ b/dev-perl/CPAN-Checksums/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/CPAN-Checksums
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/CPAN-Checksums/ChangeLog,v 1.31 2010/08/15 17:14:02 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/CPAN-Checksums/ChangeLog,v 1.32 2010/10/29 02:04:32 robbat2 Exp $
+
+*CPAN-Checksums-2.06 (29 Oct 2010)
+
+ 29 Oct 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +CPAN-Checksums-2.06.ebuild:
+ Version bump via perl-bump experimental tool.
15 Aug 2010; Torsten Veller <tove@gentoo.org>
-CPAN-Checksums-1.050.ebuild, -CPAN-Checksums-2.04.ebuild:
diff --git a/dev-perl/MogileFS-Client/ChangeLog b/dev-perl/MogileFS-Client/ChangeLog
index 65306f1bae23..20e5bcf75dd5 100644
--- a/dev-perl/MogileFS-Client/ChangeLog
+++ b/dev-perl/MogileFS-Client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/MogileFS-Client
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MogileFS-Client/ChangeLog,v 1.8 2010/08/20 21:13:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MogileFS-Client/ChangeLog,v 1.9 2010/10/29 02:02:37 robbat2 Exp $
+
+*MogileFS-Client-1.13 (29 Oct 2010)
+
+ 29 Oct 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +MogileFS-Client-1.13.ebuild:
+ Version bump via perl-bump experimental tool.
*MogileFS-Client-1.12 (20 Aug 2010)
diff --git a/dev-perl/MogileFS-Client/MogileFS-Client-1.13.ebuild b/dev-perl/MogileFS-Client/MogileFS-Client-1.13.ebuild
new file mode 100644
index 000000000000..eeb7fa3d99fc
--- /dev/null
+++ b/dev-perl/MogileFS-Client/MogileFS-Client-1.13.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MogileFS-Client/MogileFS-Client-1.13.ebuild,v 1.1 2010/10/29 02:02:37 robbat2 Exp $
+
+MODULE_AUTHOR="DORMANDO"
+inherit perl-module
+
+DESCRIPTION="Client library for the MogileFS distributed file system"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=dev-perl/IO-stringy-2.110
+ dev-perl/libwww-perl
+ dev-lang/perl"
+
+# Tests only available if you have a local mogilefsd on 127.0.0.1:7001
+#SRC_TEST="do"
+mydoc="CHANGES TODO"
diff --git a/dev-perl/MogileFS-Utils/ChangeLog b/dev-perl/MogileFS-Utils/ChangeLog
index 1bbcd0c59807..3fb32cf4d910 100644
--- a/dev-perl/MogileFS-Utils/ChangeLog
+++ b/dev-perl/MogileFS-Utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/MogileFS-Utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MogileFS-Utils/ChangeLog,v 1.13 2010/08/20 21:14:11 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MogileFS-Utils/ChangeLog,v 1.14 2010/10/29 02:03:50 robbat2 Exp $
+
+*MogileFS-Utils-2.18 (29 Oct 2010)
+
+ 29 Oct 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +MogileFS-Utils-2.18.ebuild:
+ Version bump via perl-bump experimental tool.
*MogileFS-Utils-2.17 (20 Aug 2010)
diff --git a/dev-perl/MogileFS-Utils/MogileFS-Utils-2.18.ebuild b/dev-perl/MogileFS-Utils/MogileFS-Utils-2.18.ebuild
new file mode 100644
index 000000000000..582a58baa71f
--- /dev/null
+++ b/dev-perl/MogileFS-Utils/MogileFS-Utils-2.18.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MogileFS-Utils/MogileFS-Utils-2.18.ebuild,v 1.1 2010/10/29 02:03:50 robbat2 Exp $
+
+MODULE_AUTHOR="DORMANDO"
+inherit perl-module
+
+DESCRIPTION="Server for the MogileFS distributed file system"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="virtual/perl-IO-Compress
+ dev-perl/libwww-perl
+ >=dev-perl/MogileFS-Client-1.11"
diff --git a/dev-perl/Net-Patricia/ChangeLog b/dev-perl/Net-Patricia/ChangeLog
index 4d4c2fb6d6c3..a1a487c41a25 100644
--- a/dev-perl/Net-Patricia/ChangeLog
+++ b/dev-perl/Net-Patricia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Net-Patricia
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/ChangeLog,v 1.20 2010/08/15 18:53:43 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/ChangeLog,v 1.21 2010/10/29 02:05:05 robbat2 Exp $
+
+*Net-Patricia-1.18 (29 Oct 2010)
+
+ 29 Oct 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +Net-Patricia-1.18.ebuild:
+ Version bump via perl-bump experimental tool.
15 Aug 2010; Torsten Veller <tove@gentoo.org> -Net-Patricia-1.014.ebuild,
-Net-Patricia-1.15.ebuild:
diff --git a/dev-perl/Net-Patricia/Net-Patricia-1.18.ebuild b/dev-perl/Net-Patricia/Net-Patricia-1.18.ebuild
new file mode 100644
index 000000000000..89c5c887909d
--- /dev/null
+++ b/dev-perl/Net-Patricia/Net-Patricia-1.18.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/Net-Patricia-1.18.ebuild,v 1.1 2010/10/29 02:05:03 robbat2 Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=PHILIPP
+inherit perl-module
+
+DESCRIPTION="Patricia Trie perl module for fast IP address lookups"
+
+LICENSE="|| ( GPL-2 GPL-3 )" # GPL-2+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+#SRC_TEST="do"
diff --git a/dev-perl/Net-Z3950-ZOOM/ChangeLog b/dev-perl/Net-Z3950-ZOOM/ChangeLog
index 9f3f308053ed..1e850152c8d8 100644
--- a/dev-perl/Net-Z3950-ZOOM/ChangeLog
+++ b/dev-perl/Net-Z3950-ZOOM/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Net-Z3950-ZOOM
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Z3950-ZOOM/ChangeLog,v 1.6 2010/08/15 18:54:51 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Z3950-ZOOM/ChangeLog,v 1.7 2010/10/29 02:06:06 robbat2 Exp $
+
+*Net-Z3950-ZOOM-1.28 (29 Oct 2010)
+
+ 29 Oct 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +Net-Z3950-ZOOM-1.28.ebuild:
+ Version bump via perl-bump experimental tool.
15 Aug 2010; Torsten Veller <tove@gentoo.org> -Net-Z3950-ZOOM-1.25.ebuild:
Cleanup
diff --git a/dev-perl/Net-Z3950-ZOOM/Net-Z3950-ZOOM-1.28.ebuild b/dev-perl/Net-Z3950-ZOOM/Net-Z3950-ZOOM-1.28.ebuild
new file mode 100644
index 000000000000..764cab7957bf
--- /dev/null
+++ b/dev-perl/Net-Z3950-ZOOM/Net-Z3950-ZOOM-1.28.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Z3950-ZOOM/Net-Z3950-ZOOM-1.28.ebuild,v 1.1 2010/10/29 02:06:06 robbat2 Exp $
+
+EAPI=3
+
+MODULE_AUTHOR="MIRK"
+inherit perl-module
+
+DESCRIPTION="Perl extension for invoking the ZOOM-C API"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/yaz-2.1.50"
+DEPEND="${RDEPEND}"
+
+#SRC_TEST=online