summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-07-16 07:10:12 +0000
committerTorsten Veller <tove@gentoo.org>2010-07-16 07:10:12 +0000
commit56f3a7a11cca9770eb46a2c5e5ea951600b4cc70 (patch)
tree892f84636a0497a7ecd944b093f121128934902d /dev-perl
parentVersion bump (finally works with cmake). (diff)
downloadhistorical-56f3a7a11cca9770eb46a2c5e5ea951600b4cc70.tar.gz
historical-56f3a7a11cca9770eb46a2c5e5ea951600b4cc70.tar.bz2
historical-56f3a7a11cca9770eb46a2c5e5ea951600b4cc70.zip
Version bump
Package-Manager: portage-2.2_rc67_p226/cvs/Linux x86_64
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Bio-Das/Bio-Das-1.17.ebuild24
-rw-r--r--dev-perl/Bio-Das/ChangeLog7
-rw-r--r--dev-perl/MooseX-ClassAttribute/ChangeLog8
-rw-r--r--dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.16.ebuild23
-rw-r--r--dev-perl/MooseX-Getopt/ChangeLog7
-rw-r--r--dev-perl/MooseX-Getopt/MooseX-Getopt-0.31.ebuild25
-rw-r--r--dev-perl/MooseX-StrictConstructor/ChangeLog10
-rw-r--r--dev-perl/MooseX-StrictConstructor/MooseX-StrictConstructor-0.09.ebuild21
8 files changed, 120 insertions, 5 deletions
diff --git a/dev-perl/Bio-Das/Bio-Das-1.17.ebuild b/dev-perl/Bio-Das/Bio-Das-1.17.ebuild
new file mode 100644
index 000000000000..d67e302ea683
--- /dev/null
+++ b/dev-perl/Bio-Das/Bio-Das-1.17.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Bio-Das/Bio-Das-1.17.ebuild,v 1.1 2010/07/16 06:58:56 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR="LDS"
+inherit perl-module
+
+DESCRIPTION="Interface to Distributed Annotation System"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/perl-IO-Compress-1.0
+ sci-biology/bioperl
+ >=dev-perl/HTML-Parser-3
+ >=dev-perl/libwww-perl-5
+ >=virtual/perl-MIME-Base64-2.12"
+RDEPEND="${DEPEND}"
+
+SRC_TEST=online
diff --git a/dev-perl/Bio-Das/ChangeLog b/dev-perl/Bio-Das/ChangeLog
index 002ac817067d..1b1766246239 100644
--- a/dev-perl/Bio-Das/ChangeLog
+++ b/dev-perl/Bio-Das/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Bio-Das
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Bio-Das/ChangeLog,v 1.27 2010/06/22 15:41:58 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Bio-Das/ChangeLog,v 1.28 2010/07/16 06:58:56 tove Exp $
+
+*Bio-Das-1.17 (16 Jul 2010)
+
+ 16 Jul 2010; Torsten Veller <tove@gentoo.org> +Bio-Das-1.17.ebuild:
+ Version bump
*Bio-Das-1.15 (22 Jun 2010)
diff --git a/dev-perl/MooseX-ClassAttribute/ChangeLog b/dev-perl/MooseX-ClassAttribute/ChangeLog
index 276917d93a12..57ff4706410a 100644
--- a/dev-perl/MooseX-ClassAttribute/ChangeLog
+++ b/dev-perl/MooseX-ClassAttribute/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/MooseX-ClassAttribute
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MooseX-ClassAttribute/ChangeLog,v 1.8 2010/04/09 07:45:31 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MooseX-ClassAttribute/ChangeLog,v 1.9 2010/07/16 07:10:12 tove Exp $
+
+*MooseX-ClassAttribute-0.16 (16 Jul 2010)
+
+ 16 Jul 2010; Torsten Veller <tove@gentoo.org>
+ +MooseX-ClassAttribute-0.16.ebuild:
+ Version bump
09 Apr 2010; Torsten Veller <tove@gentoo.org>
-MooseX-ClassAttribute-0.10.ebuild:
diff --git a/dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.16.ebuild b/dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.16.ebuild
new file mode 100644
index 000000000000..5a6dbc691a5a
--- /dev/null
+++ b/dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.16.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.16.ebuild,v 1.1 2010/07/16 07:10:12 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=DROLSKY
+inherit perl-module
+
+DESCRIPTION="Declare class attributes Moose-style"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Moose-0.98
+ dev-perl/namespace-autoclean"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.31
+ test? ( >=virtual/perl-Test-Simple-0.88 )"
+
+SRC_TEST=do
diff --git a/dev-perl/MooseX-Getopt/ChangeLog b/dev-perl/MooseX-Getopt/ChangeLog
index af3da2c6edbe..dd087c43468e 100644
--- a/dev-perl/MooseX-Getopt/ChangeLog
+++ b/dev-perl/MooseX-Getopt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/MooseX-Getopt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MooseX-Getopt/ChangeLog,v 1.16 2010/06/16 07:31:45 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MooseX-Getopt/ChangeLog,v 1.17 2010/07/16 07:03:35 tove Exp $
+
+*MooseX-Getopt-0.31 (16 Jul 2010)
+
+ 16 Jul 2010; Torsten Veller <tove@gentoo.org> +MooseX-Getopt-0.31.ebuild:
+ Version bump
*MooseX-Getopt-0.29 (16 Jun 2010)
diff --git a/dev-perl/MooseX-Getopt/MooseX-Getopt-0.31.ebuild b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.31.ebuild
new file mode 100644
index 000000000000..4a0945ddd97e
--- /dev/null
+++ b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.31.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MooseX-Getopt/MooseX-Getopt-0.31.ebuild,v 1.1 2010/07/16 07:03:35 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=BOBTFISH
+inherit perl-module
+
+DESCRIPTION="A Moose role for processing command line options"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Moose-0.56
+ >=dev-perl/Getopt-Long-Descriptive-0.081
+ >=virtual/perl-Getopt-Long-2.37"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.31
+ test? ( >=dev-perl/Test-Exception-0.21
+ >=virtual/perl-Test-Simple-0.62
+ >=dev-perl/Test-Warn-0.21 )"
+
+SRC_TEST=do
diff --git a/dev-perl/MooseX-StrictConstructor/ChangeLog b/dev-perl/MooseX-StrictConstructor/ChangeLog
index 5a96b958ff7a..b30df8862901 100644
--- a/dev-perl/MooseX-StrictConstructor/ChangeLog
+++ b/dev-perl/MooseX-StrictConstructor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/MooseX-StrictConstructor
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MooseX-StrictConstructor/ChangeLog,v 1.4 2009/05/01 22:48:24 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MooseX-StrictConstructor/ChangeLog,v 1.5 2010/07/16 07:06:56 tove Exp $
+
+*MooseX-StrictConstructor-0.09 (16 Jul 2010)
+
+ 16 Jul 2010; Torsten Veller <tove@gentoo.org>
+ +MooseX-StrictConstructor-0.09.ebuild:
+ Version bump
01 May 2009; Torsten Veller <tove@gentoo.org>
-MooseX-StrictConstructor-0.07.ebuild:
diff --git a/dev-perl/MooseX-StrictConstructor/MooseX-StrictConstructor-0.09.ebuild b/dev-perl/MooseX-StrictConstructor/MooseX-StrictConstructor-0.09.ebuild
new file mode 100644
index 000000000000..e87975eca3ed
--- /dev/null
+++ b/dev-perl/MooseX-StrictConstructor/MooseX-StrictConstructor-0.09.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MooseX-StrictConstructor/MooseX-StrictConstructor-0.09.ebuild,v 1.1 2010/07/16 07:06:56 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=DROLSKY
+inherit perl-module
+
+DESCRIPTION="Make your object constructors blow up on unknown attributes"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/Moose-0.94"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.31"
+
+SRC_TEST=do