summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-06-01 12:51:10 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-06-01 12:51:10 +0000
commit5cb1e4124a87432b2dfecc1b9dd0df2d2191f9d5 (patch)
treebe62074b21514c5188b79fffb4a8e652c9ad12fe /dev-perl/libwww-perl/libwww-perl-5.803-r1.ebuild
parentStable on x86. (diff)
downloadhistorical-5cb1e4124a87432b2dfecc1b9dd0df2d2191f9d5.tar.gz
historical-5cb1e4124a87432b2dfecc1b9dd0df2d2191f9d5.tar.bz2
historical-5cb1e4124a87432b2dfecc1b9dd0df2d2191f9d5.zip
libwww no longer provides copies of GET, HEAD, and POST but instead attempts to create symlinks. Thanks to Gregg Casillo for noticing this.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-perl/libwww-perl/libwww-perl-5.803-r1.ebuild')
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.803-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/libwww-perl/libwww-perl-5.803-r1.ebuild b/dev-perl/libwww-perl/libwww-perl-5.803-r1.ebuild
new file mode 100644
index 000000000000..d62d033b080c
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.803-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.803-r1.ebuild,v 1.1 2005/06/01 12:51:10 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+SRC_URI="mirror://cpan/authors/id/G/GA/GAAS/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~gaas/${P}/"
+IUSE="ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-perl/libnet-1.16
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=perl-core/Digest-MD5-2.12
+ >=perl-core/MIME-Base64-2.12
+ dev-perl/Compress-Zlib
+ ssl? ( dev-perl/Crypt-SSLeay )"
+
+src_compile() {
+ echo "y" | perl-module_src_compile
+}
+
+src_install() {
+ perl-module_src_install
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+}