summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-16 17:14:40 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-16 17:14:40 +0000
commit2cc975fb226aade3c4534f4bf4827305acc9c3a2 (patch)
treea2727631cba0d0b4f2f28b5eee2c098fef948bbf /dev-perl/XML-LibXSLT
parentdigest file (diff)
downloadhistorical-2cc975fb226aade3c4534f4bf4827305acc9c3a2.tar.gz
historical-2cc975fb226aade3c4534f4bf4827305acc9c3a2.tar.bz2
historical-2cc975fb226aade3c4534f4bf4827305acc9c3a2.zip
*** empty log message ***
Diffstat (limited to 'dev-perl/XML-LibXSLT')
-rw-r--r--dev-perl/XML-LibXSLT/XML-LibXSLT-0.95.ebuild43
-rw-r--r--dev-perl/XML-LibXSLT/files/XML-LibXSLT-0.95-LibXML.xs-gentoo.diff38
-rw-r--r--dev-perl/XML-LibXSLT/files/digest-XML-LibXSLT-0.951
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-perl/XML-LibXSLT/XML-LibXSLT-0.95.ebuild b/dev-perl/XML-LibXSLT/XML-LibXSLT-0.95.ebuild
new file mode 100644
index 000000000000..b8603b6d471a
--- /dev/null
+++ b/dev-perl/XML-LibXSLT/XML-LibXSLT-0.95.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXSLT/XML-LibXSLT-0.95.ebuild,v 1.1 2001/03/16 17:13:26 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
+SRC_URI="http://cpan.valueclick.com/modules/by-category/11_String_Lang_Text_Proc/XML/${A}"
+HOMEPAGE="http://cpan.valueclick.com/modules/by-category/11_String_Lang_Text_Proc/XML/${P}.readme"
+
+DEPEND=">=sys-devel/perl-5
+ >=gnome-libs/libxslt-0.5
+ >=dev-perl/libwww-perl-5.48"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-LibXML.xs-gentoo.diff
+}
+
+src_compile() {
+
+ perl Makefile.PL
+ try make
+ try make test
+}
+
+src_install () {
+
+ try make PREFIX=${D}/usr install
+ dodoc MANIFEST README
+
+}
+
+
+
+
+
+
+
+
+
diff --git a/dev-perl/XML-LibXSLT/files/XML-LibXSLT-0.95-LibXML.xs-gentoo.diff b/dev-perl/XML-LibXSLT/files/XML-LibXSLT-0.95-LibXML.xs-gentoo.diff
new file mode 100644
index 000000000000..49693bdc47d6
--- /dev/null
+++ b/dev-perl/XML-LibXSLT/files/XML-LibXSLT-0.95-LibXML.xs-gentoo.diff
@@ -0,0 +1,38 @@
+--- XML-LibXML/LibXML.xs.orig Fri Mar 16 19:03:54 2001
++++ XML-LibXML/LibXML.xs Fri Mar 16 19:04:14 2001
+@@ -333,7 +333,7 @@
+ }
+
+ xmlParserCtxtPtr
+-get_context(SV * self)
++get_context2(SV * self)
+ {
+ SV ** ctxt_sv;
+ ctxt_sv = hv_fetch((HV *)SvRV(self), "_context", 8, 0);
+@@ -363,7 +363,7 @@
+ tbuff = newSV(0);
+ tsize = newSViv(BUFSIZE);
+
+- ctxt = get_context(self);
++ ctxt = get_context2(self);
+
+ while (!done) {
+ int cnt;
+@@ -599,7 +599,7 @@
+ int well_formed;
+ CODE:
+ ptr = SvPV(string, len);
+- ctxt = get_context(self);
++ ctxt = get_context2(self);
+ xmlParseChunk(ctxt, ptr, len, 0);
+ xmlParseChunk(ctxt, ptr, 0, 1);
+ well_formed = ctxt->wellFormed;
+@@ -644,7 +644,7 @@
+ f = PerlIO_open(filename, "r");
+ }
+ if (f != NULL) {
+- ctxt = get_context(self);
++ ctxt = get_context2(self);
+ res = PerlIO_read(f, chars, 4);
+ if (res > 0) {
+ xmlParseChunk(ctxt, chars, res, 0);
diff --git a/dev-perl/XML-LibXSLT/files/digest-XML-LibXSLT-0.95 b/dev-perl/XML-LibXSLT/files/digest-XML-LibXSLT-0.95
new file mode 100644
index 000000000000..0ddede444cdb
--- /dev/null
+++ b/dev-perl/XML-LibXSLT/files/digest-XML-LibXSLT-0.95
@@ -0,0 +1 @@
+MD5 460e2c1fc82fc62ae825d127d0730acb XML-LibXSLT-0.95.tar.gz