summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-04-15 06:41:26 +0000
committerTorsten Veller <tove@gentoo.org>2010-04-15 06:41:26 +0000
commit096d72a39834bde26cd231e1f1f4bec863e666fe (patch)
tree1127f9c649cc45adb94036a5bd060f1cca715ebd /dev-perl/WWW-Mechanize
parentVersion bump (diff)
downloadhistorical-096d72a39834bde26cd231e1f1f4bec863e666fe.tar.gz
historical-096d72a39834bde26cd231e1f1f4bec863e666fe.tar.bz2
historical-096d72a39834bde26cd231e1f1f4bec863e666fe.zip
Version bump
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/WWW-Mechanize')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog7
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.62.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index fee39afa6302..fc883ea2f7bc 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/WWW-Mechanize
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.68 2010/01/14 16:21:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.69 2010/04/15 06:40:57 tove Exp $
+
+*WWW-Mechanize-1.62 (15 Apr 2010)
+
+ 15 Apr 2010; Torsten Veller <tove@gentoo.org> +WWW-Mechanize-1.62.ebuild:
+ Version bump
14 Jan 2010; Fabian Groffen <grobian@gentoo.org>
WWW-Mechanize-1.60.ebuild:
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.62.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.62.ebuild
new file mode 100644
index 000000000000..775b0d092fd5
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.62.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.62.ebuild,v 1.1 2010/04/15 06:40:57 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=PETDANCE
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+# Bug in the tests - improper use of HTTP::Server
+SRC_TEST="do"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+RDEPEND="dev-perl/IO-Socket-SSL
+ >=dev-perl/libwww-perl-5.829
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/Test-LongString"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle )"
+# dev-perl/HTTP-Server-Simple )"
+
+# Remove test until the bug is fixed:
+# http://rt.cpan.org/Public/Bug/Display.html?id=41673
+src_prepare() {
+ mv "${S}"/t/cookies.t{,.disable} || die
+ sed -i "/cookies.t/d" "${S}/MANIFEST" || die
+ perl-module_src_prepare
+}