summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-01-16 20:56:43 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-01-16 20:56:43 +0000
commit96d6bff1527ed51f7c293edf1096d810b3b4a58c (patch)
tree33f5f354c6b0103e32cad41a99e0e34a913e344e /dev-perl/PDL
parentStable on sparc (diff)
downloadhistorical-96d6bff1527ed51f7c293edf1096d810b3b4a58c.tar.gz
historical-96d6bff1527ed51f7c293edf1096d810b3b4a58c.tar.bz2
historical-96d6bff1527ed51f7c293edf1096d810b3b4a58c.zip
Bug 107375, added badval support
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/ChangeLog7
-rw-r--r--dev-perl/PDL/Manifest10
-rw-r--r--dev-perl/PDL/PDL-2.4.2.ebuild12
3 files changed, 24 insertions, 5 deletions
diff --git a/dev-perl/PDL/ChangeLog b/dev-perl/PDL/ChangeLog
index 7b168bb01ac4..8b047fde3b19 100644
--- a/dev-perl/PDL/ChangeLog
+++ b/dev-perl/PDL/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-perl/PDL
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.44 2005/12/29 18:17:36 mcummings Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.45 2006/01/16 20:56:43 mcummings Exp $
+
+ 16 Jan 2006; Michael Cummings <mcummings@gentoo.org> PDL-2.4.2.ebuild:
+ Bug 107375, added badval support
29 Dec 2005; <mcumming@gentoo.org> PDL-2.4.0-r2.ebuild, PDL-2.4.2.ebuild:
Updating dep to perl-core/Filter
diff --git a/dev-perl/PDL/Manifest b/dev-perl/PDL/Manifest
index 6ef40592ffdd..2081a84bbb18 100644
--- a/dev-perl/PDL/Manifest
+++ b/dev-perl/PDL/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 1d5b99daea310c4c1fb6e4e8629cab5f ChangeLog 5740
MD5 1649e9d7c3239cdd2b6625f880f2be7f PDL-2.4.0-r2.ebuild 2100
MD5 0638df8582a977fdf0e92ab0e7584d82 PDL-2.4.2.ebuild 2518
@@ -6,3 +9,10 @@ MD5 ec437e93538a4c2ac25d8618f51ddc86 files/digest-PDL-2.4.2 62
MD5 5c22c0f59ad10f36608505d621618f2b files/gsl.patch 483
MD5 62cbe79e2c7c354d5c165b63c571cc13 files/perldl.conf 2716
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFDzAiTtG5z4I8BtQoRAlmvAJ9D/7M3Q44/2CR9uynQ/exHWzmPhQCZAfs4
+jlDFQyxULv6aPZIxcKPns5Q=
+=I9H3
+-----END PGP SIGNATURE-----
diff --git a/dev-perl/PDL/PDL-2.4.2.ebuild b/dev-perl/PDL/PDL-2.4.2.ebuild
index 9902e445e1bf..f64d0759d0ae 100644
--- a/dev-perl/PDL/PDL-2.4.2.ebuild
+++ b/dev-perl/PDL/PDL-2.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.2.ebuild,v 1.9 2005/12/29 18:17:36 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.2.ebuild,v 1.10 2006/01/16 20:56:43 mcummings Exp $
inherit perl-module eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://cpan/authors/id/C/CS/CSOE/${P}.tar.gz"
LICENSE="Artistic as-is"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc sparc x86"
-IUSE="opengl"
+IUSE="opengl badval"
DEPEND=">=sys-libs/ncurses-5.2
perl-core/Filter
@@ -43,6 +43,12 @@ src_unpack() {
${FILESDIR}/perldl.conf > ${S}/perldl.conf
fi
+ if use badval ; then
+ sed -i -e "s:WITH_BADVAL => 0:WITH_BADVAL => 1:" \
+ ${S}/perldl.conf
+ fi
+
+
# Unconditional -fPIC for the lib (#55238)
sed -i -e "s/mycompiler -c -o/mycompiler -fPIC -c -o/" ${S}/Lib/Slatec/Makefile.PL
}