summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-08 02:43:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-08 02:43:05 +0000
commitc87ad59dcaa7a2176881f7dce9ac073f4448b322 (patch)
tree156cc2b5fa520ad4e463659cb2f73f029cc74a69 /dev-perl/HTML-Mason
parentRemoving wltjr as a maintainer since he was retired. (diff)
downloadhistorical-c87ad59dcaa7a2176881f7dce9ac073f4448b322.tar.gz
historical-c87ad59dcaa7a2176881f7dce9ac073f4448b322.tar.bz2
historical-c87ad59dcaa7a2176881f7dce9ac073f4448b322.zip
Version bump.
Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog8
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.40.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index 6c56d33d374f..b2e77bf95e3c 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.82 2008/11/18 15:04:48 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.83 2008/12/08 02:20:22 robbat2 Exp $
+
+*HTML-Mason-1.40 (08 Dec 2008)
+
+ 08 Dec 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +HTML-Mason-1.40.ebuild:
+ Version bump.
18 Nov 2008; Torsten Veller <tove@gentoo.org> HTML-Mason-1.37.ebuild:
New virtuals: module-build
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.40.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.40.ebuild
new file mode 100644
index 000000000000..61fda9aabbad
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.40.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.40.ebuild,v 1.1 2008/12/08 02:20:22 robbat2 Exp $
+
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+SRC_URI="mirror://cpan/authors/id/D/DR/DROLSKY/${P}.tar.gz"
+HOMEPAGE="http://www.masonhq.com/"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="modperl doc"
+SRC_TEST="do"
+
+RDEPEND="!modperl? ( virtual/perl-CGI )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Params-Validate-0.7
+ >=virtual/perl-Module-Build-0.28
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ dev-perl/HTML-Parser
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01
+ dev-lang/perl"
+
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build"
+
+want_apache2 modperl
+
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+perl-module_src_prep() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ sleep 5
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ APACHE="${APACHE_BIN}" perl ${S}/Build.PL installdirs=vendor destdir=${D} ${myconf}
+}
+
+src_install () {
+ perl-module_src_install
+ # rendhalver - the html docs have subdirs so this gets all of them
+ use doc && dohtml -r htdocs/*
+}