summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-01-27 03:32:57 +0000
committerDonny Davies <woodchip@gentoo.org>2002-01-27 03:32:57 +0000
commit40159500baccbeb5dd8c407df5418849939d7018 (patch)
treec2a1e6c14570f6af0ba376ac957b31cd67472c27 /dev-perl/Crypt-Blowfish
parentremoving another glide. Should be added to the xfree build. (diff)
downloadhistorical-40159500baccbeb5dd8c407df5418849939d7018.tar.gz
historical-40159500baccbeb5dd8c407df5418849939d7018.tar.bz2
historical-40159500baccbeb5dd8c407df5418849939d7018.zip
initial checkin
Diffstat (limited to 'dev-perl/Crypt-Blowfish')
-rw-r--r--dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.09.ebuild30
-rw-r--r--dev-perl/Crypt-Blowfish/files/digest-Crypt-Blowfish-2.091
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.09.ebuild b/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.09.ebuild
new file mode 100644
index 000000000000..e3d1896d1138
--- /dev/null
+++ b/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.09.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.09.ebuild,v 1.1 2002/01/27 03:27:03 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Crypt::Blowfish module for perl"
+SRC_URI="http://www.cpan.org/authors/id/D/DP/DPARIS/${P}.tar.gz"
+DEPEND="virtual/glibc >=sys-devel/perl-5"
+
+src_compile() {
+
+ OPTIMIZE="$CFLAGS" perl Makefile.PL
+ make || die
+}
+
+src_install () {
+
+ eval `perl '-V:installarchlib'`
+ mkdir -p ${D}/$installarchlib
+
+ perl Makefile.PL
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+
+ dodoc ChangeLog MANIFEST README ToDo
+}
diff --git a/dev-perl/Crypt-Blowfish/files/digest-Crypt-Blowfish-2.09 b/dev-perl/Crypt-Blowfish/files/digest-Crypt-Blowfish-2.09
new file mode 100644
index 000000000000..61d5af22f315
--- /dev/null
+++ b/dev-perl/Crypt-Blowfish/files/digest-Crypt-Blowfish-2.09
@@ -0,0 +1 @@
+MD5 bbd037e1eb20778f3d636dff345ed02f Crypt-Blowfish-2.09.tar.gz 20480