summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-02-06 12:51:23 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-02-06 12:51:23 +0000
commite60b6597f0724dfccc853905bc16beb4271344d5 (patch)
tree52e8161fdfb990f05432622a4fce9f871d1e33f4 /dev-perl/BSD-Resource
parentRemoved old versions. (diff)
downloadhistorical-e60b6597f0724dfccc853905bc16beb4271344d5.tar.gz
historical-e60b6597f0724dfccc853905bc16beb4271344d5.tar.bz2
historical-e60b6597f0724dfccc853905bc16beb4271344d5.zip
Bug 79329
Package-Manager: portage-2.0.51-r13
Diffstat (limited to 'dev-perl/BSD-Resource')
-rw-r--r--dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild10
-rw-r--r--dev-perl/BSD-Resource/ChangeLog11
-rw-r--r--dev-perl/BSD-Resource/Manifest11
-rw-r--r--dev-perl/BSD-Resource/files/portage_niceness.patch16
4 files changed, 40 insertions, 8 deletions
diff --git a/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild b/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild
index 3739115d3768..44318d21eced 100644
--- a/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild
+++ b/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild,v 1.7 2005/01/22 12:53:19 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/BSD-Resource/BSD-Resource-1.24.ebuild,v 1.8 2005/02/06 12:51:23 mcummings Exp $
-inherit perl-module
+inherit perl-module eutils
CATEGORY="dev-perl"
DESCRIPTION="Perl module for BSD process resource limit and priority functions"
@@ -14,3 +14,9 @@ SLOT="0"
KEYWORDS="x86 ~amd64 ~ppc sparc alpha"
IUSE=""
SRC_TEST="do"
+src_unpack(){
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/portage_niceness.patch
+}
+
diff --git a/dev-perl/BSD-Resource/ChangeLog b/dev-perl/BSD-Resource/ChangeLog
index 63d0851e5baa..9e8fe33d931c 100644
--- a/dev-perl/BSD-Resource/ChangeLog
+++ b/dev-perl/BSD-Resource/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-perl/BSD-Resource
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/BSD-Resource/ChangeLog,v 1.10 2005/01/22 12:53:19 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/BSD-Resource/ChangeLog,v 1.11 2005/02/06 12:51:23 mcummings Exp $
+
+ 06 Feb 2005; Michael Cummings <mcummings@gentoo.org>
+ +files/portage_niceness.patch, BSD-Resource-1.24.ebuild:
+ This update is to include a patch to deal with users employing the
+ PORTAGE_NICENESS variable. The getpriority tests that the module uses assume
+ that there is a priority of 0 for these tests - but if you've used niceness,
+ then that isn't the case and they will fail. Instead, we leave the old
+ values and adjust them to the niceness level if PORTAGE_NICENESS has been
+ set. Bug 79329.
22 Jan 2005; Gustavo Zacarias <gustavoz@gentoo.org>
BSD-Resource-1.24.ebuild:
diff --git a/dev-perl/BSD-Resource/Manifest b/dev-perl/BSD-Resource/Manifest
index a518fe9f718a..bd81eb99c1db 100644
--- a/dev-perl/BSD-Resource/Manifest
+++ b/dev-perl/BSD-Resource/Manifest
@@ -2,15 +2,16 @@
Hash: SHA1
MD5 a7bcbaac7dae0b74bdaea5a7c7091fc2 BSD-Resource-1.23.ebuild 570
-MD5 2296595f4df5d7ebdb008e61cadf3ca6 BSD-Resource-1.24.ebuild 576
-MD5 30f504225f70c96c21a0c3bbabd5eeb5 ChangeLog 1427
+MD5 fe7cd3e1a132da2c5debbaf12f7abcdb BSD-Resource-1.24.ebuild 666
+MD5 ac0dd99cf0b00bacd23a5a15228fab46 ChangeLog 1937
MD5 0a0f6e1776ef2c772bd38d1e1587b010 metadata.xml 309
MD5 0864dc089d8956d37dabee38530d7ad5 files/digest-BSD-Resource-1.23 68
MD5 7c0143f2a1de9325985efd9311baa470 files/digest-BSD-Resource-1.24 68
+MD5 53281413b2c669afae5d401d892c4693 files/portage_niceness.patch 479
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFB8kzKKRy60XGEcJIRAkPeAJ4iH19kGrM7o56f/n2TCkJSAj4FrwCcDS0p
-anTfPertJ+BOgsU99WQY0Zo=
-=c/Lx
+iD8DBQFCBhJttG5z4I8BtQoRAnF4AJ9SEOA+g8r4FwkRKg5/QHFxxuJj+gCcDRxl
+suNZ2vHCdQZAwhLsEjrc/FA=
+=xQ8J
-----END PGP SIGNATURE-----
diff --git a/dev-perl/BSD-Resource/files/portage_niceness.patch b/dev-perl/BSD-Resource/files/portage_niceness.patch
new file mode 100644
index 000000000000..c85836c9c09b
--- /dev/null
+++ b/dev-perl/BSD-Resource/files/portage_niceness.patch
@@ -0,0 +1,16 @@
+--- t/getpriority.t 1997-04-08 02:54:17.000000000 -0400
++++ t/getpriority.t.new 2005-02-06 07:37:07.092780984 -0500
+@@ -12,6 +12,13 @@
+
+ # AIX without BSD libs has 0..39 priorities, not -20..20.
+ $okpriopat = $Config{'osname'} eq 'aix' ? '0|19' : '0';
++my $priority = 0;
++if (defined($ENV{'PORTAGE_NICENESS'})) {
++ $priority = int($ENV{'PORTAGE_NICENESS'})
++} else {
++ $priority = 19
++}
++$okpriopat = defined($priority) ? "0|$priority" : '0';
+
+ $okpriopat = "^($okpriopat)";
+