summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-12 07:09:11 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-12 07:09:11 +0000
commit23e2038e7e77e5774576883c547b77818c378687 (patch)
treecf7783c9e4f057cf1e3732d05b64da3ff9717e77 /dev-ml
parentupdate homepage (diff)
downloadhistorical-23e2038e7e77e5774576883c547b77818c378687.tar.gz
historical-23e2038e7e77e5774576883c547b77818c378687.tar.bz2
historical-23e2038e7e77e5774576883c547b77818c378687.zip
version bump
Package-Manager: portage-2.1.5_rc10
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ulex/ChangeLog7
-rw-r--r--dev-ml/ulex/ulex-1.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/ulex/ChangeLog b/dev-ml/ulex/ChangeLog
index b54757d60a92..c1d5e534df5d 100644
--- a/dev-ml/ulex/ChangeLog
+++ b/dev-ml/ulex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ulex
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ulex/ChangeLog,v 1.14 2008/04/09 07:34:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ulex/ChangeLog,v 1.15 2008/05/12 07:09:10 aballier Exp $
+
+*ulex-1.1 (12 May 2008)
+
+ 12 May 2008; Alexis Ballier <aballier@gentoo.org> +ulex-1.1.ebuild:
+ version bump
09 Apr 2008; Alexis Ballier <aballier@gentoo.org> -ulex-0.4.ebuild,
-ulex-0.5.ebuild:
diff --git a/dev-ml/ulex/ulex-1.1.ebuild b/dev-ml/ulex/ulex-1.1.ebuild
new file mode 100644
index 000000000000..0673677d43e5
--- /dev/null
+++ b/dev-ml/ulex/ulex-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ulex/ulex-1.1.ebuild,v 1.1 2008/05/12 07:09:11 aballier Exp $
+
+inherit eutils findlib
+
+EAPI="1"
+
+DESCRIPTION="A lexer generator for unicode"
+HOMEPAGE="http://www.cduce.org"
+SRC_URI="http://www.cduce.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10.0"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ emake all || die "failed to build bytecode"
+ if use ocamlopt; then
+ emake all.opt || die "failed to build native code"
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README CHANGES
+}