summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-06-30 14:49:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-06-30 14:49:17 +0000
commit20a2fc39be16f1222d653f43c2e968d54a865bd4 (patch)
tree5ecf24c9b6c57b02668447d9091d4025d56aef54 /dev-ml
parentmask pipebang (diff)
downloadhistorical-20a2fc39be16f1222d653f43c2e968d54a865bd4.tar.gz
historical-20a2fc39be16f1222d653f43c2e968d54a865bd4.tar.bz2
historical-20a2fc39be16f1222d653f43c2e968d54a865bd4.zip
initial import, ebuild by me
Package-Manager: portage-2.2.0_alpha114/cvs/Linux x86_64
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pipebang/ChangeLog10
-rw-r--r--dev-ml/pipebang/metadata.xml5
-rw-r--r--dev-ml/pipebang/pipebang-108.00.01.ebuild19
-rw-r--r--dev-ml/variantslib/ChangeLog10
-rw-r--r--dev-ml/variantslib/metadata.xml5
-rw-r--r--dev-ml/variantslib/variantslib-108.00.01.ebuild23
6 files changed, 72 insertions, 0 deletions
diff --git a/dev-ml/pipebang/ChangeLog b/dev-ml/pipebang/ChangeLog
new file mode 100644
index 000000000000..dc2e45bce3b4
--- /dev/null
+++ b/dev-ml/pipebang/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/pipebang
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pipebang/ChangeLog,v 1.1 2012/06/30 14:49:17 aballier Exp $
+
+*pipebang-108.00.01 (30 Jun 2012)
+
+ 30 Jun 2012; Alexis Ballier <aballier@gentoo.org> +pipebang-108.00.01.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/dev-ml/pipebang/metadata.xml b/dev-ml/pipebang/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/pipebang/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/pipebang/pipebang-108.00.01.ebuild b/dev-ml/pipebang/pipebang-108.00.01.ebuild
new file mode 100644
index 000000000000..97560aba4253
--- /dev/null
+++ b/dev-ml/pipebang/pipebang-108.00.01.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pipebang/pipebang-108.00.01.ebuild,v 1.1 2012/06/30 14:49:17 aballier Exp $
+
+EAPI="4"
+
+inherit oasis
+
+DESCRIPTION="Syntax extension to transform x |! f into f x"
+HOMEPAGE="http://bitbucket.org/yminsky/ocaml-core/wiki/Home"
+SRC_URI="http://bitbucket.org/yminsky/ocaml-core/downloads/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-3.0.5"
+RDEPEND="${DEPEND}"
diff --git a/dev-ml/variantslib/ChangeLog b/dev-ml/variantslib/ChangeLog
new file mode 100644
index 000000000000..142da84960f6
--- /dev/null
+++ b/dev-ml/variantslib/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/variantslib
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/variantslib/ChangeLog,v 1.1 2012/06/30 14:44:29 aballier Exp $
+
+*variantslib-108.00.01 (30 Jun 2012)
+
+ 30 Jun 2012; Alexis Ballier <aballier@gentoo.org>
+ +variantslib-108.00.01.ebuild, +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/dev-ml/variantslib/metadata.xml b/dev-ml/variantslib/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/variantslib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/variantslib/variantslib-108.00.01.ebuild b/dev-ml/variantslib/variantslib-108.00.01.ebuild
new file mode 100644
index 000000000000..8a47ace1c69e
--- /dev/null
+++ b/dev-ml/variantslib/variantslib-108.00.01.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/variantslib/variantslib-108.00.01.ebuild,v 1.1 2012/06/30 14:44:29 aballier Exp $
+
+EAPI="4"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml variants as first class values"
+HOMEPAGE="http://bitbucket.org/yminsky/ocaml-core/wiki/Home"
+SRC_URI="http://bitbucket.org/yminsky/ocaml-core/downloads/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-3.0.5"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README" )