summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:54:47 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:54:47 +0000
commitf64df7559351f5ed153c74f4b53274e97659bb69 (patch)
tree93e4faf76267607b95f9f5cd7d3f9f11fcf86696 /dev-ml/camlidl
parentShorten DESCRIPTION to under 100 characters in order to make repoman happy. (diff)
downloadhistorical-f64df7559351f5ed153c74f4b53274e97659bb69.tar.gz
historical-f64df7559351f5ed153c74f4b53274e97659bb69.tar.bz2
historical-f64df7559351f5ed153c74f4b53274e97659bb69.zip
Migrate to EAPI 2 in order to nuke built_with_use.
Package-Manager: portage-2.2_rc40/cvs/Linux i686
Diffstat (limited to 'dev-ml/camlidl')
-rw-r--r--dev-ml/camlidl/ChangeLog5
-rw-r--r--dev-ml/camlidl/camlidl-1.05.ebuild21
2 files changed, 10 insertions, 16 deletions
diff --git a/dev-ml/camlidl/ChangeLog b/dev-ml/camlidl/ChangeLog
index 5c85f7fa7997..fcfa39ed612f 100644
--- a/dev-ml/camlidl/ChangeLog
+++ b/dev-ml/camlidl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/camlidl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/ChangeLog,v 1.4 2009/04/15 04:55:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/ChangeLog,v 1.5 2009/09/28 16:45:42 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> camlidl-1.05.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
15 Apr 2009; Alexis Ballier <aballier@gentoo.org> +files/includes.patch,
+files/tests.patch, camlidl-1.05.ebuild:
diff --git a/dev-ml/camlidl/camlidl-1.05.ebuild b/dev-ml/camlidl/camlidl-1.05.ebuild
index f11cbf52094b..970a6aa4266a 100644
--- a/dev-ml/camlidl/camlidl-1.05.ebuild
+++ b/dev-ml/camlidl/camlidl-1.05.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/camlidl-1.05.ebuild,v 1.3 2009/04/15 04:55:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/camlidl-1.05.ebuild,v 1.4 2009/09/28 16:45:42 betelgeuse Exp $
+
+EAPI="2"
inherit eutils toolchain-funcs
@@ -11,20 +13,9 @@ LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
IUSE=""
-DEPEND=">=dev-lang/ocaml-3.07"
-
-pkg_setup() {
- if ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "${PN} needs to be built with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/tests.patch"
epatch "${FILESDIR}/includes.patch"
}
@@ -54,5 +45,5 @@ src_install() {
emake BINDIR="${D}/usr/bin" OCAMLLIB="${D}${libdir}" install || die
# Documentation
- dodoc README Changes
+ dodoc README Changes || die
}