summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-12-08 17:54:14 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-12-08 17:54:14 +0000
commit9e4c702dda3d8568dd97e84c72ec109b8649cc6c (patch)
treec9c5259c1fe75126129ccb61eab5f76d759e8a6c /dev-lisp
parentAdjusted RDEPEND to depend on emul-linux-x86-java to enable java functionalit... (diff)
downloadhistorical-9e4c702dda3d8568dd97e84c72ec109b8649cc6c.tar.gz
historical-9e4c702dda3d8568dd97e84c72ec109b8649cc6c.tar.bz2
historical-9e4c702dda3d8568dd97e84c72ec109b8649cc6c.zip
New upstream version.
Package-Manager: portage-2.0.53
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest10
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.8.8.ebuild39
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.81
4 files changed, 52 insertions, 5 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index 2e8e5687a2a7..76c4766acffd 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.21 2005/12/01 03:45:27 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.22 2005/12/08 17:54:14 mkennedy Exp $
+
+*cl-tbnl-0.8.8 (08 Dec 2005)
+
+ 08 Dec 2005; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.8.8.ebuild:
+ New upstream version.
*cl-tbnl-0.8.7 (01 Dec 2005)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index 0e68c7d15dac..cca41721b00c 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,14 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 f5882a2a4dba5c5dc450f331017ee399 ChangeLog 3722
+MD5 f4359c04a62dfa24413fb0b03e5fa3bc ChangeLog 3853
MD5 38e71c4087443d86aec430c6236160e9 cl-tbnl-0.8.7.ebuild 1012
+MD5 eff85ae53f12c38626978e8ca170de0a cl-tbnl-0.8.8.ebuild 1012
MD5 e68a684df62d4199e136f123b586678b files/digest-cl-tbnl-0.8.7 66
+MD5 4c0c8cd27248e534fb9166f203b056f2 files/digest-cl-tbnl-0.8.8 66
MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDjnHkyiNZaEAZA+ARAgyOAJ0Xn83PTZsIIKsB8WPhTGx7Xzd6mACfd7nM
-N11r5kcnC2BWxrFJht3q4Vw=
-=498N
+iD8DBQFDmHN7yiNZaEAZA+ARAh8jAJ9kQRCAPcnqwTcfqcJvtJfwU5ksqwCdFUaW
+cd/NE9cwNM9bW+8M9i81QzA=
+=HBet
-----END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.8.8.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.8.8.ebuild
new file mode 100644
index 000000000000..4141d9fe8d34
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.8.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.8.8.ebuild,v 1.1 2005/12/08 17:54:14 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="standalone"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+# RDEPEND="${DEPEND}
+# apache2? ( www-apache/mod_lisp2 ) !apache2? ( www-apache/mod_lisp )"
+
+RDEPEND="${DEPEND}
+ !standalone? ( www-apache/mod_lisp )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/
+ doins -r test contrib
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.8 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.8
new file mode 100644
index 000000000000..2f458f20eb4f
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.8
@@ -0,0 +1 @@
+MD5 e74fae9a09f80cf527b8bbff3efdfa61 tbnl_0.8.8.orig.tar.gz 87150