summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-04-25 02:19:41 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-04-25 02:19:41 +0000
commit96e34216686eb0a29f7469059024324fd8a2173d (patch)
treeaa43233580b76f30f78e37d445e826fd733dab46 /dev-lisp/cl-yacc
parentremoving old ebuilds (diff)
downloadhistorical-96e34216686eb0a29f7469059024324fd8a2173d.tar.gz
historical-96e34216686eb0a29f7469059024324fd8a2173d.tar.bz2
historical-96e34216686eb0a29f7469059024324fd8a2173d.zip
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-lisp/cl-yacc')
-rw-r--r--dev-lisp/cl-yacc/ChangeLog10
-rw-r--r--dev-lisp/cl-yacc/Manifest4
-rw-r--r--dev-lisp/cl-yacc/cl-yacc-0.1.ebuild32
-rw-r--r--dev-lisp/cl-yacc/files/digest-cl-yacc-0.11
-rw-r--r--dev-lisp/cl-yacc/metadata.xml5
5 files changed, 52 insertions, 0 deletions
diff --git a/dev-lisp/cl-yacc/ChangeLog b/dev-lisp/cl-yacc/ChangeLog
new file mode 100644
index 000000000000..3a6704cf2c6b
--- /dev/null
+++ b/dev-lisp/cl-yacc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-yacc
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-yacc/ChangeLog,v 1.1 2005/04/25 02:19:41 mkennedy Exp $
+
+*cl-yacc-0.1 (25 Apr 2005)
+
+ 25 Apr 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-yacc-0.1.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-yacc/Manifest b/dev-lisp/cl-yacc/Manifest
new file mode 100644
index 000000000000..51cd389c403f
--- /dev/null
+++ b/dev-lisp/cl-yacc/Manifest
@@ -0,0 +1,4 @@
+MD5 50219edfbb7141a87db9546bd200852e cl-yacc-0.1.ebuild 836
+MD5 c98cbe46141d5d1b6a447cf493b4947b ChangeLog 403
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 be8a75f4d235045b2f91002d75a2229f files/digest-cl-yacc-0.1 62
diff --git a/dev-lisp/cl-yacc/cl-yacc-0.1.ebuild b/dev-lisp/cl-yacc/cl-yacc-0.1.ebuild
new file mode 100644
index 000000000000..851f289fe6ed
--- /dev/null
+++ b/dev-lisp/cl-yacc/cl-yacc-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-yacc/cl-yacc-0.1.ebuild,v 1.1 2005/04/25 02:19:41 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="CL-YACC is a LALR(1) parser generator for Common Lisp"
+HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/cl-yacc/
+ http://www.cliki.net/CL-Yacc"
+SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86 ~amd64 ~ppc"
+IUSE="doc"
+DEPEND="virtual/commonlisp
+ dev-lisp/common-lisp-controller
+ doc? ( sys-apps/texinfo )"
+
+CLPACKAGE="yacc"
+
+src_compile() {
+ if use doc; then
+ makeinfo cl-yacc.texi || die
+ fi
+}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ use doc && doinfo *.info*
+ dodoc README COPYING
+}
diff --git a/dev-lisp/cl-yacc/files/digest-cl-yacc-0.1 b/dev-lisp/cl-yacc/files/digest-cl-yacc-0.1
new file mode 100644
index 000000000000..03ea91702baa
--- /dev/null
+++ b/dev-lisp/cl-yacc/files/digest-cl-yacc-0.1
@@ -0,0 +1 @@
+MD5 410b8962adbf2afd177c995362335958 cl-yacc-0.1.tar.gz 16737
diff --git a/dev-lisp/cl-yacc/metadata.xml b/dev-lisp/cl-yacc/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-yacc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>