summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-16 17:32:12 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-16 17:32:12 +0000
commit88bb2525929411d5a56facc91b892e4f48441705 (patch)
tree6a9d8d550834aa13ce1d0841e93155bea3524963 /dev-lisp/cl-tbnl
parentmx4j now makes use of java-pkg_dosrc (diff)
downloadhistorical-88bb2525929411d5a56facc91b892e4f48441705.tar.gz
historical-88bb2525929411d5a56facc91b892e4f48441705.tar.bz2
historical-88bb2525929411d5a56facc91b892e4f48441705.zip
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-lisp/cl-tbnl')
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest4
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.4.1.ebuild38
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.4.11
4 files changed, 48 insertions, 2 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index 29018f4af19b..fb6a23bf4fff 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.3 2005/03/13 00:07:36 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.4 2005/03/16 17:32:12 mkennedy Exp $
+
+*cl-tbnl-0.4.1 (16 Mar 2005)
+
+ 16 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.4.1.ebuild:
+ New upstream version.
*cl-tbnl-0.3.12 (12 Mar 2005)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index ed3a44eec0c4..19b21aa1e11f 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,12 +1,14 @@
-MD5 9f2352ff5c728ba2ee218b3d4fab6344 ChangeLog 855
+MD5 77114687ae3d8310e4bb57566eb474b6 ChangeLog 986
MD5 2bdf3650be3177e2c14b14a95be6d7b3 cl-tbnl-0.2.12.ebuild 829
MD5 7ef0646dda8baa631e5ed98d7db5b6d7 cl-tbnl-0.3.10.ebuild 918
MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
MD5 741ea3f3dc3c79bf46ae27f46d809c94 cl-tbnl-0.3.11.ebuild 923
MD5 0d1f4e17c59a3b0325807341d6efc04d cl-tbnl-0.3.12.ebuild 923
MD5 959fd151be631d3deb7c78f314d1cae9 cl-tbnl-0.3.13.ebuild 923
+MD5 93d2851f8c41f2d64497dc6f80fe00bf cl-tbnl-0.4.1.ebuild 922
MD5 8bc422e5dac6886c3c688ffd6ed93dd6 files/digest-cl-tbnl-0.2.12 62
MD5 96bbbd53007caa5cc06cc59bcb68c1ff files/digest-cl-tbnl-0.3.10 62
MD5 a85a52d1daff75e4574ebd35622844f5 files/digest-cl-tbnl-0.3.11 67
MD5 5764ebffe3c1d612b13d29a2494df2eb files/digest-cl-tbnl-0.3.12 67
MD5 e5ef74a2e8ed899318b177f8a554db55 files/digest-cl-tbnl-0.3.13 67
+MD5 650b3eb0a9f443c6bcd6b083cdb71a49 files/digest-cl-tbnl-0.4.1 66
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.4.1.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.4.1.ebuild
new file mode 100644
index 000000000000..ff7d3a9cd311
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.4.1.ebuild,v 1.1 2005/03/16 17:32:12 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="apache2"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre"
+
+# RDEPEND="${DEPEND}
+# apache2? ( www-apache/mod_lisp2 ) !apache2? ( www-apache/mod_lisp )"
+
+RDEPEND="${DEPEND}
+ www-apache/mod_lisp"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+ docinto test
+ dodoc test/*
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.4.1 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.4.1
new file mode 100644
index 000000000000..ddccdca5a237
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.4.1
@@ -0,0 +1 @@
+MD5 b7dfe91392d72b3af65760f6d27dfe90 tbnl_0.4.1.orig.tar.gz 83475