summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-03-16 04:30:15 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-03-16 04:30:15 +0000
commitb0ee3317096df993c1a1995764b3ef4adc6ad9e1 (patch)
tree375717daa7c0ea78abb19d56b8e851df06ad30b7 /dev-lisp/cl-spatial-trees/cl-spatial-trees-0.1.ebuild
parentReplace _epatch_draw_line() with a very short shell script (diff)
downloadhistorical-b0ee3317096df993c1a1995764b3ef4adc6ad9e1.tar.gz
historical-b0ee3317096df993c1a1995764b3ef4adc6ad9e1.tar.bz2
historical-b0ee3317096df993c1a1995764b3ef4adc6ad9e1.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'dev-lisp/cl-spatial-trees/cl-spatial-trees-0.1.ebuild')
-rw-r--r--dev-lisp/cl-spatial-trees/cl-spatial-trees-0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/cl-spatial-trees/cl-spatial-trees-0.1.ebuild b/dev-lisp/cl-spatial-trees/cl-spatial-trees-0.1.ebuild
new file mode 100644
index 000000000000..2cdc615fd267
--- /dev/null
+++ b/dev-lisp/cl-spatial-trees/cl-spatial-trees-0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-spatial-trees/cl-spatial-trees-0.1.ebuild,v 1.1 2006/03/16 04:30:15 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A Common Lisp library providing access to dynamic index structures for spatially-extended data."
+HOMEPAGE="http://www.cliki.net/spatial-trees"
+SRC_URI="http://ftp.linux.org.uk/pub/lisp/cclan/spatial-trees-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=spatial-trees
+
+S=${WORKDIR}/spatial-trees-${PV}
+
+src_install() {
+ common-lisp-install *.{asd,lisp}
+ common-lisp-system-symlink
+ dodoc LICENCE TODO
+}