summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:53:04 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:53:04 +0000
commit617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f (patch)
treebcfe11291f5c920da39dfc65ba00f51356086a04 /dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild
parentDEPEND on sed >= 4 (diff)
downloadhistorical-617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f.tar.gz
historical-617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f.tar.bz2
historical-617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f.zip
initial common lisp import
Diffstat (limited to 'dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild')
-rw-r--r--dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild b/dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild
new file mode 100644
index 000000000000..a7194b60643e
--- /dev/null
+++ b/dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-inflate/cl-inflate-1.1.4.2.1.ebuild,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp package to decompress a gzip, jar, and winzip file"
+HOMEPAGE="http://opensource.franz.com/deflate/index.html
+ http://packages.debian.org/unstable/devel/cl-inflate.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-inflate/${PN}_${PV}.orig.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=inflate
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ common-lisp-install inflate.lisp ${FILESDIR}/inflate.asd
+ common-lisp-system-symlink
+}