summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-12-05 20:01:43 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-12-05 20:01:43 +0000
commitd4c6e05e99ebb8dcd91fced62057b2300563eee2 (patch)
tree5b5f9f0907868be7920b7fe590429b46f428241e /dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.11.ebuild
parentBump revision to include new init.d script to fix issues reported in bug #154162 (diff)
downloadhistorical-d4c6e05e99ebb8dcd91fced62057b2300563eee2.tar.gz
historical-d4c6e05e99ebb8dcd91fced62057b2300563eee2.tar.bz2
historical-d4c6e05e99ebb8dcd91fced62057b2300563eee2.zip
New upstream version.
Package-Manager: portage-2.1.2_rc2-r3
Diffstat (limited to 'dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.11.ebuild')
-rw-r--r--dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.11.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.11.ebuild b/dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.11.ebuild
new file mode 100644
index 000000000000..fd9717430938
--- /dev/null
+++ b/dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.11.ebuild,v 1.1 2006/12/05 20:01:43 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Hunchentoot is a web server written in Common Lisp and at the same time a toolkit for building dynamic websites with Common Lisp."
+HOMEPAGE="http://weitz.de/hunchentoot/"
+SRC_URI="mirror://gentoo/hunchentoot_${PV}.orig.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-rfc2388
+ dev-lisp/cl-plus-ssl
+ dev-lisp/cl-chunga
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-who"
+SLOT="0"
+
+CLPACKAGE="hunchentoot hunchentoot-test"
+
+S=${WORKDIR}/hunchentoot-${PV}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ insinto $CLSOURCEROOT/hunchentoot/test
+ doins test/*
+ for i in hunchentoot{,-test}; do
+ dosym $CLSOURCEROOT/hunchentoot/$i.asd $CLSYSTEMROOT/$i.asd
+ done
+ dodoc CHANGELOG* README
+ dohtml -r doc/*
+}