summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-11-09 04:30:53 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-11-09 04:30:53 +0000
commit8ebe4d5733c07ad8f575950039a39bb2b3b08d1d (patch)
tree0166f5a0621fe28e996561dd5f6015c289aef42d /dev-lisp/cl-drakma/cl-drakma-0.5.2.ebuild
parentRemove Common Lisp Controller support. (diff)
downloadhistorical-8ebe4d5733c07ad8f575950039a39bb2b3b08d1d.tar.gz
historical-8ebe4d5733c07ad8f575950039a39bb2b3b08d1d.tar.bz2
historical-8ebe4d5733c07ad8f575950039a39bb2b3b08d1d.zip
New upstream version.
Package-Manager: portage-2.1.2_rc1-r4
Diffstat (limited to 'dev-lisp/cl-drakma/cl-drakma-0.5.2.ebuild')
-rw-r--r--dev-lisp/cl-drakma/cl-drakma-0.5.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lisp/cl-drakma/cl-drakma-0.5.2.ebuild b/dev-lisp/cl-drakma/cl-drakma-0.5.2.ebuild
new file mode 100644
index 000000000000..8be755dd3298
--- /dev/null
+++ b/dev-lisp/cl-drakma/cl-drakma-0.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-drakma/cl-drakma-0.5.2.ebuild,v 1.1 2006/11/09 04:30:53 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Drakma is a Common Lisp HTTP client."
+HOMEPAGE="http://weitz.de/drakma/"
+SRC_URI="http://common-lisp.net/project/portage-overlay/distfiles/drakma_${PV}.orig.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+SLOT="0"
+DEPEND="dev-lisp/cl-chunga
+ dev-lisp/cl-puri
+ >=dev-lisp/cl-base64-3.3.2
+ dev-lisp/cl-trivial-sockets
+ dev-lisp/cl-plus-ssl"
+
+S=${WORKDIR}/${P/cl-}
+
+CLPACKAGE=drakma
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ dodoc CHANGELOG*
+ dohtml doc/index.html
+}