summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-07-25 06:22:31 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-07-25 06:22:31 +0000
commitb7048353dff4874d6b3895402cf477e5cd96a98e (patch)
tree4bf0590c17396c715271793f74b03df1519884de /dev-lisp/cl-ch-util
parentRequire mozilla-launcher-1.44 which has the -calendar hack (diff)
downloadhistorical-b7048353dff4874d6b3895402cf477e5cd96a98e.tar.gz
historical-b7048353dff4874d6b3895402cf477e5cd96a98e.tar.bz2
historical-b7048353dff4874d6b3895402cf477e5cd96a98e.zip
.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-lisp/cl-ch-util')
-rw-r--r--dev-lisp/cl-ch-util/ChangeLog11
-rw-r--r--dev-lisp/cl-ch-util/Manifest15
-rw-r--r--dev-lisp/cl-ch-util/cl-ch-util-0.1.4.20050724.ebuild36
-rw-r--r--dev-lisp/cl-ch-util/files/0.1.4.20050724-fasl-output-gentoo.patch52
-rw-r--r--dev-lisp/cl-ch-util/files/digest-cl-ch-util-0.1.4.200507241
-rw-r--r--dev-lisp/cl-ch-util/metadata.xml5
6 files changed, 120 insertions, 0 deletions
diff --git a/dev-lisp/cl-ch-util/ChangeLog b/dev-lisp/cl-ch-util/ChangeLog
new file mode 100644
index 000000000000..d77375b2bb07
--- /dev/null
+++ b/dev-lisp/cl-ch-util/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-lisp/cl-ch-util
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ch-util/ChangeLog,v 1.1 2005/07/25 06:22:31 mkennedy Exp $
+
+*cl-ch-util-0.1.4.20050724 (25 Jul 2005)
+
+ 25 Jul 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/0.1.4.20050724-fasl-output-gentoo.patch, +metadata.xml,
+ +cl-ch-util-0.1.4.20050724.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-ch-util/Manifest b/dev-lisp/cl-ch-util/Manifest
new file mode 100644
index 000000000000..2a48409f7666
--- /dev/null
+++ b/dev-lisp/cl-ch-util/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 cae1fb574188dff3f8cf7acd28609534 cl-ch-util-0.1.4.20050724.ebuild 1056
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 57b436e1ffe48daad21523f0d3dcb509 ChangeLog 488
+MD5 0ce6b51f0162512cfe9ae43b9f73db01 files/digest-cl-ch-util-0.1.4.20050724 72
+MD5 1cd754672d755dfaabb81c59238b65a4 files/0.1.4.20050724-fasl-output-gentoo.patch 2323
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFC5IVpyiNZaEAZA+ARAiRJAJ9NXGJp8bpZOPsXE9DNqpH6IrHPxgCfW7+X
+2CqJO7F/qggRxKYdEYhfaTQ=
+=KIIR
+-----END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-ch-util/cl-ch-util-0.1.4.20050724.ebuild b/dev-lisp/cl-ch-util/cl-ch-util-0.1.4.20050724.ebuild
new file mode 100644
index 000000000000..3ea2c6c28af6
--- /dev/null
+++ b/dev-lisp/cl-ch-util/cl-ch-util-0.1.4.20050724.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ch-util/cl-ch-util-0.1.4.20050724.ebuild,v 1.1 2005/07/25 06:22:31 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Cyrus Harmon's Common Lisp utility library."
+HOMEPAGE="http://www.cyrusharmon.org/cl/blog/"
+SRC_URI="http://cyrusharmon.org/cl/static/releases/ch-util-${PV/.2005/-2005}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE=""
+DEPEND=""
+S=${WORKDIR}/ch-util
+
+CLPACKAGE='ch-util ch-util-test'
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-fasl-output-gentoo.patch || die
+ rm ${S}/Makefile
+}
+
+src_install() {
+ dodir $CLSYSTEMROOT
+ insinto $CLSOURCEROOT/ch-util
+ doins *.{cl,asd}
+ insinto $CLSOURCEROOT/ch-util/src/
+ doins src/*.cl
+ insinto $CLSOURCEROOT/ch-util/test/
+ doins test/*.cl
+ dosym ${CLSOURCEROOT}/ch-util/ch-util.asd ${CLSYSTEMROOT}/ch-util.asd
+ dosym ${CLSOURCEROOT}/ch-util/ch-util-test.asd ${CLSYSTEMROOT}/ch-util-test.asd
+ dodoc COPYRIGHT README
+}
diff --git a/dev-lisp/cl-ch-util/files/0.1.4.20050724-fasl-output-gentoo.patch b/dev-lisp/cl-ch-util/files/0.1.4.20050724-fasl-output-gentoo.patch
new file mode 100644
index 000000000000..30d855276c41
--- /dev/null
+++ b/dev-lisp/cl-ch-util/files/0.1.4.20050724-fasl-output-gentoo.patch
@@ -0,0 +1,52 @@
+diff -ur ch-util.orig/ch-util-test.asd ch-util/ch-util-test.asd
+--- ch-util.orig/ch-util-test.asd 2005-07-24 13:44:50.000000000 -0500
++++ ch-util/ch-util-test.asd 2005-07-25 00:23:10.000000000 -0500
+@@ -12,15 +12,15 @@
+ ;;;;
+ (defclass ch-util-test-cl-source-file (cl-source-file) ())
+
+-(defparameter *fasl-directory*
+- (make-pathname :directory '(:relative #+sbcl "sbcl-fasl"
+- #+openmcl "openmcl-fasl"
+- #-(or sbcl openmcl) "fasl")))
++;; (defparameter *fasl-directory*
++;; (make-pathname :directory '(:relative #+sbcl "sbcl-fasl"
++;; #+openmcl "openmcl-fasl"
++;; #-(or sbcl openmcl) "fasl")))
+
+ (defmethod source-file-type ((c ch-util-test-cl-source-file) (s module)) "cl")
+
+-(defmethod asdf::output-files :around ((operation compile-op) (c ch-util-test-cl-source-file))
+- (list (merge-pathnames *fasl-directory* (compile-file-pathname (component-pathname c)))))
++;; (defmethod asdf::output-files :around ((operation compile-op) (c ch-util-test-cl-source-file))
++;; (list (merge-pathnames *fasl-directory* (compile-file-pathname (component-pathname c)))))
+
+ (defsystem #:ch-util-test
+ :name "ch-util-test"
+Only in ch-util: ch-util-test.asd~
+diff -ur ch-util.orig/ch-util.asd ch-util/ch-util.asd
+--- ch-util.orig/ch-util.asd 2005-07-24 13:44:50.000000000 -0500
++++ ch-util/ch-util.asd 2005-07-25 00:23:00.000000000 -0500
+@@ -12,15 +12,15 @@
+ ;;;;
+ (defclass ch-util-cl-source-file (cl-source-file) ())
+
+-(defparameter *fasl-directory*
+- (make-pathname :directory '(:relative #+sbcl "sbcl-fasl"
+- #+openmcl "openmcl-fasl"
+- #-(or sbcl openmcl) "fasl")))
++;; (defparameter *fasl-directory*
++;; (make-pathname :directory '(:relative #+sbcl "sbcl-fasl"
++;; #+openmcl "openmcl-fasl"
++;; #-(or sbcl openmcl) "fasl")))
+
+ (defmethod source-file-type ((c ch-util-cl-source-file) (s module)) "cl")
+
+-(defmethod asdf::output-files :around ((operation compile-op) (c ch-util-cl-source-file))
+- (list (merge-pathnames *fasl-directory* (compile-file-pathname (component-pathname c)))))
++;; (defmethod asdf::output-files :around ((operation compile-op) (c ch-util-cl-source-file))
++;; (list (merge-pathnames *fasl-directory* (compile-file-pathname (component-pathname c)))))
+
+ (defsystem #:ch-util
+ :name "ch-util"
+Only in ch-util: ch-util.asd~
diff --git a/dev-lisp/cl-ch-util/files/digest-cl-ch-util-0.1.4.20050724 b/dev-lisp/cl-ch-util/files/digest-cl-ch-util-0.1.4.20050724
new file mode 100644
index 000000000000..a4908c05aeac
--- /dev/null
+++ b/dev-lisp/cl-ch-util/files/digest-cl-ch-util-0.1.4.20050724
@@ -0,0 +1 @@
+MD5 b0ba6f85025b0d4eeef28c007362100e ch-util-0.1.4-20050724.tar.gz 7007
diff --git a/dev-lisp/cl-ch-util/metadata.xml b/dev-lisp/cl-ch-util/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-ch-util/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>