summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-03-14 07:34:06 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-03-14 07:34:06 +0000
commit41a7167cfb96c6095a3f91ccda2bf70b5a5dd262 (patch)
tree35b3178dd0025d0c408d1b10d685e08b6014e78b /dev-lisp/cl-cffi/cl-cffi-0.9.0.ebuild
parentSlight annoyance fix (diff)
downloadhistorical-41a7167cfb96c6095a3f91ccda2bf70b5a5dd262.tar.gz
historical-41a7167cfb96c6095a3f91ccda2bf70b5a5dd262.tar.bz2
historical-41a7167cfb96c6095a3f91ccda2bf70b5a5dd262.zip
New upstream version; Removed old ebuilds.
Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'dev-lisp/cl-cffi/cl-cffi-0.9.0.ebuild')
-rw-r--r--dev-lisp/cl-cffi/cl-cffi-0.9.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-lisp/cl-cffi/cl-cffi-0.9.0.ebuild b/dev-lisp/cl-cffi/cl-cffi-0.9.0.ebuild
new file mode 100644
index 000000000000..6a8bf53a8888
--- /dev/null
+++ b/dev-lisp/cl-cffi/cl-cffi-0.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cffi/cl-cffi-0.9.0.ebuild,v 1.1 2006/03/14 07:34:06 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="The Common Foreign Function Interface (CFFI)"
+HOMEPAGE="http://common-lisp.net/project/cffi/"
+SRC_URI="http://common-lisp.net/project/cffi/releases/cffi-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+S=${WORKDIR}/cffi-${PV}
+
+DEPEND="doc? ( dev-lisp/sbcl virtual/tetex sys-apps/texinfo )"
+
+CLPACKAGE=cffi
+
+src_compile() {
+ use doc && make -C doc docs
+}
+
+src_install() {
+ dodir $CLSYSTEMROOT
+ insinto $CLSOURCEROOT/$CLPACKAGE
+ for i in cffi cffi-tests cffi-examples cffi-uffi-compat; do
+ dosym $CLSOURCEROOT/$CLPACKAGE/$i.asd \
+ $CLSYSTEMROOT/
+ done
+ doins -r tests src uffi-compat examples *.asd
+ dodoc README COPYRIGHT HEADER TODO
+ dodoc doc/*.txt
+ if use doc; then
+ doinfo doc/*.info
+ insinto /usr/share/doc/${PF}/html
+ doins -r doc/{spec,manual}
+ fi
+}