summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-01 04:44:15 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-01 04:44:15 +0000
commite8f97b6647a331dcc3bfaefe25cd3552aa263900 (patch)
treedd932a9fd1fa32e5be7751dcf706c59b841b1a89 /dev-libs
parentAdded dependencies (diff)
downloadhistorical-e8f97b6647a331dcc3bfaefe25cd3552aa263900.tar.gz
historical-e8f97b6647a331dcc3bfaefe25cd3552aa263900.tar.bz2
historical-e8f97b6647a331dcc3bfaefe25cd3552aa263900.zip
Added dependencies
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/glib/glib-1.2.8-r1.ebuild5
-rw-r--r--dev-libs/gmp/gmp-3.1.ebuild7
-rw-r--r--dev-libs/libpcre/libpcre-3.2-r1.ebuild5
-rw-r--r--dev-libs/librep/librep-0.13.1.ebuild8
-rw-r--r--dev-libs/openssl/openssl-0.9.6.ebuild4
5 files changed, 23 insertions, 6 deletions
diff --git a/dev-libs/glib/glib-1.2.8-r1.ebuild b/dev-libs/glib/glib-1.2.8-r1.ebuild
index da85bfffe9ef..215d93df3a8e 100644
--- a/dev-libs/glib/glib-1.2.8-r1.ebuild
+++ b/dev-libs/glib/glib-1.2.8-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.8-r1.ebuild,v 1.5 2000/10/28 04:17:42 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.8-r1.ebuild,v 1.6 2000/11/01 04:44:15 achim Exp $
# also, this script now has pre/post inst/rm support
@@ -12,6 +12,9 @@ DESCRIPTION="The GLib library of C routines"
SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/"${A}
HOMEPAGE="http://www.gtk.org/"
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/glibc-2.1.3"
+
src_compile() {
cd ${S}
try ./configure --host=${CHOST} --prefix=/usr --infodir=/usr/info --with-threads=posix
diff --git a/dev-libs/gmp/gmp-3.1.ebuild b/dev-libs/gmp/gmp-3.1.ebuild
index 8ade6e26014c..2f0a425e0b3f 100644
--- a/dev-libs/gmp/gmp-3.1.ebuild
+++ b/dev-libs/gmp/gmp-3.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-3.1.ebuild,v 1.3 2000/10/04 16:04:34 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-3.1.ebuild,v 1.4 2000/11/01 04:44:15 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,6 +9,7 @@ DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational nu
SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gmp/${A}
ftp://prep.ai.mit.edu/gnu/gmp/${A}"
HOMEPAGE="http://www.gnu.org/software/gmp/gmp.html"
+DEPEND=">=sys-libs/glibc-2.1.3"
src_unpack() {
unpack ${A}
@@ -25,8 +26,10 @@ src_install() {
try make prefix=${D}/usr install
prepinfo
dodoc AUTHORS ChangeLog COPYING* NEWS README
+ dodoc doc/assembly_code doc/configuration
+ dodoc doc/isa_abi_headache doc/multiplication
docinto html
- dodoc projects/*.html
+ dodoc doc/*.html
}
diff --git a/dev-libs/libpcre/libpcre-3.2-r1.ebuild b/dev-libs/libpcre/libpcre-3.2-r1.ebuild
index 1ea2b1505daf..1fa64a353e04 100644
--- a/dev-libs/libpcre/libpcre-3.2-r1.ebuild
+++ b/dev-libs/libpcre/libpcre-3.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-3.2-r1.ebuild,v 1.3 2000/09/15 20:08:48 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-3.2-r1.ebuild,v 1.4 2000/11/01 04:44:15 achim Exp $
P=libpcre-3.2
A=pcre-3.2.tar.gz
@@ -9,6 +9,9 @@ S=${WORKDIR}/pcre-3.2
DESCRIPTION="Perl compatible regular expressions"
SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/"${A}
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/glibc-2.1.3"
+
src_unpack() {
unpack ${A}
}
diff --git a/dev-libs/librep/librep-0.13.1.ebuild b/dev-libs/librep/librep-0.13.1.ebuild
index a3d92e570408..f6288bd7d4ca 100644
--- a/dev-libs/librep/librep-0.13.1.ebuild
+++ b/dev-libs/librep/librep-0.13.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.13.1.ebuild,v 1.1 2000/10/14 11:24:09 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.13.1.ebuild,v 1.2 2000/11/01 04:44:15 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,6 +9,12 @@ DESCRIPTION="Share library implementing a Lisp dialect"
SRC_URI="ftp://librep.sourceforge.net/pub/librep/"${A}
HOMEPAGE="http://librep.sourceforge.net/"
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1
+ >=dev-libs/gmp-3.1"
src_unpack() {
unpack ${A}
diff --git a/dev-libs/openssl/openssl-0.9.6.ebuild b/dev-libs/openssl/openssl-0.9.6.ebuild
index a352e8fc2c84..21436f712b7c 100644
--- a/dev-libs/openssl/openssl-0.9.6.ebuild
+++ b/dev-libs/openssl/openssl-0.9.6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.6.ebuild,v 1.2 2000/10/23 11:27:13 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.6.ebuild,v 1.3 2000/11/01 04:44:15 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,6 +9,8 @@ DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
SRC_URI="http://www.openssl.org/source/${A}"
HOMEPAGE="http://www.opensl.org/"
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/glibc-2.1.3"
src_compile() {
./config --prefix=/usr --openssldir=/usr/ssl threads