summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-10-14 00:46:04 +0000
committerChris White <chriswhite@gentoo.org>2004-10-14 00:46:04 +0000
commitbe275bc2b0c8bed9dc85510eba87e88a6782d169 (patch)
tree066ec8611f1d081cf87666838a4dd2c55d0b5231 /dev-libs
parent+us -> u+s (diff)
downloadhistorical-be275bc2b0c8bed9dc85510eba87e88a6782d169.tar.gz
historical-be275bc2b0c8bed9dc85510eba87e88a6782d169.tar.bz2
historical-be275bc2b0c8bed9dc85510eba87e88a6782d169.zip
bump to 2.4.0. Part of fixing Bug #6740. Also applied an upstream gcc 3.4 patch (after some modification).
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/vdk/ChangeLog9
-rw-r--r--dev-libs/vdk/Manifest5
-rw-r--r--dev-libs/vdk/files/digest-vdk-2.4.01
-rw-r--r--dev-libs/vdk/files/vdk-2.4.0-gcc3.4.patch165
-rw-r--r--dev-libs/vdk/vdk-2.4.0.ebuild56
5 files changed, 234 insertions, 2 deletions
diff --git a/dev-libs/vdk/ChangeLog b/dev-libs/vdk/ChangeLog
index 8f3818efb4da..ea63792901de 100644
--- a/dev-libs/vdk/ChangeLog
+++ b/dev-libs/vdk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/vdk
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/vdk/ChangeLog,v 1.8 2004/10/13 21:02:57 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/vdk/ChangeLog,v 1.9 2004/10/14 00:46:04 chriswhite Exp $
+
+*vdk-2.4.0 (13 Oct 2004)
+
+ 13 Oct 2004; Chris White <chriswhite@gentoo.org>
+ +files/vdk-2.4.0-gcc3.4.patch, +vdk-2.4.0.ebuild:
+ bump to 2.4.0. Part of fixing Bug #6740. Also applied an upstream gcc 3.4
+ patch (after some modification).
13 Oct 2004; Chris White <chriswhite@gentoo.org> +metadata.xml:
Taking over as maintainer.
diff --git a/dev-libs/vdk/Manifest b/dev-libs/vdk/Manifest
index 37beb9e40c7f..75600442d62c 100644
--- a/dev-libs/vdk/Manifest
+++ b/dev-libs/vdk/Manifest
@@ -1,7 +1,10 @@
-MD5 3955b2754bb7b2f0bcc1d058d22b3458 ChangeLog 826
+MD5 3d146f535a492b026106da3ab0f75a3f ChangeLog 1067
MD5 362802d08a50735dacc44422c6bf47eb vdk-2.0.2-r1.ebuild 912
MD5 b3b9904376a77d65cd3050cc74b40e72 vdk-2.0.2.ebuild 885
MD5 b67bcaffc79666637f73082499f772b0 metadata.xml 228
+MD5 ed6b26f24903df9fe7122213f7b8f583 vdk-2.4.0.ebuild 1499
+MD5 8bbcc0a70a6e499bd8539275f40e574a files/digest-vdk-2.4.0 62
MD5 99848ddbdb27f9085a04d4be864953c8 files/digest-vdk-2.0.2 61
MD5 99848ddbdb27f9085a04d4be864953c8 files/digest-vdk-2.0.2-r1 61
MD5 ce2f3ecb79a589ce3ac4bbd88f7bc2fd files/vdk-2.0.2-makefile.in.patch 445
+MD5 c3617790721213fc5725772e45f7b02b files/vdk-2.4.0-gcc3.4.patch 4695
diff --git a/dev-libs/vdk/files/digest-vdk-2.4.0 b/dev-libs/vdk/files/digest-vdk-2.4.0
new file mode 100644
index 000000000000..5c92344a994d
--- /dev/null
+++ b/dev-libs/vdk/files/digest-vdk-2.4.0
@@ -0,0 +1 @@
+MD5 b23dcfa237dbf4b9424bcaa37683a7ba vdk-2.4.0.tar.gz 1071732
diff --git a/dev-libs/vdk/files/vdk-2.4.0-gcc3.4.patch b/dev-libs/vdk/files/vdk-2.4.0-gcc3.4.patch
new file mode 100644
index 000000000000..b8a7ef3c3ce8
--- /dev/null
+++ b/dev-libs/vdk/files/vdk-2.4.0-gcc3.4.patch
@@ -0,0 +1,165 @@
+--- vdk/chart.cc_old 2002-05-22 17:26:12.000000000 +0900
++++ vdk/chart.cc 2004-08-05 19:16:35.000000000 +0900
+@@ -45,7 +45,10 @@
+ size = Usize;
+ printf("\nsize:%d,%d",size.x,size.y);
+ fflush(stdout);
+- axis = ChartAxis(this,size.X(),size.Y());
++ // patch Bug#262091
++ // axis = ChartAxis(this,size.X(),size.Y());
++ ChartAxis axis_tmp( this, size.X(), size.Y() );
++ axis = axis_tmp;
+ axis.Draw();
+ DrawTitle();
+ DrawChart();
+@@ -115,7 +118,10 @@
+ void VDKChart::SetChartBorder(int b)
+ {
+ size = Usize;
+-axis = ChartAxis(this,size.X(),size.Y());
++// patch Bug#262091
++// axis = ChartAxis(this,size.X(),size.Y());
++ChartAxis axis_tmp(this,size.X(),size.Y());
++axis = axis_tmp;
+ DrawChart();
+ }
+ /*
+@@ -415,10 +421,18 @@
+ ChartAxis::ChartAxis(VDKChart* owner,int w, int h):
+ owner(owner)
+ {
++// patch Bug#262091
++/*
+ domain = VDKRect(owner->ChartBorder,
+ h-owner->ChartBorder,
+ w-owner->ChartBorder*2,
+ h-owner->ChartBorder*2);
++*/
++VDKRect r(owner->ChartBorder,
++ h-owner->ChartBorder,
++ w-owner->ChartBorder*2,
++ h-owner->ChartBorder*2);
++domain = r;
+ }
+ /*
+ copy-initializer
+--- vdk/vdkbtrees.h_old 2000-11-22 14:10:33.000000000 +0900
++++ vdk/vdkbtrees.h 2004-08-05 19:16:36.000000000 +0900
+@@ -717,7 +717,7 @@
+ class AbstractRedBlackTree : public AbstractBinaryTree<T, Node> {
+ protected:
+ virtual Node *FindNode(T q)
+- { return (root) ? (Node *) root->find(q) : NULL; }
++ { return (this->root) ? (Node *) this->root->find(q) : NULL; }
+ };
+
+ /*!
+@@ -985,14 +985,14 @@
+ BlackHeight = -1;
+
+ // Check binary tree properties.
+- if (parent != _parent)
++ if (this->parent != _parent)
+ return NULL;
+- if (left) {
+- if (object < left->object)
++ if (this->left) {
++ if (this->object < this->left->object)
+ return NULL;
+ }
+- if (right) {
+- if (right->object < object)
++ if (this->right) {
++ if (this->right->object < this->object)
+ return NULL;
+ }
+
+@@ -1001,15 +1001,15 @@
+ // If a node is red, then both its children are black
+ // (NULL nodes are black).
+ if (clr == Red) {
+- if ((left && left->clr != Black) ||
+- (right && right->clr != Black))
++ if ((this->left && this->left->clr != Black) ||
++ (this->right && this->right->clr != Black))
+ return NULL;
+ }
+
+ // The black-heights of all leaf nodes are equal.
+ int bh = NULL;
+
+- if ((! left) && (! right)) {
++ if ((! this->left) && (! this->right)) {
+ // Compute black-height of node
+ for (Node *sc = (Node *) this; sc; sc = sc->parent)
+ if (sc->clr == Black)
+@@ -1023,9 +1023,9 @@
+ return NULL;
+ }
+ }
+- if (left && (! left->CheckTreeProperties((Node *) this)))
++ if (this->left && (! this->left->CheckTreeProperties((Node *) this)))
+ return NULL;
+- if (right && (! right->CheckTreeProperties((Node *) this)))
++ if (this->right && (! this->right->CheckTreeProperties((Node *) this)))
+ return NULL;
+ return 1;
+ }
+--- vdk/vdkheap.h_old 2000-11-22 14:10:52.000000000 +0900
++++ vdk/vdkheap.h 2004-08-05 19:16:36.000000000 +0900
+@@ -85,7 +85,7 @@
+ VDKHeap<T>::VDKHeap(T* source, int size): VDKContainer<T>(size)
+ {
+ for(int i = 0; i < size; i++)
+- data[i] = source[i];
++ this->data[i] = source[i];
+ BuildHeap();
+ }
+
+@@ -94,13 +94,13 @@
+ void VDKHeap<T>::Heapify(int i, int heapsize)
+ {
+ int l = left(i), r = right(i), largest = i;
+- if( (l < heapsize) && (data[l] > data[i])) largest = l;
+- if( (r < heapsize) && (data[r] > data[largest])) largest = r;
++ if( (l < heapsize) && (this->data[l] > this->data[i])) largest = l;
++ if( (r < heapsize) && (this->data[r] > this->data[largest])) largest = r;
+ if(largest != i)
+ {
+- T temp = data[i];
+- data[i] = data[largest];
+- data[largest] = temp;
++ T temp = this->data[i];
++ this->data[i] = this->data[largest];
++ this->data[largest] = temp;
+ Heapify(largest,heapsize);
+ }
+ }
+@@ -109,21 +109,21 @@
+ template <class T>
+ void VDKHeap<T>::BuildHeap(void)
+ {
+- for (int i = (size()-1)/2 ; i >= 0; i--)
+- Heapify(i,size());
++ for (int i = (this->size()-1)/2 ; i >= 0; i--)
++ Heapify(i,this->size());
+ }
+
+ // HEAPSORT
+ template <class T>
+ void VDKHeap<T>::Sort(void)
+ {
+- int heapsize = size();
++ int heapsize = this->size();
+ int i = heapsize-1;
+ for(; i > 0; i--)
+ {
+- T temp = data[0];
+- data[0] = data[i];
+- data[i] = temp;
++ T temp = this->data[0];
++ this->data[0] = this->data[i];
++ this->data[i] = temp;
+ heapsize--;
+ Heapify(0,heapsize);
+ }
diff --git a/dev-libs/vdk/vdk-2.4.0.ebuild b/dev-libs/vdk/vdk-2.4.0.ebuild
new file mode 100644
index 000000000000..4ea3672f79e7
--- /dev/null
+++ b/dev-libs/vdk/vdk-2.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/vdk/vdk-2.4.0.ebuild,v 1.1 2004/10/14 00:46:04 chriswhite Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A Visual Development Kit for RAD"
+SRC_URI="mirror://sourceforge/vdkbuilder/${P}.tar.gz"
+HOMEPAGE="http://vdk.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa"
+IUSE="doc debug"
+
+DEPEND=">x11-libs/gtk+-2.4*
+ doc? (app-doc/doxygen)"
+
+src_compile() {
+ cd ${S}
+
+ if [ "$(gcc-major-version)" -ge "4" ] || [ "$(gcc-major-version)" -ge "3" -a "$(gcc-minor-version)" -ge "4" ]
+ then
+ epatch ${FILESDIR}/${P}-gcc3.4.patch
+ fi
+
+ # gnome and sigc USE flags need to be added later
+ # when upstream decides to re-support them - ChrisWhite
+
+ use doc && \
+ myconf="${myconf} --enable-doc-html=yes \
+ --enable-doc-latex=yes \
+ --enable-doc-man=yes"
+
+ use debug && \
+ myconf="${myconf} --enable-debug=yes"
+
+ econf \
+ ${myconf} \
+ --with-gnu-ld \
+ --enable-testvdk=no \
+ || die "econf failed"
+
+ # die non user custom CFLAGS!
+ sed -e "s/CFLAGS = .*/CFLAGS = ${CFLAGS}/" -i Makefile
+ sed -e "s/CXXFLAGS = .*/CXXFLAGS = ${CXXFLAGS}/" -i Makefile
+ sed -e "s/CFLAGS = .*/CFLAGS = ${CFLAGS}/" -i vdk/Makefile
+ sed -e "s/CXXFLAGS = .*/CXXFLAGS = ${CXXFLAGS}/" -i vdk/Makefile
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README TODO
+}