summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-12-06 03:54:18 +0000
committerDaniel Goller <morfic@gentoo.org>2005-12-06 03:54:18 +0000
commit5ca54ed96ab969f9f11472f21bd17bb5bc6827bc (patch)
tree89f6cee26bc5366868593447ad14de0220ae1a13 /dev-libs
parentVersion bump (bug #112654). (diff)
downloadhistorical-5ca54ed96ab969f9f11472f21bd17bb5bc6827bc.tar.gz
historical-5ca54ed96ab969f9f11472f21bd17bb5bc6827bc.tar.bz2
historical-5ca54ed96ab969f9f11472f21bd17bb5bc6827bc.zip
Revision Bump
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog7
-rw-r--r--dev-libs/boost/Manifest20
-rw-r--r--dev-libs/boost/boost-1.33.1.ebuild209
-rw-r--r--dev-libs/boost/files/digest-boost-1.33.11
4 files changed, 232 insertions, 5 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index cd21a4cf79a5..48352530b302 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.76 2005/11/27 21:36:34 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.77 2005/12/06 03:54:18 morfic Exp $
+
+*boost-1.33.1 (06 Dec 2005)
+
+ 06 Dec 2005; Daniel Goller <morfic@gentoo.org> +boost-1.33.1.ebuild:
+ bumping to new version
27 Nov 2005; Guy Martin <gmsoft@gentoo.org> boost-1.33.0-r1.ebuild:
Stable on hppa.
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 31651ae7be59..00bc6f6430f7 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -1,9 +1,21 @@
-MD5 1443ed0511791a5f10409e0c29fe6454 ChangeLog 10574
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 e48ab5e8df0c388febe39a998fbb2318 ChangeLog 10700
MD5 48a9e1b7d8d0a0b83513977929156c2d boost-1.31.0.ebuild 3975
-MD5 16a0704d7282649d4c5920e3c8b39bee metadata.xml 343
-MD5 421fe3be35fd6d405bf2b3381d51867f boost-1.33.0.ebuild 6259
MD5 ee5df7e478ec05759c688ca2439c7697 boost-1.33.0-r1.ebuild 5647
+MD5 421fe3be35fd6d405bf2b3381d51867f boost-1.33.0.ebuild 6259
+MD5 cd09649f71ef634223314fb36c56c010 boost-1.33.1.ebuild 5649
+MD5 238bb8043f0cdc8bd91f81bd0b55f92a files/boost-alpha-threads.patch 1111
MD5 4aa5a3b9a3818e9dce488a20cb5ff00b files/digest-boost-1.31.0 66
MD5 612f486fa190f86f9be3a17465036dd0 files/digest-boost-1.33.0 67
-MD5 238bb8043f0cdc8bd91f81bd0b55f92a files/boost-alpha-threads.patch 1111
MD5 612f486fa190f86f9be3a17465036dd0 files/digest-boost-1.33.0-r1 67
+MD5 a570d92201976dd05112d28ca484ed95 files/digest-boost-1.33.1 67
+MD5 16a0704d7282649d4c5920e3c8b39bee metadata.xml 343
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDlQt//aM9DdBw91cRAv+1AJ9wxlCESX28zDbQLfhFcYl/lDaGjACglKE7
+VwEeV/rzdIa7Pw1F25aEd5M=
+=RO9x
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/boost/boost-1.33.1.ebuild b/dev-libs/boost/boost-1.33.1.ebuild
new file mode 100644
index 000000000000..ef620f385b6d
--- /dev/null
+++ b/dev-libs/boost/boost-1.33.1.ebuild
@@ -0,0 +1,209 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.1.ebuild,v 1.1 2005/12/06 03:54:18 morfic Exp $
+
+# This ebuild was generated by Ebuilder v0.4.
+inherit python distutils multilib eutils
+
+DESCRIPTION="Boost Libraries for C++"
+HOMEPAGE="http://www.boost.org/"
+BOOST_PV1=${PV/./_}
+BOOST_PV=${BOOST_PV1/./_}
+SRC_URI="mirror://sourceforge/boost/${PN}_${BOOST_PV}.tar.bz2"
+LICENSE="freedist Boost-1.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bcp bjam debug doc pyste static threads threadsonly"
+
+DEPEND=" sys-devel/gcc
+ dev-lang/python"
+
+RDEPEND="pyste? ( dev-cpp/gccxml dev-python/elementtree ) ${DEPEND}"
+
+S="${WORKDIR}/${PN}_${BOOST_PV}"
+
+pkg_setup() {
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
+
+ if use ppc-macos ; then
+ BOOST_TOOLSET="darwin"
+ TOOLSET_NAME="darwin"
+ SOSUFFIX="dylib"
+ else
+ BOOST_TOOLSET="gcc"
+ TOOLSET_NAME="gcc"
+ SOSUFFIX="so"
+ fi
+
+ if use static ; then
+ BUILD="release <runtime-link>static"
+ else
+ BUILD="release <runtime-link>dynamic"
+ fi
+
+ if use debug ; then
+ BUILD="${BUILD} debug"
+ fi
+
+ if use threads && use threadsonly ; then
+ BUILD="${BUILD} <threading>multi"
+ fi
+
+ if use threads && ! use threadsonly ; then
+ BUILD="${BUILD} <threading>single/multi"
+ fi
+
+ if ! use threads ; then
+ BUILD="${BUILD} <threading>single"
+ fi
+
+ BOOSTJAM="${S}/tools/build/jam_src/bin.*/bjam"
+
+ # we dont like what get_number_of_jobs does, so we borrow what counts to us,
+ # thanks H?kan Wessberg <nacka-gentoo@refug.org>, bug #13565
+
+ if [ "`egrep "^[[:space:]]*MAKEOPTS=" /etc/make.conf | wc -l`" -gt 0 ]; then
+ ADMINOPTS="`egrep "^[[:space:]]*MAKEOPTS=" /etc/make.conf | cut -d= -f2 | sed 's/\"//g'`"
+ ADMINPARAM="`echo ${ADMINOPTS} | gawk '{match($0, /-j *[0-9]*/, opt); print opt[0]}'`"
+ NUMJOBS="${ADMINPARAM}"
+ fi
+
+ python_version
+
+}
+
+src_compile() {
+ # Build bjam, a jam variant, which is used instead of make
+ cd "${S}/tools/build/jam_src"
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+ cd "${S}"
+
+ #Fixing boost with threads on alpha. Thanks to ibm <imirkin@mit.edu>
+ if use threads && [ "${ARCH}" == "alpha" ]; then
+ epatch ${FILESDIR}/boost-alpha-threads.patch
+ fi
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ if use pyste; then
+ cd "${S}/libs/python/pyste/install"
+ distutils_src_compile
+ fi
+
+ if use bcp; then
+ cd "${S}/tools/bcp/"
+ ${BOOSTJAM} || die "Building bcp failed"
+ fi
+}
+
+src_install () {
+ # install build tools
+ cd "${S}/tools/build"
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ dodir /usr/share/boost-build
+ insinto /usr/share/boost-build
+ cp -pPR index.html v1/ v2/ "${D}/usr/share/boost-build" || die "failed to install docs"
+ cd "${S}"
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ --prefix="${D}/usr" \
+ --layout=system \
+ install || die "Install failed"
+
+ # Install documentation; seems to be mostly under ${S}/lib
+
+ if use doc ; then
+ dodoc README
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css \
+ -A pdf -r more-r people -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} "${D}/usr/share/doc/${PF}/html/\{\}" \;
+ fi
+ #and finally set "default" links to -gcc-mt versions
+ cd "${D}/usr/lib"
+
+ for fn in `ls -1 *.${SOSUFFIX}| cut -d- -f1 | sort | uniq`; do
+ if [ -f "$fn.${SOSUFFIX}" ] ; then
+ dosym "$fn.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}.${SOSUFFIX}"
+ fi
+ if [ -f "$fn-mt.${SOSUFFIX}" ] ; then
+ dosym "$fn-mt.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}-mt.${SOSUFFIX}"
+ fi
+ if [ -f "$fn-d.${SOSUFFIX}" ] ; then
+ dosym "$fn-d.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}-d.${SOSUFFIX}"
+ fi
+ if [ -f "$fn-mt-d.${SOSUFFIX}" ] ; then
+ dosym "$fn-mt-d.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}-mt-d.${SOSUFFIX}"
+ fi
+ done
+
+ for fn in `ls -1 *.a| cut -d- -f1 | sort | uniq`; do
+ if [ -f "$fn.a" ] ; then
+ dosym "$fn.a" "/usr/lib/$fn-${TOOLSET_NAME}.a"
+ fi
+ if [ -f "$fn-mt.a" ] ; then
+ dosym "$fn-mt.a" "/usr/lib/$fn-${TOOLSET_NAME}-mt.a"
+ fi
+ if [ -f "$fn-d.a" ] ; then
+ dosym "$fn-d.a" "/usr/lib/$fn-${TOOLSET_NAME}-d.a"
+ fi
+ if [ -f "$fn-mt-d.a" ] ; then
+ dosym "$fn-mt-d.a" "/usr/lib/$fn-${TOOLSET_NAME}-mt-d.a"
+ fi
+ done
+
+ [[ $(get_libdir) == "lib" ]] || mv "${D}/usr/lib" "${D}/usr/$(get_libdir)"
+
+ if use pyste; then
+ cd "${S}/libs/python/pyste/install"
+ distutils_src_install
+ fi
+
+ if use bcp; then
+ cd "${S}/tools/bcp/run/"
+ exeinto /usr/bin
+ doexe bcp || die "bcp install failed"
+ fi
+
+ if use bjam; then
+ cd "${S}"/tools/build/jam_src/bin.*/
+ exeinto /usr/bin
+ doexe bjam || die "bjam install failed"
+ fi
+}
diff --git a/dev-libs/boost/files/digest-boost-1.33.1 b/dev-libs/boost/files/digest-boost-1.33.1
new file mode 100644
index 000000000000..bfe998337449
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.33.1
@@ -0,0 +1 @@
+MD5 2b999b2fb7798e1737d1fff8fac602ef boost_1_33_1.tar.bz2 11507161