summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-10-02 22:48:00 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-10-02 22:48:00 +0000
commit4074467223d6e0dedb817b7ed04750f00cbee0b6 (patch)
treed0d72c14b6a84d86f40c1934efe37587538f7b7e /dev-libs
parentFix missing soname for libbdelta.so (bug #436990 by Ilya Gordeev). (diff)
downloadhistorical-4074467223d6e0dedb817b7ed04750f00cbee0b6.tar.gz
historical-4074467223d6e0dedb817b7ed04750f00cbee0b6.tar.bz2
historical-4074467223d6e0dedb817b7ed04750f00cbee0b6.zip
Remove older versions
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian-bindings/ChangeLog8
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.2.10.ebuild173
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.2.8.ebuild177
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.2.9.ebuild173
-rw-r--r--dev-libs/xapian/ChangeLog6
-rw-r--r--dev-libs/xapian/xapian-1.2.10.ebuild63
-rw-r--r--dev-libs/xapian/xapian-1.2.5.ebuild29
-rw-r--r--dev-libs/xapian/xapian-1.2.8.ebuild63
-rw-r--r--dev-libs/xapian/xapian-1.2.9.ebuild63
9 files changed, 11 insertions, 744 deletions
diff --git a/dev-libs/xapian-bindings/ChangeLog b/dev-libs/xapian-bindings/ChangeLog
index 9748a91e72f8..d3d7e7dabdd7 100644
--- a/dev-libs/xapian-bindings/ChangeLog
+++ b/dev-libs/xapian-bindings/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/xapian-bindings
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.43 2012/09/19 09:44:44 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.44 2012/10/02 22:48:00 blueness Exp $
+
+ 02 Oct 2012; Anthony G. Basile <blueness@gentoo.org>
+ -xapian-bindings-1.2.10.ebuild, -xapian-bindings-1.2.8.ebuild,
+ -xapian-bindings-1.2.9.ebuild:
+ Remove older versions
19 Sep 2012; Johannes Huber <johu@gentoo.org> xapian-bindings-1.2.12.ebuild:
Stable for x86, wrt bug #434564
@@ -233,4 +238,3 @@
+files/xapian-bindings-0.9.5-skip-csharp-test.patch, +metadata.xml,
+xapian-bindings-0.9.5.ebuild:
New package.
-
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.2.10.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.2.10.ebuild
deleted file mode 100644
index b03c6977bd03..000000000000
--- a/dev-libs/xapian-bindings/xapian-bindings-1.2.10.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/xapian-bindings-1.2.10.ebuild,v 1.1 2012/05/10 09:10:39 blueness Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="python? 2"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-PHP_EXT_NAME="xapian"
-PHP_EXT_INI="yes"
-PHP_EXT_OPTIONAL_USE="php"
-
-inherit java-pkg-opt-2 mono php-ext-source-r2 python
-
-DESCRIPTION="SWIG and JNI bindings for Xapian"
-HOMEPAGE="http://www.xapian.org/"
-SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="java lua mono perl php python ruby tcl"
-
-COMMONDEPEND="=dev-libs/xapian-${PV}*
- lua? ( >=dev-lang/lua-5.1 )
- mono? ( >=dev-lang/mono-1.0.8 )
- perl? ( dev-lang/perl )
- ruby? ( dev-lang/ruby )
- tcl? ( >=dev-lang/tcl-8.1 )"
-DEPEND="${COMMONDEPEND}
- java? ( >=virtual/jdk-1.3 )"
-RDEPEND="${COMMONDEPEND}
- java? ( >=virtual/jre-1.3 )"
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
-
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- java-pkg-opt-2_src_prepare
- if use java; then
- sed \
- -e 's/$(JAVAC)/$(JAVAC) $(JAVACFLAGS)/' \
- -i java{/,/org/xapian/errors/,/org/xapian/}Makefile.in || die "sed failed"
- fi
-
- if use python; then
- sed \
- -e 's:\(^pkgpylib_DATA = xapian/__init__.py\).*:\1:' \
- -e 's|\(^xapian/__init__.py: modern/xapian.py\)|\1 xapian/_xapian$(PYTHON_SO)|' \
- -i python/Makefile.in || die "sed failed"
- fi
-}
-
-src_configure() {
- if use java; then
- CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
- fi
-
- if use perl; then
- export PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
- export PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
- fi
-
- if use lua; then
- export LUA_LIB="$(pkg-config --variable=INSTALL_CMOD lua)"
- fi
-
- econf \
- $(use_with java) \
- $(use_with lua) \
- $(use_with mono csharp) \
- $(use_with perl) \
- $(use_with php) \
- $(use_with python) \
- $(use_with ruby) \
- $(use_with tcl)
-
- # Python bindings are built/tested/installed manually.
- sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile"
-}
-
-src_compile() {
- default
-
- if use python; then
- python_copy_sources python
- building() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian"
- }
- python_execute_function -s --source-dir python building
- fi
-}
-
-src_test() {
- default
-
- if use python; then
- testing() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian" \
- VERBOSE="1" \
- check
- }
- python_execute_function -s --source-dir python testing
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use java; then
- java-pkg_dojar java/built/xapian_jni.jar
- # TODO: make the build system not install this...
- java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so"
- rm "${D}/${S}/java/built/libxapian_jni.so"
- rmdir -p "${D}/${S}/java/built"
- rmdir -p "${D}/${S}/java/native"
- fi
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian" \
- install
- }
- python_execute_function -s --source-dir python installation
- fi
-
- if use php; then
- php-ext-source-r2_createinifiles
- fi
-
- # For some USE combinations this directory is not created
- if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
- mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
- fi
-
- dodoc AUTHORS HACKING NEWS TODO README || die "dodoc failed"
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize xapian
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup xapian
- fi
-}
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.2.8.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.2.8.ebuild
deleted file mode 100644
index 4c6f256c9b64..000000000000
--- a/dev-libs/xapian-bindings/xapian-bindings-1.2.8.ebuild
+++ /dev/null
@@ -1,177 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/xapian-bindings-1.2.8.ebuild,v 1.5 2012/03/08 09:29:46 phajdan.jr Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-PHP_EXT_NAME="xapian"
-PHP_EXT_INI="yes"
-PHP_EXT_OPTIONAL_USE="php"
-
-inherit java-pkg-opt-2 mono php-ext-source-r2 python autotools
-
-DESCRIPTION="SWIG and JNI bindings for Xapian"
-HOMEPAGE="http://www.xapian.org/"
-SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="java lua mono perl php python ruby tcl"
-
-COMMONDEPEND="=dev-libs/xapian-${PV}*
- lua? ( >=dev-lang/lua-5.1 )
- mono? ( >=dev-lang/mono-1.0.8 )
- perl? ( dev-lang/perl )
- ruby? ( dev-lang/ruby )
- tcl? ( >=dev-lang/tcl-8.1 )"
-DEPEND="${COMMONDEPEND}
- java? ( >=virtual/jdk-1.3 )"
-RDEPEND="${COMMONDEPEND}
- java? ( >=virtual/jre-1.3 )"
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
-
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use lua; then
- epatch "${FILESDIR}"/fix-LUA_LIB-envvar.patch
- eautoreconf
- fi
-
- java-pkg-opt-2_src_prepare
- if use java; then
- sed \
- -e 's/$(JAVAC)/$(JAVAC) $(JAVACFLAGS)/' \
- -i java{/,/org/xapian/errors/,/org/xapian/}Makefile.in || die "sed failed"
- fi
-
- if use python; then
- sed \
- -e 's:\(^pkgpylib_DATA = xapian/__init__.py\).*:\1:' \
- -e 's|\(^xapian/__init__.py: modern/xapian.py\)|\1 xapian/_xapian$(PYTHON_SO)|' \
- -i python/Makefile.in || die "sed failed"
- fi
-}
-
-src_configure() {
- if use java; then
- CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
- fi
-
- if use perl; then
- export PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
- export PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
- fi
-
- if use lua; then
- export LUA_LIB="$(pkg-config --variable=INSTALL_CMOD lua)"
- fi
-
- econf \
- $(use_with java) \
- $(use_with lua) \
- $(use_with mono csharp) \
- $(use_with perl) \
- $(use_with php) \
- $(use_with python) \
- $(use_with ruby) \
- $(use_with tcl)
-
- # Python bindings are built/tested/installed manually.
- sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile"
-}
-
-src_compile() {
- default
-
- if use python; then
- python_copy_sources python
- building() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian"
- }
- python_execute_function -s --source-dir python building
- fi
-}
-
-src_test() {
- default
-
- if use python; then
- testing() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian" \
- VERBOSE="1" \
- check
- }
- python_execute_function -s --source-dir python testing
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use java; then
- java-pkg_dojar java/built/xapian_jni.jar
- # TODO: make the build system not install this...
- java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so"
- rm "${D}/${S}/java/built/libxapian_jni.so"
- rmdir -p "${D}/${S}/java/built"
- rmdir -p "${D}/${S}/java/native"
- fi
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian" \
- install
- }
- python_execute_function -s --source-dir python installation
- fi
-
- if use php; then
- php-ext-source-r2_createinifiles
- fi
-
- # For some USE combinations this directory is not created
- if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
- mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
- fi
-
- dodoc AUTHORS HACKING NEWS TODO README || die "dodoc failed"
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize xapian
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup xapian
- fi
-}
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.2.9.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.2.9.ebuild
deleted file mode 100644
index 68ba6f3ecbc4..000000000000
--- a/dev-libs/xapian-bindings/xapian-bindings-1.2.9.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/xapian-bindings-1.2.9.ebuild,v 1.2 2012/03/14 02:23:50 blueness Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="python? 2"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-PHP_EXT_NAME="xapian"
-PHP_EXT_INI="yes"
-PHP_EXT_OPTIONAL_USE="php"
-
-inherit java-pkg-opt-2 mono php-ext-source-r2 python
-
-DESCRIPTION="SWIG and JNI bindings for Xapian"
-HOMEPAGE="http://www.xapian.org/"
-SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="java lua mono perl php python ruby tcl"
-
-COMMONDEPEND="=dev-libs/xapian-${PV}*
- lua? ( >=dev-lang/lua-5.1 )
- mono? ( >=dev-lang/mono-1.0.8 )
- perl? ( dev-lang/perl )
- ruby? ( dev-lang/ruby )
- tcl? ( >=dev-lang/tcl-8.1 )"
-DEPEND="${COMMONDEPEND}
- java? ( >=virtual/jdk-1.3 )"
-RDEPEND="${COMMONDEPEND}
- java? ( >=virtual/jre-1.3 )"
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
-
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- java-pkg-opt-2_src_prepare
- if use java; then
- sed \
- -e 's/$(JAVAC)/$(JAVAC) $(JAVACFLAGS)/' \
- -i java{/,/org/xapian/errors/,/org/xapian/}Makefile.in || die "sed failed"
- fi
-
- if use python; then
- sed \
- -e 's:\(^pkgpylib_DATA = xapian/__init__.py\).*:\1:' \
- -e 's|\(^xapian/__init__.py: modern/xapian.py\)|\1 xapian/_xapian$(PYTHON_SO)|' \
- -i python/Makefile.in || die "sed failed"
- fi
-}
-
-src_configure() {
- if use java; then
- CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
- fi
-
- if use perl; then
- export PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
- export PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
- fi
-
- if use lua; then
- export LUA_LIB="$(pkg-config --variable=INSTALL_CMOD lua)"
- fi
-
- econf \
- $(use_with java) \
- $(use_with lua) \
- $(use_with mono csharp) \
- $(use_with perl) \
- $(use_with php) \
- $(use_with python) \
- $(use_with ruby) \
- $(use_with tcl)
-
- # Python bindings are built/tested/installed manually.
- sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile"
-}
-
-src_compile() {
- default
-
- if use python; then
- python_copy_sources python
- building() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian"
- }
- python_execute_function -s --source-dir python building
- fi
-}
-
-src_test() {
- default
-
- if use python; then
- testing() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian" \
- VERBOSE="1" \
- check
- }
- python_execute_function -s --source-dir python testing
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use java; then
- java-pkg_dojar java/built/xapian_jni.jar
- # TODO: make the build system not install this...
- java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so"
- rm "${D}/${S}/java/built/libxapian_jni.so"
- rmdir -p "${D}/${S}/java/built"
- rmdir -p "${D}/${S}/java/native"
- fi
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian" \
- install
- }
- python_execute_function -s --source-dir python installation
- fi
-
- if use php; then
- php-ext-source-r2_createinifiles
- fi
-
- # For some USE combinations this directory is not created
- if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
- mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
- fi
-
- dodoc AUTHORS HACKING NEWS TODO README || die "dodoc failed"
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize xapian
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup xapian
- fi
-}
diff --git a/dev-libs/xapian/ChangeLog b/dev-libs/xapian/ChangeLog
index 07fe060552d9..04e7bfdc0827 100644
--- a/dev-libs/xapian/ChangeLog
+++ b/dev-libs/xapian/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/xapian
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.87 2012/09/19 09:41:40 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.88 2012/10/02 22:46:46 blueness Exp $
+
+ 02 Oct 2012; Anthony G. Basile <blueness@gentoo.org> -xapian-1.2.10.ebuild,
+ -xapian-1.2.5.ebuild, -xapian-1.2.8.ebuild, -xapian-1.2.9.ebuild:
+ Remove older versions
19 Sep 2012; Johannes Huber <johu@gentoo.org> xapian-1.2.12.ebuild:
Stable for x86, wrt bug #434564
diff --git a/dev-libs/xapian/xapian-1.2.10.ebuild b/dev-libs/xapian/xapian-1.2.10.ebuild
deleted file mode 100644
index 0c511c1ac098..000000000000
--- a/dev-libs/xapian/xapian-1.2.10.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.10.ebuild,v 1.1 2012/05/10 08:59:58 blueness Exp $
-
-EAPI="4"
-
-MY_P="${PN}-core-${PV}"
-
-DESCRIPTION="Xapian Probabilistic Information Retrieval library"
-HOMEPAGE="http://www.xapian.org/"
-SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc static-libs -sse +sse2 +brass +chert +flint +inmemory +remote"
-
-DEPEND="sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local myconf=""
-
- ewarn
- if use sse2; then
- ewarn "Using sse2"
- myconf="${myconf} --enable-sse=sse2"
- else
- if use sse; then
- ewarn "Using sse"
- myconf="${myconf} --enable-sse=sse"
- else
- ewarn "Disabling sse and sse2"
- myconf="${myconf} --disable-sse"
- fi
- fi
- ewarn
-
- myconf="${myconf} $(use_enable static-libs static)"
-
- use brass || myconf="${myconf} --disable-backend-brass"
- use chert || myconf="${myconf} --disable-backend-chert"
- use flint || myconf="${myconf} --disable-backend-flint"
- use inmemory || myconf="${myconf} --disable-backend-inmemory"
- use remote || myconf="${myconf} --disable-backend-remote"
-
- econf $myconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
- use doc || rm -rf "${D}usr/share/doc/${PF}"
-
- dodoc AUTHORS HACKING PLATFORMS README NEWS
-}
-
-src_test() {
- emake check VALGRIND=
-}
diff --git a/dev-libs/xapian/xapian-1.2.5.ebuild b/dev-libs/xapian/xapian-1.2.5.ebuild
deleted file mode 100644
index 123f594ffb16..000000000000
--- a/dev-libs/xapian/xapian-1.2.5.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.5.ebuild,v 1.5 2012/03/15 10:05:41 blueness Exp $
-
-EAPI="3"
-
-MY_P="${PN}-core-${PV}"
-
-DESCRIPTION="Xapian Probabilistic Information Retrieval library"
-HOMEPAGE="http://www.xapian.org/"
-SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="ppc"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
-
- dodoc AUTHORS HACKING PLATFORMS README NEWS || die "dodoc failed"
-}
diff --git a/dev-libs/xapian/xapian-1.2.8.ebuild b/dev-libs/xapian/xapian-1.2.8.ebuild
deleted file mode 100644
index 4080481517f1..000000000000
--- a/dev-libs/xapian/xapian-1.2.8.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.8.ebuild,v 1.5 2012/02/24 14:44:54 phajdan.jr Exp $
-
-EAPI=4
-
-MY_P="${PN}-core-${PV}"
-
-DESCRIPTION="Xapian Probabilistic Information Retrieval library"
-HOMEPAGE="http://www.xapian.org/"
-SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc static-libs -sse +sse2 +brass +chert +flint +inmemory +remote"
-
-DEPEND="sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local myconf=""
-
- ewarn
- if use sse2; then
- ewarn "Using sse2"
- myconf="${myconf} --enable-sse=sse2"
- else
- if use sse; then
- ewarn "Using sse"
- myconf="${myconf} --enable-sse=sse"
- else
- ewarn "Disabling sse and sse2"
- myconf="${myconf} --disable-sse"
- fi
- fi
- ewarn
-
- myconf="${myconf} $(use_enable static-libs static)"
-
- use brass || myconf="${myconf} --disable-backend-brass"
- use chert || myconf="${myconf} --disable-backend-chert"
- use flint || myconf="${myconf} --disable-backend-flint"
- use inmemory || myconf="${myconf} --disable-backend-inmemory"
- use remote || myconf="${myconf} --disable-backend-remote"
-
- econf $myconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
- use doc || rm -rf "${D}usr/share/doc/${PF}"
-
- dodoc AUTHORS HACKING PLATFORMS README NEWS
-}
-
-src_test() {
- emake check VALGRIND=
-}
diff --git a/dev-libs/xapian/xapian-1.2.9.ebuild b/dev-libs/xapian/xapian-1.2.9.ebuild
deleted file mode 100644
index 7b48f33cc0b8..000000000000
--- a/dev-libs/xapian/xapian-1.2.9.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.9.ebuild,v 1.2 2012/03/14 02:21:24 blueness Exp $
-
-EAPI="4"
-
-MY_P="${PN}-core-${PV}"
-
-DESCRIPTION="Xapian Probabilistic Information Retrieval library"
-HOMEPAGE="http://www.xapian.org/"
-SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc static-libs -sse +sse2 +brass +chert +flint +inmemory +remote"
-
-DEPEND="sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local myconf=""
-
- ewarn
- if use sse2; then
- ewarn "Using sse2"
- myconf="${myconf} --enable-sse=sse2"
- else
- if use sse; then
- ewarn "Using sse"
- myconf="${myconf} --enable-sse=sse"
- else
- ewarn "Disabling sse and sse2"
- myconf="${myconf} --disable-sse"
- fi
- fi
- ewarn
-
- myconf="${myconf} $(use_enable static-libs static)"
-
- use brass || myconf="${myconf} --disable-backend-brass"
- use chert || myconf="${myconf} --disable-backend-chert"
- use flint || myconf="${myconf} --disable-backend-flint"
- use inmemory || myconf="${myconf} --disable-backend-inmemory"
- use remote || myconf="${myconf} --disable-backend-remote"
-
- econf $myconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
- use doc || rm -rf "${D}usr/share/doc/${PF}"
-
- dodoc AUTHORS HACKING PLATFORMS README NEWS
-}
-
-src_test() {
- emake check VALGRIND=
-}