summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-04-08 16:26:14 +0000
committerPeter Gavin <pete@gentoo.org>2001-04-08 16:26:14 +0000
commit3184130f61f9de926cfde4cf0d9b7eaf7bfa8a5c (patch)
treed91b0e7bbce3e92d02ad408258c179c0d17f479f /dev-libs
parentsys-apps/autoconf build dep fix (diff)
downloadhistorical-3184130f61f9de926cfde4cf0d9b7eaf7bfa8a5c.tar.gz
historical-3184130f61f9de926cfde4cf0d9b7eaf7bfa8a5c.tar.bz2
historical-3184130f61f9de926cfde4cf0d9b7eaf7bfa8a5c.zip
added glib-1.2.10, ORBit-0.5.7-r1 gnome-libs-1.2.13 imlib-1.9.10
gtk+-1.2.10, some digests, fixed linux-sources-2.4.2.{13,27}-r1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/glib/glib-1.2.10.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-1.2.10.ebuild b/dev-libs/glib/glib-1.2.10.ebuild
new file mode 100644
index 000000000000..a1945ea5cd87
--- /dev/null
+++ b/dev-libs/glib/glib-1.2.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10.ebuild,v 1.1 2001/04/08 16:26:14 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The GLib library of C routines"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${A}
+ ftp://ftp.gnome.org/pub/GNOME/stable/sources/glib/${A}
+ http://ftp.gnome.org/pub/GNOME/stable/sources/glib/${A}"
+HOMEPAGE="http://www.gtk.org/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf
+
+ if [ "${DEBUG}" ]
+ then
+ myconf="--enable-debug=yes"
+ else
+ myconf="--enable-debug=no"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-threads=posix ${myconf}
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS
+ cd docs
+ docinto html
+ dodoc glib.html glib_toc.html
+}
+
+
+
+
+