summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-24 10:19:23 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-24 10:19:23 +0000
commit0ec44f79ea12d8621d4ad19e43b5cfb62f0ddc1b (patch)
treeadb3697946f660cd416d00439b247ec4f001802c /dev-libs
parent3.0.11 - x86/amd64 stable, bug 199738. Remove old from the tree. (diff)
downloadhistorical-0ec44f79ea12d8621d4ad19e43b5cfb62f0ddc1b.tar.gz
historical-0ec44f79ea12d8621d4ad19e43b5cfb62f0ddc1b.tar.bz2
historical-0ec44f79ea12d8621d4ad19e43b5cfb62f0ddc1b.zip
old/broken
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/DirectFB/DirectFB-1.1.0.ebuild134
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.1.0-headers.patch46
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.1.0-pkgconfig.patch22
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-1.1.06
4 files changed, 0 insertions, 208 deletions
diff --git a/dev-libs/DirectFB/DirectFB-1.1.0.ebuild b/dev-libs/DirectFB/DirectFB-1.1.0.ebuild
deleted file mode 100644
index 7f471ee1b67c..000000000000
--- a/dev-libs/DirectFB/DirectFB-1.1.0.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.1.0.ebuild,v 1.2 2007/12/08 18:50:44 vapier Exp $
-
-inherit eutils toolchain-funcs
-
-IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 i830 mach64 matrox neomagic nsc nvidia radeon savage sis315 tdfx unichrome"
-IUSE_INPUT_DEVICES="dbox2remote elo-input gunze h3600_ts joystick keyboard dreamboxremote linuxinput lirc mutouch none permount ps2mouse serialmouse sonypijogdial wm97xx"
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz
- mirror://gentoo/DirectFB-1.1.0-upstream-git-gfxdrivers-fixes.patch.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
-IUSE="debug fbcon fusion gif jpeg mmx png sdl sse sysfs truetype v4l v4l2 zlib"
-
-# fusion? ( >=dev-libs/linux-fusion-7.0.1 )
-DEPEND="sdl? ( media-libs/libsdl )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- sysfs? ( sys-fs/sysfsutils )
- zlib? ( sys-libs/zlib )
- truetype? ( >=media-libs/freetype-2.0.1 )"
-
-pkg_setup() {
- if [[ -z ${VIDEO_CARDS} ]] ; then
- ewarn "All video drivers will be built since you did not specify"
- ewarn "via the VIDEO_CARDS variable what video card you use."
- ewarn "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
- echo
- fi
- if [[ -z ${INPUT_DEVICES} ]] ; then
- ewarn "All input drivers will be built since you did not specify"
- ewarn "via the INPUT_DEVICES variable which input drivers to use."
- ewarn "DirectFB supports: ${IUSE_INPUT_DEVICES} all none"
- echo
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${WORKDIR}"/${P}-upstream-git-gfxdrivers-fixes.patch
- epatch "${FILESDIR}"/${PN}-0.9.24-CFLAGS.patch
- epatch "${FILESDIR}"/${P}-headers.patch
- epatch "${FILESDIR}"/${P}-pkgconfig.patch
-
- # This is only a partial fix to the X11 order issue #201626. It's just
- # the only part we need in order to make the issue go away. Upstream
- # bug tracker is currently broken, so list things to do here:
- # configure.in:
- # - only add -I/usr/X11R6/include to X11_CFLAGS as needed
- # - only add -L/usr/X11R6/lib to X11_LIBS as needed
- # systems/x11/Makefile.am:
- # - add $(X11_LIBS) to end of _LIBADD variables
- sed -i \
- -e '/X11_LIBS/s:-L/usr/X11R6/lib::' \
- -e '/CFLAGS/s:-I/usr/X11R6/include::' \
- configure
-}
-
-src_compile() {
- local vidcards card input inputdrivers
- for card in ${VIDEO_CARDS} ; do
- has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
- #use video_cards_${card} && vidcards="${vidcards},${card}"
- done
- [[ -z ${vidcards} ]] \
- && vidcards="all" \
- || vidcards=${vidcards:1}
- for input in ${INPUT_DEVICES} ; do
- has ${input} ${IUSE_INPUT_DEVICES} && inputdrivers="${inputdrivers},${input}"
- #use input_devics_${input} && inputdrivers="${inputdrivers},${input}"
- done
- [[ -z ${inputdrivers} ]] \
- && inputdrivers="all" \
- || inputdrivers=${inputdrivers:1}
-
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- econf \
- --enable-static \
- $(use_enable fbcon fbdev) \
- $(use_enable mmx) \
- $(use_enable sse) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable gif) \
- $(use_enable truetype freetype) \
- $(use_enable fusion multi) \
- $(use_enable debug) \
- $(use_enable sysfs) \
- $(use_enable zlib) \
- $(use_enable v4l video4linux) \
- $(use_enable v4l2 video4linux2) \
- ${sdlconf} \
- --with-gfxdrivers="${vidcards}" \
- --with-inputdrivers="${inputdrivers}" \
- --disable-vnc \
- || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc fb.modes AUTHORS ChangeLog NEWS README* TODO
- dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update in the 0.9.xx series"
- ewarn "breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
- ewarn
- ewarn "If you have an ALPS touchpad, then you might"
- ewarn "get your mouse unexpectedly set in absolute"
- ewarn "mode in all DirectFB applications."
- ewarn "This can be fixed by removing linuxinput from"
- ewarn "INPUT_DEVICES."
-}
diff --git a/dev-libs/DirectFB/files/DirectFB-1.1.0-headers.patch b/dev-libs/DirectFB/files/DirectFB-1.1.0-headers.patch
deleted file mode 100644
index 0e93de3c9d7f..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.1.0-headers.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Don't rely on the kernel to tell us what the cpu target is ... we'll just
-use the default values all the time instead.
-
-http://bugs.gentoo.org/152614
-
---- lib/direct/ppcasm_memcpy_cachable.S
-+++ lib/direct/ppcasm_memcpy_cachable.S
-@@ -34,8 +34,6 @@
-
- #define __ASSEMBLY__
-
--#include <linux/config.h>
--
- #if defined(CONFIG_8xx) || defined(CONFIG_403GCX)
- #define L1_CACHE_LINE_SIZE 16
- #define LG_L1_CACHE_LINE_SIZE 4
-
-Don't pollute the namespace with define hacks, just use the real deal.
-
---- include/dfb_types.h
-+++ include/dfb_types.h
-@@ -60,6 +60,8 @@
-
- #endif
-
-+#include <asm/types.h>
-+#define DIRECTFB_NO_CRUFT
- #ifndef DIRECTFB_NO_CRUFT
- #define __u8 u8
- #define __u16 u16
-
-some arches (*cough* powerpc *cough*) are retarded and export a completely
-worthless asm/page.h ... so set a fallback for PAGE_SIZE
-
---- lib/direct/system.c
-+++ lib/direct/system.c
-@@ -35,7 +35,8 @@
-
- #if HAVE_ASM_PAGE_H
- #include <asm/page.h>
--#else
-+#endif
-+#ifndef PAGE_SIZE
- #define PAGE_SIZE sysconf( _SC_PAGESIZE )
- #endif
-
diff --git a/dev-libs/DirectFB/files/DirectFB-1.1.0-pkgconfig.patch b/dev-libs/DirectFB/files/DirectFB-1.1.0-pkgconfig.patch
deleted file mode 100644
index f28d263fa79e..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.1.0-pkgconfig.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-http://bugs.gentoo.org/200661
-
---- DirectFB/directfb-config.in
-+++ DirectFB/directfb-config.in
-@@ -300,7 +300,7 @@
- libs=-L@libdir@
-
- if test "$lib_directfb" = "yes"; then
-- libs="$libs -ldirectfb -lfusion -ldirect @THREADLIB@ @ZLIB_LIBS@"
-+ libs="$libs -ldirectfb -lfusion -ldirect @THREADLIB@ @ZLIB_LIBS@ @SYSFS_LIBS@"
-
- if test -z "$echo_static"; then
- libs="$libs @DYNLIB@"
---- DirectFB/directfb.pc.in
-+++ DirectFB/directfb.pc.in
-@@ -7,5 +7,5 @@
- Description: Graphics and windowing library for the Linux frame buffer device
- Version: @VERSION@
- Requires: fusion direct
--Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
-+Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @SYSFS_LIBS@ @OSX_LIBS@
- Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-1.1.0 b/dev-libs/DirectFB/files/digest-DirectFB-1.1.0
deleted file mode 100644
index 56d66956d5fb..000000000000
--- a/dev-libs/DirectFB/files/digest-DirectFB-1.1.0
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 4d05469904126e9cd60e5d36970775bc DirectFB-1.1.0-upstream-git-gfxdrivers-fixes.patch.bz2 7167
-RMD160 08327bca85e6d133c282e1da19addba46adf6102 DirectFB-1.1.0-upstream-git-gfxdrivers-fixes.patch.bz2 7167
-SHA256 b009646ad5fc4131f73ffa549258fbfcb5ca6ff8bf93aa2abfcea5d4fa639fb8 DirectFB-1.1.0-upstream-git-gfxdrivers-fixes.patch.bz2 7167
-MD5 da30fa2748c7501913c8832a83e654ab DirectFB-1.1.0.tar.gz 2624473
-RMD160 9e5dd3b44ec828dd1b2cc739d14670d7d9e7f7a9 DirectFB-1.1.0.tar.gz 2624473
-SHA256 0ee87256a278079955d78e4f235c15a174afbb507b5434f1966cd3e5f5a3f23a DirectFB-1.1.0.tar.gz 2624473