summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-16 21:41:17 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-16 21:41:17 +0000
commitf1508bb7e582d86c0eac6228b116c4a3ef1e122d (patch)
tree3afe32df87eeca36ce8d28f9b628e3ce96ed1026 /dev-libs/openssl
parentModified molscript that uses POV-Ray, does thermal ellipsoids, and more. (diff)
downloadhistorical-f1508bb7e582d86c0eac6228b116c4a3ef1e122d.tar.gz
historical-f1508bb7e582d86c0eac6228b116c4a3ef1e122d.tar.bz2
historical-f1508bb7e582d86c0eac6228b116c4a3ef1e122d.zip
Remove USE=sse2 for now as it breaks ABI #147758 by Andrew Stimpson.
Package-Manager: portage-2.1.1
Diffstat (limited to 'dev-libs/openssl')
-rw-r--r--dev-libs/openssl/ChangeLog8
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.8c-r13
-rw-r--r--dev-libs/openssl/openssl-0.9.8c-r1.ebuild170
3 files changed, 180 insertions, 1 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index 8becda351e12..aab2bab1841d 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/openssl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.191 2006/09/15 01:28:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.192 2006/09/16 21:41:17 vapier Exp $
+
+*openssl-0.9.8c-r1 (16 Sep 2006)
+
+ 16 Sep 2006; Mike Frysinger <vapier@gentoo.org> -openssl-0.9.8c.ebuild,
+ +openssl-0.9.8c-r1.ebuild:
+ Remove USE=sse2 for now as it breaks ABI #147758 by Andrew Stimpson.
15 Sep 2006; Mike Frysinger <vapier@gentoo.org> files/gentoo.config-0.9.8,
openssl-0.9.8c.ebuild:
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.8c-r1 b/dev-libs/openssl/files/digest-openssl-0.9.8c-r1
new file mode 100644
index 000000000000..95a35c845cc7
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.8c-r1
@@ -0,0 +1,3 @@
+MD5 78454bec556bcb4c45129428a766c886 openssl-0.9.8c.tar.gz 3313857
+RMD160 718e487a7c874fbc79081cbbee4ec5fdc3387aa6 openssl-0.9.8c.tar.gz 3313857
+SHA256 896f7830c1921688f22c6fe4fb3d7b75189cefdd79acca5fb0cad2b599139048 openssl-0.9.8c.tar.gz 3313857
diff --git a/dev-libs/openssl/openssl-0.9.8c-r1.ebuild b/dev-libs/openssl/openssl-0.9.8c-r1.ebuild
new file mode 100644
index 000000000000..7628f4c48d11
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.8c-r1.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8c-r1.ebuild,v 1.1 2006/09/16 21:41:17 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+HOMEPAGE="http://www.openssl.org/"
+SRC_URI="mirror://openssl/source/${P}.tar.gz"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="-* alpha amd64 ~arm ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc x86"
+IUSE="bindist emacs test zlib"
+# This breaks ABI so we will wait until next ABI change to enable: sse2
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-apps/diffutils
+ >=dev-lang/perl-5
+ test? ( sys-devel/bc )"
+PDEPEND="app-misc/ca-certificates"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-0.9.8-ppc64.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7e-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8-hppa-fix-detection.patch
+ epatch "${FILESDIR}"/${PN}-0.9.7-alpha-default-gcc.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8b-parallel-build.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8-make-engines-dir.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8-toolchain.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8b-doc-updates.patch
+
+ # allow openssl to be cross-compiled
+ cp "${FILESDIR}"/gentoo.config-0.9.8 gentoo.config || die "cp cross-compile failed"
+ chmod a+rx gentoo.config
+
+ # Don't build manpages if we don't want them
+ has noman FEATURES \
+ && sed -i '/^install:/s:install_docs::' Makefile.org \
+ || sed -i '/^MANDIR=/s:=.*:=/usr/share/man:' Makefile.org
+
+ # Try to derice users
+ [[ $(gcc-major-version) == "3" ]] \
+ && filter-flags -fprefetch-loop-arrays -freduce-all-givs -funroll-loops
+ [[ $(tc-arch) == ppc* ]] && append-flags -fno-strict-aliasing
+ append-flags -Wa,--noexecstack
+
+ # using a library directory other than lib requires some magic
+ sed -i \
+ -e "s+\(\$(INSTALL_PREFIX)\$(INSTALLTOP)\)/lib+\1/$(get_libdir)+g" \
+ -e "s+libdir=\$\${exec_prefix}/lib+libdir=\$\${exec_prefix}/$(get_libdir)+g" \
+ Makefile.org engines/Makefile \
+ || die "sed failed"
+ ./config --test-sanity || die "I AM NOT SANE"
+}
+
+src_compile() {
+ tc-export CC AR RANLIB
+
+ # Clean out patent-or-otherwise-encumbered code
+ # MDC-2: 4,908,861 13/03/2007
+ # IDEA: 5,214,703 25/05/2010
+ # RC5: 5,724,428 03/03/2015
+ # EC: ????????? ??/??/2015
+ local confopts=""
+ if use bindist ; then
+ confopts="no-idea no-rc5 no-mdc2 no-ec"
+ else
+ confopts="enable-idea enable-rc5 enable-mdc2 enable-ec"
+ fi
+ use zlib && confopts="${confopts} zlib-dynamic"
+ #use sse2 || confopts="${confopts} no-sse2"
+
+ local sslout=$(./gentoo.config)
+ einfo "Use configuration ${sslout:-(openssl knows best)}"
+ local config="Configure"
+ [[ -z ${sslout} ]] && config="config"
+ ./${config} \
+ ${sslout} \
+ ${confopts} \
+ --prefix=/usr \
+ --openssldir=/etc/ssl \
+ shared threads \
+ || die "Configure failed"
+
+ # Clean out hardcoded flags that openssl uses
+ local CFLAG=$(grep ^CFLAG= Makefile | LC_ALL=C sed \
+ -e 's:^CFLAG=::' \
+ -e 's:-fomit-frame-pointer ::g' \
+ -e 's:-O[0-9] ::g' \
+ -e 's:-march=[-a-z0-9]* ::g' \
+ -e 's:-mcpu=[-a-z0-9]* ::g' \
+ -e 's:-m[a-z0-9]* ::g' \
+ )
+ sed -i -e "/^CFLAG/s:=.*:=${CFLAG} ${CFLAGS}:" Makefile || die
+
+ # depend is needed to use $confopts
+ # rehash is needed to prep the certs/ dir
+ emake -j1 depend || die "depend failed"
+ emake all rehash || die "make all failed"
+
+ # force until we get all the gentoo.config kinks worked out
+ if has test ${FEATURES} && ! tc-is-cross-compiler ; then
+ src_test
+ fi
+}
+
+src_test() {
+ # make sure sandbox doesnt die on *BSD
+ addpredict /dev/crypto
+
+ make test || die "make test failed"
+}
+
+src_install() {
+ make INSTALL_PREFIX="${D}" install || die
+ dodoc CHANGES* FAQ NEWS README doc/*.txt
+ dohtml doc/*
+
+ if use emacs ; then
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+ fi
+
+ # create the certs directory
+ dodir /etc/ssl/certs
+ cp -RP certs/* "${D}"/etc/ssl/certs/ || die "failed to install certs"
+ rm -r "${D}"/etc/ssl/certs/{demo,expired}
+
+ # Namespace openssl programs to prevent conflicts with other man pages
+ cd "${D}"/usr/share/man
+ local m d s
+ for m in $(find . -type f -printf '%P ' | xargs grep -L '#include') ; do
+ d=${m%/*} ; m=${m##*/}
+ mv ${d}/{,ssl-}${m}
+ ln -s ssl-${m} ${d}/openssl-${m}
+ # locate any symlinks that point to this man page
+ for s in $(find ${d} -lname ${m}) ; do
+ s=${s##*/}
+ rm -f ${d}/${s}
+ ln -s ssl-${m} ${d}/ssl-${s}
+ ln -s ssl-${s} ${d}/openssl-${s}
+ done
+ done
+
+ diropts -m0700
+ keepdir /etc/ssl/private
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/usr/$(get_libdir)/libcrypto.so.0.9.7 ]] ; then
+ cp -pPR "${ROOT}"/usr/$(get_libdir)/lib{crypto,ssl}.so.0.9.7 "${IMAGE}"/usr/$(get_libdir)/
+ fi
+}
+
+pkg_postinst() {
+ if [[ -e ${ROOT}/usr/$(get_libdir)/libcrypto.so.0.9.7 ]] ; then
+ ewarn "You must re-compile all packages that are linked against"
+ ewarn "OpenSSL 0.9.7 by using revdep-rebuild from gentoolkit:"
+ ewarn "# revdep-rebuild --library libssl.so.0.9.7"
+ ewarn "# revdep-rebuild --library libcrypto.so.0.9.7"
+ ewarn "After this, you can delete /usr/$(get_libdir)/libssl.so.0.9.7"
+ ewarn "and /usr/$(get_libdir)/libcrypto.so.0.9.7"
+ fi
+}