summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-07-10 19:00:53 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-07-10 19:00:53 +0000
commit82cc9eb28cebffa771bc49b4b8f689c313daa1eb (patch)
tree5d1639df0edd0fcece7f5176713989e5687f16fd /dev-libs/openssl
parentfix for umask stuff (diff)
downloadhistorical-82cc9eb28cebffa771bc49b4b8f689c313daa1eb.tar.gz
historical-82cc9eb28cebffa771bc49b4b8f689c313daa1eb.tar.bz2
historical-82cc9eb28cebffa771bc49b4b8f689c313daa1eb.zip
This is an updated package with a fix for the PRNG bug / exploit. More
information can be found here http://www.securityfocus.com/templates/archive.pike?list=1&start=2001-07-08&threads=0&end=2001-07-14&tid=195829& I think it would be best if packages were upgraded ASAP since so many daemons are linked against the affected code.
Diffstat (limited to 'dev-libs/openssl')
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.6b1
-rw-r--r--dev-libs/openssl/openssl-0.9.6b.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.6b b/dev-libs/openssl/files/digest-openssl-0.9.6b
new file mode 100644
index 000000000000..db16c437c4e8
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.6b
@@ -0,0 +1 @@
+MD5 bd8c4d8c5bafc7a4d55d152989fdb327 openssl-0.9.6b.tar.gz
diff --git a/dev-libs/openssl/openssl-0.9.6b.ebuild b/dev-libs/openssl/openssl-0.9.6b.ebuild
new file mode 100644
index 000000000000..201dd455dcd0
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.6b.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.6-r1.ebuild,v 1.1 2001/03/09 10:26:59 achim Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+SRC_URI="http://www.openssl.org/source/${A}"
+HOMEPAGE="http://www.opensl.org/"
+
+DEPEND="virtual/glibc >=sys-devel/perl-5"
+
+
+RDEPEND="virtual/glibc "
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-Makefile.org-gentoo.diff
+ cp Configure Configure.orig
+ sed -e "s/-O3/$CFLAGS/" -e "s/-m486//" \
+ Configure.orig > Configure
+
+}
+
+src_compile() {
+
+ ./config --prefix=/usr --openssldir=/usr/ssl shared threads
+ try make all
+}
+
+src_install() {
+ dodir /usr/ssl
+ try make INSTALL_PREFIX=${D} install
+
+ dodoc CHANGES* FAQ LICENSE NEWS README
+ dodoc doc/*.txt
+ docinto html
+ dodoc doc/*.gif doc/*.html
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+}
+
+
+