summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-09-26 06:25:31 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-09-26 06:25:31 +0000
commitfee544f7d4d61ea1a2c9133caa766cd359440f03 (patch)
treebef56ff213527a46ea6193459c8e54af86af2858 /dev-libs/nspr
parentarm stable (diff)
downloadhistorical-fee544f7d4d61ea1a2c9133caa766cd359440f03.tar.gz
historical-fee544f7d4d61ea1a2c9133caa766cd359440f03.tar.bz2
historical-fee544f7d4d61ea1a2c9133caa766cd359440f03.zip
old
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-libs/nspr')
-rw-r--r--dev-libs/nspr/nspr-4.6.7.ebuild95
1 files changed, 0 insertions, 95 deletions
diff --git a/dev-libs/nspr/nspr-4.6.7.ebuild b/dev-libs/nspr/nspr-4.6.7.ebuild
deleted file mode 100644
index 8406612657b0..000000000000
--- a/dev-libs/nspr/nspr-4.6.7.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.6.7.ebuild,v 1.11 2008/03/17 12:10:08 armin76 Exp $
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="Netscape Portable Runtime"
-HOMEPAGE="http://www.mozilla.org/projects/nspr/"
-SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v${PV}/src/${P}.tar.gz"
-
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="ipv6 debug"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- mkdir build inst
- epatch "${FILESDIR}"/${PN}-4.6.1-config.patch
- epatch "${FILESDIR}"/${PN}-4.6.1-config-1.patch
- epatch "${FILESDIR}"/${PN}-4.6.1-lang.patch
- epatch "${FILESDIR}"/${PN}-4.6.1-prtime.patch
-}
-
-src_compile() {
- cd build
-
- echo > "${T}"/test.c
- $(tc-getCC) -c "${T}"/test.c -o "${T}"/test.o
- case $(file "${T}"/test.o) in
- *64-bit*) myconf="${myconf} --enable-64bit";;
- *32-bit*) ;;
- *) die "FAIL";;
- esac
-
- if use ipv6; then
- myconf="${myconf} --enable-ipv6"
- fi
-
- myconf="${myconf} --libdir=/usr/$(get_libdir)/nspr"
-
- ECONF_SOURCE="../mozilla/nsprpub" econf \
- $(use_enable debug) \
- ${myconf} || die "econf failed"
- make || die
-}
-
-src_install () {
- # Their build system is royally fucked, as usual
- MINOR_VERSION=6
- cd "${S}/build"
- make install
- insinto /usr
- doins -r dist/*
- rm -rf "${D}"/usr/bin/lib*.so
-
- #removing includes/nspr/md as per fedora spec
- # i.e a waste of space!
- rm -rf "${D}/usr/include/nspr/md"
-
- # there have been /usr/lib/nspr changes (like the ldpath below), but never
- # have I seen any libraries end up in this directory. lets fix that.
- # note: I tried doing this fix via the build system. It wont work.
- if [ ! -e "${D}/usr/lib/nspr" ] ; then
- mkdir -p "${D}/usr/lib/nspr"
- mv "${D}"/usr/lib/*so* "${D}/usr/lib/nspr"
- mv "${D}"/usr/lib/*\.a "${D}/usr/lib/nspr"
- fi
- # and while we're at it, lets make it actually use the arch's libdir damnit
- if [ "lib" != "$(get_libdir)" ] ; then
- mv "${D}/usr/lib" "${D}/usr/$(get_libdir)"
- fi
- #and while at it move them to files with versions-ending
- #and link them back :)
- cd "${D}/usr/$(get_libdir)/nspr"
- for file in *.so; do
- mv ${file} ${file}.${MINOR_VERSION}
- ln -s ${file}.${MINOR_VERSION} ${file}
- done
- # cope with libraries being in /usr/lib/nspr
- dodir /etc/env.d
- echo "LDPATH=/usr/$(get_libdir)/nspr" > "${D}/etc/env.d/08nspr"
-
- # install nspr-config
- insinto /usr/bin
- doins "${S}/build/config/nspr-config"
- chmod a+x "${D}/usr/bin/nspr-config"
-
- # create pkg-config file
- insinto /usr/$(get_libdir)/pkgconfig/
- doins "${S}/build/config/nspr.pc"
-}