summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-11-25 04:54:46 +0000
committerTravis Tilley <lv@gentoo.org>2004-11-25 04:54:46 +0000
commiteeede441a682319afa82f63c1b94b6df8f73c114 (patch)
treef064ad2ab301b4d16392a1acb80e0a25c9796a7d /dev-libs/nspr/nspr-4.4.1-r2.ebuild
parentAdded src_test(). (diff)
downloadhistorical-eeede441a682319afa82f63c1b94b6df8f73c114.tar.gz
historical-eeede441a682319afa82f63c1b94b6df8f73c114.tar.bz2
historical-eeede441a682319afa82f63c1b94b6df8f73c114.zip
get_libdir-ized and made libnspr actually install to /usr/$(get_libdir)/nspr
Diffstat (limited to 'dev-libs/nspr/nspr-4.4.1-r2.ebuild')
-rw-r--r--dev-libs/nspr/nspr-4.4.1-r2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/nspr/nspr-4.4.1-r2.ebuild b/dev-libs/nspr/nspr-4.4.1-r2.ebuild
new file mode 100644
index 000000000000..7aec41596e3b
--- /dev/null
+++ b/dev-libs/nspr/nspr-4.4.1-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.4.1-r2.ebuild,v 1.1 2004/11/25 04:54:46 lv Exp $
+
+inherit eutils
+
+DESCRIPTION="Netscape Portable Runtime"
+HOMEPAGE="http://www.mozilla.org/projects/nspr/"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v${PV}/src/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ mkdir ${S}/build
+ mkdir ${S}/inst
+ if [ "${ARCH}" = "amd64" ]
+ then
+ cd ${S}; epatch ${FILESDIR}/${PN}-4.3-amd64.patch
+ elif [ "${ARCH}" = "hppa" ]
+ then
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-${PV}-hppa.patch
+ fi
+}
+src_compile() {
+ cd ${S}/build
+ ../mozilla/nsprpub/configure \
+ --host=${CHOST} \
+ --prefix=${S}/inst \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ make || die
+}
+
+src_install () {
+ # Their build system is royally fucked, as usual
+ cd ${S}/build
+ make install
+ dodir /usr
+ cp -rfL dist/* ${D}/usr
+ rm -rf ${D}/usr/bin/lib*.so
+
+ # there have been /usr/lib/nspr changes (like the ldpath below), but never
+ # have I seen any libraries end up in this directory. lets fix that.
+ # note: I tried doing this fix via the build system. It wont work.
+ if [ ! -e ${D}/usr/lib/nspr ] ; then
+ mkdir -p ${D}/usr/lib/nspr
+ mv ${D}/usr/lib/*so* ${D}/usr/lib/nspr
+ mv ${D}/usr/lib/*\.a ${D}/usr/lib/nspr
+ fi
+ # and while we're at it, lets make it actually use the arch's libdir damnit
+ if [ "lib" != "$(get_libdir)" ] ; then
+ mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+ fi
+
+ # cope with libraries being in /usr/lib/nspr
+ dodir /etc/env.d
+ echo "LDPATH=/usr/$(get_libdir)/nspr" > ${D}/etc/env.d/50nspr
+}
+