summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-03 02:07:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-03 02:07:52 +0000
commit01e18ed53205a440c59e14b7cdef2d92ad797f25 (patch)
treef95f368fd3ff4156776908d1c4b8201b2653fb47 /dev-libs/mapm/mapm-4.9.ebuild
parentVersion bump, closes #28790, 32446. (diff)
downloadhistorical-01e18ed53205a440c59e14b7cdef2d92ad797f25.tar.gz
historical-01e18ed53205a440c59e14b7cdef2d92ad797f25.tar.bz2
historical-01e18ed53205a440c59e14b7cdef2d92ad797f25.zip
initial ebuild #39949
Diffstat (limited to 'dev-libs/mapm/mapm-4.9.ebuild')
-rw-r--r--dev-libs/mapm/mapm-4.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/mapm/mapm-4.9.ebuild b/dev-libs/mapm/mapm-4.9.ebuild
new file mode 100644
index 000000000000..c88b82ab30b1
--- /dev/null
+++ b/dev-libs/mapm/mapm-4.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mapm/mapm-4.9.ebuild,v 1.1 2004/02/03 02:07:52 vapier Exp $
+
+DESCRIPTION="Mike's Arbitrary Precision Math Library"
+HOMEPAGE="http://www.tc.umn.edu/~ringx004/mapm-main.html"
+SRC_URI="http://www.tc.umn.edu/~ringx004/${P}.tar.gz"
+
+LICENSE="Freeware"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc"
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:-O2:${CFLAGS}:" make_linux_shared_lib
+}
+
+src_compile() {
+ ./make_linux_shared_lib || die
+}
+
+src_install() {
+ dolib.so libmapm.so.0
+ dosym libmapm.so.0 /usr/lib/libmapm.so
+
+ insinto /usr/include
+ doins m_apm.h
+
+ dodoc README article.pdf algorithms.used commentary.txt \
+ cpp_function.ref function.ref history.txt struct.ref
+}