summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-21 17:28:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-21 17:28:36 +0000
commita42d8be9d378c9801ad4ef9bd92a1854d648ebd8 (patch)
tree4453df9c6145c2b0c8b4ffb6a74a5f599eae9159 /dev-libs/libiconv
parentmark stable on x86 (diff)
downloadhistorical-a42d8be9d378c9801ad4ef9bd92a1854d648ebd8.tar.gz
historical-a42d8be9d378c9801ad4ef9bd92a1854d648ebd8.tar.bz2
historical-a42d8be9d378c9801ad4ef9bd92a1854d648ebd8.zip
Version bump and remove old versions. The new version uses hidden visibility when available (GCC 4.1).
Package-Manager: portage-2.1.1_pre3-r3
Diffstat (limited to 'dev-libs/libiconv')
-rw-r--r--dev-libs/libiconv/ChangeLog9
-rw-r--r--dev-libs/libiconv/files/digest-libiconv-1.113
-rw-r--r--dev-libs/libiconv/libiconv-1.11.ebuild67
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-libs/libiconv/ChangeLog b/dev-libs/libiconv/ChangeLog
index e9f9da72f572..e31769904b73 100644
--- a/dev-libs/libiconv/ChangeLog
+++ b/dev-libs/libiconv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libiconv
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/ChangeLog,v 1.19 2006/03/30 13:36:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/ChangeLog,v 1.20 2006/07/21 17:28:36 flameeyes Exp $
+
+*libiconv-1.11 (21 Jul 2006)
+
+ 21 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> -libiconv-1.10.ebuild,
+ -libiconv-1.10-r1.ebuild, +libiconv-1.11.ebuild:
+ Version bump and remove old versions. The new version uses hidden visibility
+ when available (GCC 4.1).
30 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
libiconv-1.10-r1.ebuild:
diff --git a/dev-libs/libiconv/files/digest-libiconv-1.11 b/dev-libs/libiconv/files/digest-libiconv-1.11
new file mode 100644
index 000000000000..06bf94a1f914
--- /dev/null
+++ b/dev-libs/libiconv/files/digest-libiconv-1.11
@@ -0,0 +1,3 @@
+MD5 b77a17e4a5a817100ad4b2613935055e libiconv-1.11.tar.gz 4430930
+RMD160 9adbcd61598bee2fbe4eb94ac3f35f83f568d9d0 libiconv-1.11.tar.gz 4430930
+SHA256 fbf5b9a63ea6e3abebfabc04506f0e18a2860071031e34ea4ad4f450b8c43d4b libiconv-1.11.tar.gz 4430930
diff --git a/dev-libs/libiconv/libiconv-1.11.ebuild b/dev-libs/libiconv/libiconv-1.11.ebuild
new file mode 100644
index 000000000000..ba316499a712
--- /dev/null
+++ b/dev-libs/libiconv/libiconv-1.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/libiconv-1.11.ebuild,v 1.1 2006/07/21 17:28:36 flameeyes Exp $
+
+inherit eutils multilib flag-o-matic autotools libtool
+
+DESCRIPTION="GNU charset conversion library for libc which doesn't implement it"
+SRC_URI="mirror://gnu/libiconv/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/libiconv/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="build"
+
+DEPEND="!sys-libs/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # This patch is needed as libiconv 1.10 provides (and uses) new functions
+ # and they are not present in the old libiconv.so, and this breaks the
+ # ${DESTDIR} != ${prefix} that we use. It's a problem for Solaris, but we
+ # don't have to deal with it for now.
+ epatch "${FILESDIR}/${PN}-1.10-link.patch"
+
+ # Make sure that libtool support is updated to link "the linux way" on
+ # FreeBSD.
+ elibtoolize
+}
+
+src_compile() {
+ # Filter -static as it breaks compilation
+ filter-ldflags -static
+
+ # Install in /lib as utils installed in /lib like gnutar
+ # can depend on this
+
+ # Disable NLS support because that creates a circular dependency
+ # between libiconv and gettext
+
+ econf \
+ --disable-nls \
+ --enable-shared \
+ --enable-static \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install || die "make install failed"
+
+ # Move static libs and creates ldscripts into /usr/lib
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}/$(get_libdir)"
+ gen_usr_ldscript libiconv.so
+ gen_usr_ldscript libcharset.so
+
+ use build && rm -rf "${D}/usr"
+
+ preserve_old_lib /lib/$(get_libdir)/libiconv.so.4
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /lib/$(get_libdir)/libiconv.so.4
+}