summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2003-02-04 06:02:09 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2003-02-04 06:02:09 +0000
commit4153ac17add29a1a0d6f0323f2caf29dd7e0890c (patch)
tree5a3659ecaeadc7b3103513528fe170419a6e68e9 /dev-libs/glib/glib-2.2.1.ebuild
parentnew unstable packages. (diff)
downloadhistorical-4153ac17add29a1a0d6f0323f2caf29dd7e0890c.tar.gz
historical-4153ac17add29a1a0d6f0323f2caf29dd7e0890c.tar.bz2
historical-4153ac17add29a1a0d6f0323f2caf29dd7e0890c.zip
modified a lot of DEBUG things to DEBUGBUILD and updated the latest version
Diffstat (limited to 'dev-libs/glib/glib-2.2.1.ebuild')
-rw-r--r--dev-libs/glib/glib-2.2.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-2.2.1.ebuild b/dev-libs/glib/glib-2.2.1.ebuild
new file mode 100644
index 000000000000..0737f12f5cb3
--- /dev/null
+++ b/dev-libs/glib/glib-2.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.2.1.ebuild,v 1.1 2003/02/04 06:02:09 spider Exp $
+
+inherit libtool
+
+IUSE="doc"
+S=${WORKDIR}/${P}
+DESCRIPTION="The GLib library of C routines"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.2/${P}.tar.bz2"
+HOMEPAGE="http://www.gtk.org/"
+
+SLOT="2"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=dev-util/pkgconfig-0.14.0
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ # Seems libtool have another wierd bug, try to fix it
+ # with a fix for nautilus, bug #4190
+ elibtoolize --reverse-deps
+
+ local myconf=""
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+
+ if [ -n "$DEBUGBUILD" ]; then
+ myconf="${myconf} --enable-debug=yes"
+ fi
+
+ econf \
+ --with-threads=posix \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS NEWS.pre-1-3
+}