summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-13 19:55:11 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-13 19:55:11 +0000
commit921793913e145e9cc7525b094d8ab5042e84b8a8 (patch)
treeda6aba925e9f6d20fd7c199f40b38466c97c4c9a /dev-libs/csconv/csconv-12.0.1_pre1891.ebuild
parentversion bump (diff)
downloadhistorical-921793913e145e9cc7525b094d8ab5042e84b8a8.tar.gz
historical-921793913e145e9cc7525b094d8ab5042e84b8a8.tar.bz2
historical-921793913e145e9cc7525b094d8ab5042e84b8a8.zip
Added a snapshot. Renamed previous ebuild and marked it stable.
Diffstat (limited to 'dev-libs/csconv/csconv-12.0.1_pre1891.ebuild')
-rw-r--r--dev-libs/csconv/csconv-12.0.1_pre1891.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/csconv/csconv-12.0.1_pre1891.ebuild b/dev-libs/csconv/csconv-12.0.1_pre1891.ebuild
new file mode 100644
index 000000000000..accf8f3145bf
--- /dev/null
+++ b/dev-libs/csconv/csconv-12.0.1_pre1891.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/csconv/csconv-12.0.1_pre1891.ebuild,v 1.1 2004/09/13 19:55:11 usata Exp $
+
+inherit iiimf eutils
+
+DESCRIPTION="A code conversion library for IIIMF"
+
+LICENSE="IBM"
+KEYWORDS="~x86"
+IUSE="debug"
+
+DEPEND="sys-devel/automake
+ sys-devel/autoconf"
+RDEPEND="virtual/libc"
+
+S="${WORKDIR}/${IMSDK}/lib/CSConv"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P%_*}-gentoo.diff
+}
+
+src_compile() {
+ econf --prefix=/usr/lib/im \
+ --enable-optimize \
+ `use_enable debug` || die
+ # emake doesn't work
+ make || die
+}
+
+src_install() {
+ einstall prefix=${D}/usr/lib/im || die
+
+ cd ${WORKDIR}/${IMSDK}/doc/conv
+ doman *.[1-9]
+ dodoc ChangeLog INSTALL README*
+}