summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-10-19 21:38:47 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-10-19 21:38:47 +0000
commitab834536cd15ce3ca4d5123661c2df64b1325a0b (patch)
tree6aed81f29827cd2c10e0113c8eadf47f81e871b1 /dev-libs/ccmath
parentAdded a patch for the configure script to honor the "arts" USE flag. Now it s... (diff)
downloadhistorical-ab834536cd15ce3ca4d5123661c2df64b1325a0b.tar.gz
historical-ab834536cd15ce3ca4d5123661c2df64b1325a0b.tar.bz2
historical-ab834536cd15ce3ca4d5123661c2df64b1325a0b.zip
Added ~amd64 keyword
Diffstat (limited to 'dev-libs/ccmath')
-rw-r--r--dev-libs/ccmath/ChangeLog6
-rw-r--r--dev-libs/ccmath/Manifest15
-rw-r--r--dev-libs/ccmath/ccmath-2.2.1.ebuild16
-rw-r--r--dev-libs/ccmath/files/ccmath-2.2.1-fPIC.patch31
4 files changed, 52 insertions, 16 deletions
diff --git a/dev-libs/ccmath/ChangeLog b/dev-libs/ccmath/ChangeLog
index d73b9ffa77b2..b18a6820f940 100644
--- a/dev-libs/ccmath/ChangeLog
+++ b/dev-libs/ccmath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/ccmath
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ccmath/ChangeLog,v 1.6 2004/09/30 00:13:05 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ccmath/ChangeLog,v 1.7 2004/10/19 21:38:47 sekretarz Exp $
+
+ 19 Oct 2004; Karol Wojtaszek,,, <sekretarz@gentoo.org>
+ +files/ccmath-2.2.1-fPIC.patch, ccmath-2.2.1.ebuild:
+ Added ~amd64 keyword and fPIC patch
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> ccmath-2.2.1.ebuild:
virtual/glibc -> virtual/libc
diff --git a/dev-libs/ccmath/Manifest b/dev-libs/ccmath/Manifest
index b4173f2d68ef..d5d8f493ff05 100644
--- a/dev-libs/ccmath/Manifest
+++ b/dev-libs/ccmath/Manifest
@@ -1,13 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 fbb7157d23ab6d18f77ceba3a5ef7b1a ChangeLog 1113
-MD5 cc53c4652310450b853c0e85ccf804a1 ccmath-2.2.1.ebuild 959
+MD5 fe7502af8f12f063a28e80070b5baa3d ccmath-2.2.1.ebuild 1153
+MD5 3a8103629e7d283faa430d3889c13b5a ChangeLog 1265
+MD5 e659e0f4f4aa1423e24d5d5089d0ae61 files/ccmath-2.2.1-fPIC.patch 707
MD5 1c8ba73673ef00b6ffaf5c195bccb99d files/digest-ccmath-2.2.1 64
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBW0+ZI1lqEGTUzyQRAgvoAKCBBjbMA5SjXj3qMfNQhd81iD6JfgCbBb8x
-zQl8vtwQE6UeUbOZne3Pk1Q=
-=O/LH
------END PGP SIGNATURE-----
diff --git a/dev-libs/ccmath/ccmath-2.2.1.ebuild b/dev-libs/ccmath/ccmath-2.2.1.ebuild
index d88f3bec6b2e..758e50e295f5 100644
--- a/dev-libs/ccmath/ccmath-2.2.1.ebuild
+++ b/dev-libs/ccmath/ccmath-2.2.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ccmath/ccmath-2.2.1.ebuild,v 1.8 2004/07/02 04:35:12 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ccmath/ccmath-2.2.1.ebuild,v 1.9 2004/10/19 21:38:47 sekretarz Exp $
+
+inherit eutils
DESCRIPTION="CCMATH is a mathematics library, coded in C, that contains functions for linear algebra, numerical integration,
geometry and trigonometry, curve fitting, roots and optimization, Fourier analysis, simulation generation, statistics,
@@ -11,14 +13,22 @@ HOMEPAGE="http://freshmeat.net/projects/ccmath/"
SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="x86 ppc sparc"
+KEYWORDS="x86 ppc sparc ~amd64"
DEPEND="virtual/libc"
IUSE=""
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use amd64 && epatch ${FILESDIR}/${P}-fPIC.patch
+}
+
src_compile() {
- yes | ./makelibs.sh
+ # if it is amd64 we doesn't support intels
+ use amd64 && yes n | ./makelibs.sh || yes | ./makelibs.sh
}
src_install() {
diff --git a/dev-libs/ccmath/files/ccmath-2.2.1-fPIC.patch b/dev-libs/ccmath/files/ccmath-2.2.1-fPIC.patch
new file mode 100644
index 000000000000..c95176f6d929
--- /dev/null
+++ b/dev-libs/ccmath/files/ccmath-2.2.1-fPIC.patch
@@ -0,0 +1,31 @@
+diff -Naur ccmath-2.2.1.orig/makelibs.sh ccmath-2.2.1/makelibs.sh
+--- ccmath-2.2.1.orig/makelibs.sh 2001-11-08 16:57:07.000000000 +0100
++++ ccmath-2.2.1/makelibs.sh 2004-10-19 23:33:36.745735608 +0200
+@@ -16,23 +16,23 @@
+ do
+ cd $MDR/$dr
+ echo `pwd`
+- cc -c -O3 *.c
++ cc -fPIC -c -O3 *.c
+ mv *.o $LSOD
+ done
+
+ # Compile corrected svd QR support without optimizing
+ # The GNU optimizer destroys the fix!
+ cd $MDR/matrix
+-cc -c qrb*.c
++cc -fPIC -c qrb*.c
+ mv *.o $LSOD
+ cd $MDR
+
+ if [ $F = "y" ]
+ then cd $MDR/matrix
+- cc -c -O3 solv.s
++ cc -fPIC -c -O3 solv.s
+ mv *.o $LSOD
+ cd $MDR/simu
+- cc -c -O3 *.s
++ cc -fPIC -c -O3 *.s
+ mv *.o $LSOD
+ fi
+ cd $LSOD