summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-03-11 20:38:14 +0000
committerMamoru Komachi <usata@gentoo.org>2004-03-11 20:38:14 +0000
commit3c0abbedb775b1fa97598b550386d26ae8fe4c34 (patch)
tree13439ce2ac98800de6c554af598648864576ca28 /dev-libs/boehm-gc/boehm-gc-6.2-r1.ebuild
parentSome fixes needed to be applied before I unmask this beast. (diff)
downloadhistorical-3c0abbedb775b1fa97598b550386d26ae8fe4c34.tar.gz
historical-3c0abbedb775b1fa97598b550386d26ae8fe4c34.tar.bz2
historical-3c0abbedb775b1fa97598b550386d26ae8fe4c34.zip
Include private/* headers as well. Closing bug #44251
Diffstat (limited to 'dev-libs/boehm-gc/boehm-gc-6.2-r1.ebuild')
-rw-r--r--dev-libs/boehm-gc/boehm-gc-6.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-6.2-r1.ebuild b/dev-libs/boehm-gc/boehm-gc-6.2-r1.ebuild
new file mode 100644
index 000000000000..651611da1282
--- /dev/null
+++ b/dev-libs/boehm-gc/boehm-gc-6.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-6.2-r1.ebuild,v 1.1 2004/03/11 20:38:14 usata Exp $
+
+S=${WORKDIR}/gc${PV/_/}
+
+DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
+HOMEPAGE="http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
+SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc${PV/_/}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ econf --enable-threads=pthreads \
+ || die "Configure failed..."
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ DESTDIR=${D} install-exec || die
+ insinto /usr/include/gc
+ doins include/*.h
+ insinto /usr/include/gc/private
+ doins include/private/*.h
+
+ dodoc README.QUICK doc/README* doc/barrett_diagram
+ dohtml doc/*.html
+ newman doc/gc.man gc.3
+}