summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-16 03:16:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-16 03:16:31 +0000
commit7ccde90df2bb781520f4f639aea9f5457e4213ee (patch)
tree19ca67e4628d8f88bd6673eb11f7e4ad60a248ff /dev-libs/DirectFB
parentavifile and libmpeg3 support disabled for now (diff)
downloadhistorical-7ccde90df2bb781520f4f639aea9f5457e4213ee.tar.gz
historical-7ccde90df2bb781520f4f639aea9f5457e4213ee.tar.bz2
historical-7ccde90df2bb781520f4f639aea9f5457e4213ee.zip
removed older ebuilds
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.7.ebuild69
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.9.ebuild75
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.71
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.91
4 files changed, 0 insertions, 146 deletions
diff --git a/dev-libs/DirectFB/DirectFB-0.9.7.ebuild b/dev-libs/DirectFB/DirectFB-0.9.7.ebuild
deleted file mode 100644
index eceea52f796f..000000000000
--- a/dev-libs/DirectFB/DirectFB-0.9.7.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.7.ebuild,v 1.4 2002/03/21 16:07:03 seemant Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="DirectFB is a thin library on top of the Linux fb devices"
-SRC_URI="http://www.directfb.org/download/DirectFB/${A}"
-HOMEPAGE="http://www.directfb.org"
-
-DEPEND="virtual/glibc sys-devel/perl >=media-libs/freetype-2.0.1 >=media-libs/jpeg-6
- >=media-libs/libpng-1.0.10 >=media-libs/libflash-0.4.10
- avifile? ( >=media-video/avifile-0.6.0 )
- libmpeg3? ( >=media-libs/libmpeg3-1.2.3 )"
-
-RDEPEND="virtual/glibc >=media-libs/freetype-2.0.1 >=media-libs/jpeg-6
- >=media-libs/libpng-1.0.10 >=media-libs/libflash-0.4.10
- >=dev-util/pkgconfig-0.8.0
- avifile? ( >=media-video/avifile-0.6.0 )
- libmpeg3? ( >=media-libs/libmpeg3-1.2.3 )"
-
-src_compile() {
- if [ "`use mmx`" ] ; then
- myconf="--enable-mmx"
- else
- myconf="--disable-mmx"
- fi
- if [ "`use avifile`" ] ; then
- myconf="$myconf --enable-avifile"
- else
- myconf="$myconf --disable-avifile"
- fi
- if [ "`use libmpeg3`" ] ; then
- myconf="$myconf --with-libmpeg3=/usr/include/libmpeg3"
- mkdir ${S}/interfaces/IDirectFBVideoProvider/no
- cp /usr/lib/libmpeg3.a ${S}/interfaces/IDirectFBVideoProvider/no
- else
- myconf="$myconf --disable-libmpeg3"
- fi
- if [ "$DEBUG" ] ; then
- myconf="$myconf --enable-debug"
- else
- myconf="$myconf --disable-debug"
- fi
- ./configure --prefix=/usr --host=${CHOST} $myconf \
- --enable-jpeg --enable-png --enable-gif || die
-# cp Makefile Makefile.orig
-# sed -e "s:examples::" Makefile.orig > Makefile
- if [ "`use libmpeg3`" ] ; then
- make LIBMPEG3_DIR=/usr/lib LIBMPEG3_LIBS=-lmpeg3 || die
- else
- make || die
- fi
-
-}
-
-src_install () {
- insinto /etc
- doins fb.modes
- if [ "`use libmpeg3`" ] ; then
- make LIBMPEG3_DIR=/usr/lib LIBMPEG3_LIBS=-lmpeg3 DESTDIR=${D} install || die
- else
- make DESTDIR=${D} install || die
- fi
- dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
- dohtml -r docs/html
-}
-
diff --git a/dev-libs/DirectFB/DirectFB-0.9.9.ebuild b/dev-libs/DirectFB/DirectFB-0.9.9.ebuild
deleted file mode 100644
index aa43b8b005b8..000000000000
--- a/dev-libs/DirectFB/DirectFB-0.9.9.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: system@gentoo.org
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.9.ebuild,v 1.1 2002/04/12 15:10:54 seemant Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="DirectFB is a thin library on top of the Linux framebuffer devices"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-HOMEPAGE="http://www.directfb.org"
-
-DEPEND="sys-devel/perl
- >=media-libs/freetype-2.0.1
- >=media-libs/jpeg-6
- >=media-libs/libpng-1.0.10
- >=media-libs/libflash-0.4.10
- avi? ( =media-video/avifile-0.6* )
- libmpeg3? ( >=media-libs/libmpeg3-1.2.3 )"
-
-RDEPEND="${DEPEND}"
-
-extralibinfo=""
-use libmpeg3 && extralibinfo="LIBMPEG3_DIR=/usr/lib LIBMPEG3_LIBS=-lmpeg3"
-
-src_compile() {
-
- use mmx \
- && myconf="--enable-mmx" \
- || myconf="--disable-mmx"
-
-# avifile that is in portage currently does not work with directfb
-# an older one in the 0.6.0 series is required.
-# use avi \
-# && myconf="${myconf} --enable-avifile" \
-# || myconf="${myconf} --disable-avifile"
-
- use libmpeg3 \
- && myconf="${myconf} --with-libmpeg3=/usr/include/libmpeg3" \
- && mkdir ${S}/interfaces/IDirectFBVideoProvider/no \
- && cp /usr/lib/libmpeg3.a ${S}/interfaces/IDirectFBVideoProvider/no \
- || myconf="${myconf} --disable-libmpeg3"
-
-
- if [ "$DEBUG" ] ; then
- myconf="${myconf} --enable-debug"
- else
- myconf="${myconf} --disable-debug"
- fi
-
- ./configure \
- --prefix=/usr \
- --host=${CHOST} \
- --disable-avifile \
- --enable-jpeg \
- --enable-png \
- --enable-gif \
- ${myconf} || die
-
- make \
- ${extralibinfo} || die
-
-}
-
-src_install () {
-
- insinto /etc
- doins fb.modes
-
- make \
- ${extralibinfo} \
- DESTDIR=${D} \
- install || die
-
- dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
- dohtml -r docs/html
-}
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.7 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.7
deleted file mode 100644
index b19cf649da8b..000000000000
--- a/dev-libs/DirectFB/files/digest-DirectFB-0.9.7
+++ /dev/null
@@ -1 +0,0 @@
-MD5 754e9a68d30decdf69bdc21f0d82f201 DirectFB-0.9.7.tar.gz 1258902
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.9 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.9
deleted file mode 100644
index e7ac2bbe0cbf..000000000000
--- a/dev-libs/DirectFB/files/digest-DirectFB-0.9.9
+++ /dev/null
@@ -1 +0,0 @@
-MD5 46cff64fa95e927bdbce38fc37f5baf6 DirectFB-0.9.9.tar.gz 594770