summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-17 05:03:53 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-17 05:03:53 +0000
commitfb50903f5b7ecb009b8d0047750576a0595b8014 (patch)
treeb1201d51bd1255af28a4afdd65c42dc7f601ffcb /dev-lang
parentDelete older ebuild. (diff)
downloadhistorical-fb50903f5b7ecb009b8d0047750576a0595b8014.tar.gz
historical-fb50903f5b7ecb009b8d0047750576a0595b8014.tar.bz2
historical-fb50903f5b7ecb009b8d0047750576a0595b8014.zip
Small updates.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.4.6.ebuild17
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild12
-rw-r--r--dev-lang/python/python-2.6.3.ebuild17
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild17
4 files changed, 34 insertions, 29 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index f2600c58058f..2233c5978a5f 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.21 2009/10/03 17:46:55 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.22 2009/10/17 05:03:53 arfrever Exp $
EAPI="1"
inherit autotools eutils flag-o-matic multilib python toolchain-funcs versionator
# We need this so that we don't depend on python.eclass.
-PYVER_MAJOR=$(get_major_version)
-PYVER_MINOR=$(get_version_component_range 2)
+PYVER_MAJOR="$(get_major_version)"
+PYVER_MINOR="$(get_version_component_range 2)"
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
MY_P="Python-${PV}"
@@ -57,6 +57,10 @@ pkg_setup() {
ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
ewarn "module provided by dev-python/bsddb3 which supports both Python 2 and Python 3."
fi
+
+ if ! has_version "=dev-lang/python-3*"; then
+ elog "It is highly recommended to additionally install Python 3, but without configuring Python wrapper to use Python 3."
+ fi
}
src_unpack() {
@@ -196,14 +200,14 @@ src_test() {
local skip_tests="cookielib distutils global hotshot mimetools minidom mmap posix sax strptime subprocess syntax tcl time urllib urllib2"
for test in ${skip_tests}; do
- mv "${S}"/Lib/test/test_${test}.py "${T}"
+ mv "${S}/Lib/test/test_${test}.py" "${T}"
done
# Rerun failed tests in verbose mode (regrtest -w).
EXTRATESTOPTS="-w" make test || die "make test failed"
for test in ${skip_tests}; do
- mv "${T}"/test_${test}.py "${S}"/Lib/test/test_${test}.py
+ mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
done
elog "The following tests have been skipped:"
@@ -217,7 +221,6 @@ src_test() {
}
src_install() {
- dodir /usr
emake DESTDIR="${D}" altinstall maninstall || die "emake altinstall maninstall failed"
# Install our own custom python-config
@@ -250,7 +253,7 @@ src_install() {
if use examples; then
insinto /usr/share/doc/${PF}/examples
- doins -r "${S}"/Tools || die "doins failed"
+ doins -r "${S}/Tools" || die "doins failed"
fi
newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT}
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index af4b226bf21a..bc709e341e0b 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.23 2009/10/03 17:46:55 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.24 2009/10/17 05:03:53 arfrever Exp $
EAPI="1"
inherit autotools eutils flag-o-matic libtool multilib pax-utils python toolchain-funcs versionator
# We need this so that we don't depend on python.eclass.
-PYVER_MAJOR=$(get_major_version)
-PYVER_MINOR=$(get_version_component_range 2)
+PYVER_MAJOR="$(get_major_version)"
+PYVER_MINOR="$(get_version_component_range 2)"
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
MY_P="Python-${PV}"
@@ -210,7 +210,7 @@ src_test() {
host-is-pax && skip_tests+=" ctypes"
for test in ${skip_tests}; do
- mv "${S}"/Lib/test/test_${test}.py "${T}"
+ mv "${S}/Lib/test/test_${test}.py" "${T}"
done
# Redirect stdin from /dev/tty as a workaround for bug #248081.
@@ -218,7 +218,7 @@ src_test() {
EXTRATESTOPTS="-w" make test < /dev/tty || die "make test failed"
for test in ${skip_tests}; do
- mv "${T}"/test_${test}.py "${S}"/Lib/test/test_${test}.py
+ mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
done
elog "The following tests have been skipped:"
@@ -259,7 +259,7 @@ src_install() {
if use examples; then
insinto /usr/share/doc/${PF}/examples
- doins -r "${S}"/Tools || die "doins failed"
+ doins -r "${S}/Tools" || die "doins failed"
fi
newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT}
diff --git a/dev-lang/python/python-2.6.3.ebuild b/dev-lang/python/python-2.6.3.ebuild
index 3453fb9792fb..9f1569193fd9 100644
--- a/dev-lang/python/python-2.6.3.ebuild
+++ b/dev-lang/python/python-2.6.3.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.3.ebuild,v 1.4 2009/10/14 04:13:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.3.ebuild,v 1.5 2009/10/17 05:03:53 arfrever Exp $
EAPI="2"
inherit autotools eutils flag-o-matic multilib pax-utils python toolchain-funcs versionator
# We need this so that we don't depend on python.eclass.
-PYVER_MAJOR=$(get_major_version)
-PYVER_MINOR=$(get_version_component_range 2)
+PYVER_MAJOR="$(get_major_version)"
+PYVER_MINOR="$(get_version_component_range 2)"
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
MY_P="Python-${PV}"
@@ -73,7 +73,8 @@ pkg_setup() {
}
src_prepare() {
- # Ensure that internal copy of libffi isn't used.
+ # Ensure that internal copies of expat and libffi aren't used.
+ rm -fr Modules/expat
rm -fr Modules/_ctypes/libffi*
if tc-is-cross-compiler; then
@@ -105,7 +106,7 @@ src_prepare() {
fi
# Don't silence output of setup.py.
- sed -e '/setup\.py -q build/d' -i Makefile.pre.in
+ sed -e "/setup\.py -q build/d" -i Makefile.pre.in
# Fix OtherFileTests.testStdin() not to assume
# that stdin is a tty for bug #248081.
@@ -209,14 +210,14 @@ src_test() {
host-is-pax && skip_tests+=" ctypes"
for test in ${skip_tests}; do
- mv "${S}"/Lib/test/test_${test}.py "${T}"
+ mv "${S}/Lib/test/test_${test}.py" "${T}"
done
# Rerun failed tests in verbose mode (regrtest -w).
EXTRATESTOPTS="-w" make test || die "make test failed"
for test in ${skip_tests}; do
- mv "${T}"/test_${test}.py "${S}"/Lib/test/test_${test}.py
+ mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
done
elog "The following tests have been skipped:"
@@ -260,7 +261,7 @@ src_install() {
if use examples; then
insinto /usr/share/doc/${PF}/examples
- doins -r "${S}"/Tools || die "doins failed"
+ doins -r "${S}/Tools" || die "doins failed"
fi
newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT}
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index 313a0cba643e..cda8869d4c2d 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.12 2009/10/14 09:27:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.13 2009/10/17 05:03:53 arfrever Exp $
EAPI="2"
inherit autotools eutils flag-o-matic multilib pax-utils python toolchain-funcs versionator
# We need this so that we don't depend on python.eclass.
-PYVER_MAJOR=$(get_major_version)
-PYVER_MINOR=$(get_version_component_range 2)
+PYVER_MAJOR="$(get_major_version)"
+PYVER_MINOR="$(get_version_component_range 2)"
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
MY_P="Python-${PV}"
@@ -51,7 +51,8 @@ PDEPEND="app-admin/python-updater
PROVIDE="virtual/python"
src_prepare() {
- # Ensure that internal copy of libffi isn't used.
+ # Ensure that internal copies of expat and libffi aren't used.
+ rm -fr Modules/expat
rm -fr Modules/_ctypes/libffi*
if ! tc-is-cross-compiler; then
@@ -79,7 +80,7 @@ src_prepare() {
fi
# Don't silence output of setup.py.
- sed -e '/setup\.py -q build/d' -i Makefile.pre.in
+ sed -e "/setup\.py -q build/d" -i Makefile.pre.in
# Fix OtherFileTests.testStdin() not to assume
# that stdin is a tty for bug #248081.
@@ -191,14 +192,14 @@ src_test() {
host-is-pax && skip_tests+=" ctypes"
for test in ${skip_tests}; do
- mv "${S}"/Lib/test/test_${test}.py "${T}"
+ mv "${S}/Lib/test/test_${test}.py" "${T}"
done
# Rerun failed tests in verbose mode (regrtest -w).
EXTRATESTOPTS="-w" make test || die "make test failed"
for test in ${skip_tests}; do
- mv "${T}"/test_${test}.py "${S}"/Lib/test/test_${test}.py
+ mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
done
elog "The following tests have been skipped:"
@@ -240,7 +241,7 @@ src_install() {
if use examples; then
insinto /usr/share/doc/${PF}/examples
- doins -r "${S}"/Tools || die "doins failed"
+ doins -r "${S}/Tools" || die "doins failed"
fi
newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT}