summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-04-18 03:31:55 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-04-18 03:31:55 +0000
commitda85b0b0fdddab03c78e25063728429ff8a32aab (patch)
tree9b3fac6c08b6819e1809fecdc74453ebd4806c16 /dev-lang
parentUpdate the updatedb.conf file (diff)
downloadhistorical-da85b0b0fdddab03c78e25063728429ff8a32aab.tar.gz
historical-da85b0b0fdddab03c78e25063728429ff8a32aab.tar.bz2
historical-da85b0b0fdddab03c78e25063728429ff8a32aab.zip
new package: "Yet another algebra system"
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/yacas/ChangeLog10
-rw-r--r--dev-lang/yacas/files/digest-yacas-1.0.541
-rw-r--r--dev-lang/yacas/yacas-1.0.54.ebuild63
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-lang/yacas/ChangeLog b/dev-lang/yacas/ChangeLog
new file mode 100644
index 000000000000..09d17f704ee8
--- /dev/null
+++ b/dev-lang/yacas/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-sci/yacas
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yacas/ChangeLog,v 1.1 2003/04/18 03:31:55 george Exp $
+
+*yacas-1.0.54.ebuild (17 Apr 2003)
+
+ 17 Apr 2003; George Shapovalov <george@gentoo.org> yacas-1.0.54.ebuild, files/digest-yacas-1.0.54 :
+ initial release (#3790)
+ YACAS is a very powerful, general purpose Computer Algebra System.
+ ebuild submitted by Tobias Florek <tflorek@web.de>
diff --git a/dev-lang/yacas/files/digest-yacas-1.0.54 b/dev-lang/yacas/files/digest-yacas-1.0.54
new file mode 100644
index 000000000000..9b4a5773e612
--- /dev/null
+++ b/dev-lang/yacas/files/digest-yacas-1.0.54
@@ -0,0 +1 @@
+MD5 282e705b3a7466d31dc7ee6a76158d21 yacas-1.0.54.tar.gz 1651299
diff --git a/dev-lang/yacas/yacas-1.0.54.ebuild b/dev-lang/yacas/yacas-1.0.54.ebuild
new file mode 100644
index 000000000000..30a8efbccd15
--- /dev/null
+++ b/dev-lang/yacas/yacas-1.0.54.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yacas/yacas-1.0.54.ebuild,v 1.1 2003/04/18 03:31:55 george Exp $
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="YACAS is a very powerful, general purpose Computer Algebra System."
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+DEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+#src_unpack() {
+# unpack ${A}
+# cd ${S}
+#
+# sed -i -e "s:yacas_include = :yacas_include = ${D}:" src/Makefile.in ramscripts/Makefile.in
+#}
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die
+
+ # only build gui, if we use x
+# proteus is untested and does not compile this way,
+# needs an installed (and merged) yacas to compile.
+# if use X ; then
+# cd proteus
+# emake depend -f makefile.linux || die
+# emake -f makefile.linux || die
+# cd ..
+# fi
+}
+
+src_install () {
+ #a very strange Makefile's, that do not honor standard wrappings :(
+ cd ${S}
+ find -name Makefile |xargs sed -i -e "s:datadir = /usr/share:datadir = ${D}/usr/share:"
+ cd manmake
+ sed -i -e "s:htmldir = :htmldir = ${D}:" -e "s:psdir = :psdir = ${D}:" Makefile
+ cd ${S}
+
+ DESTDIR=${D} make install-strip || die
+
+#rm -rf var/
+
+# see above notice
+# if ( use X ); then
+# cd proteus
+# emake install-strip -f makefile.linux || die
+# cd ..
+# fi
+
+ dodoc AUTHORS INSTALL NEWS README TODO
+ mv ${D}/usr/share/${PN}/documentation ${D}/usr/share/doc/${PF}/html
+ rmdir ${D}/usr/include/
+}