summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-03 14:15:25 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-03 14:15:25 +0000
commitcd87742fece3ccabc7c977355ae5177997283ac1 (patch)
tree9c725124a16b04cd33d7012b149c6dc212f7a1b6 /dev-lang
parentSecurity update (diff)
downloadhistorical-cd87742fece3ccabc7c977355ae5177997283ac1.tar.gz
historical-cd87742fece3ccabc7c977355ae5177997283ac1.tar.bz2
historical-cd87742fece3ccabc7c977355ae5177997283ac1.zip
Security update
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/files/digest-python-2.2.1-r51
-rw-r--r--dev-lang/python/files/python-2.2.1-r5-gentoo.diff126
-rw-r--r--dev-lang/python/python-2.2.1-r5.ebuild97
4 files changed, 230 insertions, 1 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index c73b830e11e2..50b014f06cdc 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.14 2002/09/08 08:12:25 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.15 2002/10/03 14:15:25 aliz Exp $
+
+*python-2.2.1-r5 (03 Oct 2002)
+
+ 03 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update.
*python-2.2.1-r4 (7 Sep 2002)
7 Sep 2002; Nicholas Jones <carpaski@gentoo.org> python-2.2.1-r4.ebuild
diff --git a/dev-lang/python/files/digest-python-2.2.1-r5 b/dev-lang/python/files/digest-python-2.2.1-r5
new file mode 100644
index 000000000000..ea99f8857c06
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.2.1-r5
@@ -0,0 +1 @@
+MD5 e7012d611602b62e36073c2fd02396a3 Python-2.2.1.tgz 6535104
diff --git a/dev-lang/python/files/python-2.2.1-r5-gentoo.diff b/dev-lang/python/files/python-2.2.1-r5-gentoo.diff
new file mode 100644
index 000000000000..13d74f626918
--- /dev/null
+++ b/dev-lang/python/files/python-2.2.1-r5-gentoo.diff
@@ -0,0 +1,126 @@
+===================================================================
+RCS file: /cvsroot/python/python/dist/src/Lib/os.py,v
+retrieving revision 1.50.8.2
+retrieving revision 1.50.8.4
+diff -u -r1.50.8.2 -r1.50.8.4
+--- python/python/dist/src/Lib/os.py 2002/03/16 18:02:20 1.50.8.2
++++ python/python/dist/src/Lib/os.py 2002/09/03 16:36:59 1.50.8.4
+@@ -298,7 +298,7 @@
+ _execvpe(file, args)
+
+ def execvpe(file, args, env):
+- """execv(file, args, env)
++ """execvpe(file, args, env)
+
+ Execute the executable file (which is searched for along $PATH)
+ with argument list args and environment env , replacing the
+@@ -308,8 +308,9 @@
+
+ __all__.extend(["execl","execle","execlp","execlpe","execvp","execvpe"])
+
+-_notfound = None
+ def _execvpe(file, args, env=None):
++ from errno import ENOENT, ENOTDIR
++
+ if env is not None:
+ func = execve
+ argrest = (args, env)
+@@ -317,7 +318,7 @@
+ func = execv
+ argrest = (args,)
+ env = environ
+- global _notfound
++
+ head, tail = path.split(file)
+ if head:
+ apply(func, (file,) + argrest)
+@@ -327,30 +328,21 @@
+ else:
+ envpath = defpath
+ PATH = envpath.split(pathsep)
+- if not _notfound:
+- if sys.platform[:4] == 'beos':
+- # Process handling (fork, wait) under BeOS (up to 5.0)
+- # doesn't interoperate reliably with the thread interlocking
+- # that happens during an import. The actual error we need
+- # is the same on BeOS for posix.open() et al., ENOENT.
+- try: unlink('/_#.# ## #.#')
+- except error, _notfound: pass
+- else:
+- import tempfile
+- t = tempfile.mktemp()
+- # Exec a file that is guaranteed not to exist
+- try: execv(t, ('blah',))
+- except error, _notfound: pass
+- exc, arg = error, _notfound
++ saved_exc = None
++ saved_tb = None
+ for dir in PATH:
+ fullname = path.join(dir, file)
+ try:
+ apply(func, (fullname,) + argrest)
+- except error, (errno, msg):
+- if errno != arg[0]:
+- exc, arg = error, (errno, msg)
+- raise exc, arg
+-
++ except error, e:
++ tb = sys.exc_info()[2]
++ if (e.errno != ENOENT and e.errno != ENOTDIR
++ and saved_exc is None):
++ saved_exc = e
++ saved_tb = tb
++ if saved_exc:
++ raise error, saved_exc, saved_tb
++ raise error, e, tb
+
+ # Change environ to automatically call putenv() if it exists
+ try:
+
+===================================================================
+RCS file: /cvsroot/python/python/dist/src/setup.py,v
+retrieving revision 1.73.4.4
+retrieving revision 1.73.4.7
+diff -u -r1.73.4.4 -r1.73.4.7
+--- python/python/dist/src/setup.py 2002/03/26 13:43:04 1.73.4.4
++++ python/python/dist/src/setup.py 2002/08/08 19:52:42 1.73.4.7
+@@ -1,7 +1,7 @@
+ # Autodetecting setup.py script for building the Python extensions
+ #
+
+-__version__ = "$Revision: 1.1 $"
++__version__ = "$Revision: 1.1 $"
+
+ import sys, os, getopt
+ from distutils import sysconfig
+@@ -273,8 +273,6 @@
+ exts.append( Extension('pwd', ['pwdmodule.c']) )
+ # grp(3)
+ exts.append( Extension('grp', ['grpmodule.c']) )
+- # posix (UNIX) errno values
+- exts.append( Extension('errno', ['errnomodule.c']) )
+ # select(2); not on ancient System V
+ exts.append( Extension('select', ['selectmodule.c']) )
+
+===================================================================
+RCS file: /cvsroot/python/python/dist/src/Modules/Setup.dist,v
+retrieving revision 1.24
+retrieving revision 1.24.10.2
+diff -u -r1.24 -r1.24.10.2
+--- python/python/dist/src/Modules/Setup.dist 2001/10/17 13:46:28 1.24
++++ python/python/dist/src/Modules/Setup.dist 2002/08/08 19:52:42 1.24.10.2
+@@ -97,6 +97,7 @@
+ # setup.py script in the root of the Python source tree.
+
+ posix posixmodule.c # posix (UNIX) system calls
++errno errnomodule.c # posix (UNIX) errno values
+ _sre _sre.c # Fredrik Lundh's new regular expressions
+ new newmodule.c # Tommy Burnette's 'new' module
+
+@@ -166,7 +167,6 @@
+ #fcntl fcntlmodule.c # fcntl(2) and ioctl(2)
+ #pwd pwdmodule.c # pwd(3)
+ #grp grpmodule.c # grp(3)
+-#errno errnomodule.c # posix (UNIX) errno values
+ #select selectmodule.c # select(2); not on ancient System V
+
diff --git a/dev-lang/python/python-2.2.1-r5.ebuild b/dev-lang/python/python-2.2.1-r5.ebuild
new file mode 100644
index 000000000000..72aea6930c51
--- /dev/null
+++ b/dev-lang/python/python-2.2.1-r5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r5.ebuild,v 1.1 2002/10/03 14:15:25 aliz Exp $
+
+PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
+PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
+PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
+S=${WORKDIR}/Python-${PV}
+DESCRIPTION="A really great language"
+SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz"
+
+HOMEPAGE="http://www.python.org"
+LICENSE="PSF-2.2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
+ berkdb? ( >=sys-libs/db-3 )
+ tcltk? ( >=dev-lang/tk-8.0 )"
+if [ -z "`use build`" -a -z "`use bootstrap`" ]; then
+ DEPEND="$DEPEND dev-libs/expat"
+fi
+RDEPEND="$DEPEND dev-python/python-fchksum"
+
+# The dev-python/python-fchksum RDEPEND is needed to that this python provides
+# the functionality expected from previous pythons.
+
+PROVIDE="virtual/python"
+
+SLOT="2.2"
+
+inherit flag-o-matic
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p4 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ filter-flags -malign-double
+ export OPT="$CFLAGS"
+
+ # adjust makefile to install pydoc into ${D} correctly
+ t=${S}/Makefile.pre.in
+ cp $t $t.orig || die
+ sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
+
+ local myopts
+ #if we are creating a new build image, we remove the dependency on g++
+ if [ "`use build`" -a ! "`use bootstrap`" ]
+ then
+ myopts="--with-cxx=no"
+ fi
+
+ econf --with-fpectl \
+ --infodir='${prefix}'/share/info \
+ --mandir='${prefix}'/share/man \
+ $myopts || die
+ emake || die "Parallel make failed"
+}
+
+src_install() {
+ dodir /usr
+ make install prefix=${D}/usr || die
+ rm "${D}/usr/bin/python"
+ dosym python${PYVER_MAJOR} /usr/bin/python
+ dosym python${PYVER_MAJOR}.${PYVER_MINOR} /usr/bin/python${PYVER_MAJOR}
+ dodoc README
+
+ # install our own custom python-config
+ exeinto /usr/bin
+ newexe ${FILESDIR}/python-config-${PV} python-config
+
+ # seems like the build do not install Makefile.pre.in anymore
+ # it probably shouldn't - use DistUtils, people!
+ insinto /usr/lib/python${PYVER}/config
+ doins ${S}/Makefile.pre.in
+
+ # While we're working on the config stuff... Let's fix the OPT var
+ # so that it doesn't have any opts listed in it. Prevents the problem
+ # with compiling things with conflicting opts later.
+ mv \
+ ${D}/usr/lib/python${PYVER}/config/Makefile \
+ ${D}/usr/lib/python${PYVER}/config/Makefile.orig
+ sed 's:^OPT=.*:OPT=-NDEBUG:' \
+ < ${D}/usr/lib/python${PYVER}/config/Makefile.orig \
+ > ${D}/usr/lib/python${PYVER}/config/Makefile
+
+ # If USE tcltk lets install idle
+ # Need to script the python version in the path
+ if use tcltk; then
+ mkdir "${D}/usr/lib/python${PYVER}/tools"
+ mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
+ dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
+ fi
+}