summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-02-06 16:09:57 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-02-06 16:09:57 +0000
commit9f799ae924ef40ad9e347ce3b636104eadbba8f2 (patch)
tree9726da281107f128038f3ba9b612e3f4e3a87f12 /dev-lang
parentfix use of DESTDIR (bug #80941) (diff)
downloadhistorical-9f799ae924ef40ad9e347ce3b636104eadbba8f2.tar.gz
historical-9f799ae924ef40ad9e347ce3b636104eadbba8f2.tar.bz2
historical-9f799ae924ef40ad9e347ce3b636104eadbba8f2.zip
New package for the caml-light language.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/caml-light/ChangeLog12
-rw-r--r--dev-lang/caml-light/Manifest4
-rw-r--r--dev-lang/caml-light/caml-light-0.75.ebuild54
-rw-r--r--dev-lang/caml-light/files/digest-caml-light-0.751
-rw-r--r--dev-lang/caml-light/metadata.xml5
5 files changed, 76 insertions, 0 deletions
diff --git a/dev-lang/caml-light/ChangeLog b/dev-lang/caml-light/ChangeLog
new file mode 100644
index 000000000000..231bbafbbe43
--- /dev/null
+++ b/dev-lang/caml-light/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-lang/caml-light
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/caml-light/ChangeLog,v 1.1 2005/02/06 16:09:57 mattam Exp $
+
+*caml-light-0.75 (06 Feb 2005)
+
+ 06 Feb 2005; Matthieu Sozeau <mattam@gentoo.org> +metadata.xml,
+ +caml-light-0.75.ebuild:
+ The caml-light language and implementation is an ancestor of ocaml still used
+ in teaching. Thanks to Pascal Vanier <vmaster@free.fr> for the original
+ ebuild. Fixes bug 80501.
+
diff --git a/dev-lang/caml-light/Manifest b/dev-lang/caml-light/Manifest
new file mode 100644
index 000000000000..6ebc5a10114c
--- /dev/null
+++ b/dev-lang/caml-light/Manifest
@@ -0,0 +1,4 @@
+MD5 5de5ddfe6766d3d8c877a4af34e7a448 caml-light-0.75.ebuild 1310
+MD5 d8edb37fd0a23ac043fe13e934e1137e ChangeLog 518
+MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
+MD5 c34d5b839fddfbac9d4547af9fa85aa8 files/digest-caml-light-0.75 61
diff --git a/dev-lang/caml-light/caml-light-0.75.ebuild b/dev-lang/caml-light/caml-light-0.75.ebuild
new file mode 100644
index 000000000000..295660896267
--- /dev/null
+++ b/dev-lang/caml-light/caml-light-0.75.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/caml-light/caml-light-0.75.ebuild,v 1.1 2005/02/06 16:09:57 mattam Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Caml-type language used in the french Computer Science lessons of the Preparatory Classes"
+HOMEPAGE="http://pauillac.inria.fr/caml/distrib-caml-light-fra.html"
+
+SRC_URI="ftp://ftp.inria.fr/INRIA/caml-light/cl75unix.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="tcltk"
+
+DEPEND="virtual/libc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/cl75/src
+}
+
+pkg_setup() {
+ ewarn
+ ewarn "Building caml-light with unsafe CFLAGS can have unexpected results"
+ ewarn "Please retry building with safer CFLAGS before reporting bugs"
+ ewarn
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+ replace-flags "-O?" -O2
+ cd ${WORKDIR}/cl75/src
+ make BINDIR=/usr/bin \
+ LIBDIR=/usr/lib/caml-light \
+ MANDIR=/usr/share/man \
+ configure || die
+
+ make world || die
+}
+
+src_install() {
+ cd ${WORKDIR}/cl75/src
+ mkdir -p ${D}usr/bin
+ mkdir -p ${D}usr/lib/caml-light
+ mkdir -p ${D}usr/share/man
+ make BINDIR=${D}usr/bin \
+ LIBDIR=${D}usr/lib/caml-light \
+ MANDIR=${D}usr/share/man \
+ install || die
+
+}
diff --git a/dev-lang/caml-light/files/digest-caml-light-0.75 b/dev-lang/caml-light/files/digest-caml-light-0.75
new file mode 100644
index 000000000000..5188195d88a0
--- /dev/null
+++ b/dev-lang/caml-light/files/digest-caml-light-0.75
@@ -0,0 +1 @@
+MD5 6c236074e4487949ec22001c7a498057 cl75unix.tar.gz 1108206
diff --git a/dev-lang/caml-light/metadata.xml b/dev-lang/caml-light/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-lang/caml-light/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>