summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-26 10:21:04 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-26 10:21:04 +0000
commit8e427e35597dbc11196707134257f09f2b466dc0 (patch)
tree82af42dd8fb4ad3d80f45e29c34efbd2436f2750 /dev-lang
parentamd64 stable, bug #284488 (diff)
downloadhistorical-8e427e35597dbc11196707134257f09f2b466dc0.tar.gz
historical-8e427e35597dbc11196707134257f09f2b466dc0.tar.bz2
historical-8e427e35597dbc11196707134257f09f2b466dc0.zip
jer's earlier fix missed some of the pkgconfig calls for the INSTALL_LIB and libdir settings. Fixup so I can do Lua SWIG bindings.
Package-Manager: portage-2.2_rc51/cvs/Linux x86_64
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/lua/ChangeLog8
-rw-r--r--dev-lang/lua/Manifest3
-rw-r--r--dev-lang/lua/lua-5.1.4-r4.ebuild117
3 files changed, 126 insertions, 2 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index a4bcf21b4dae..0c7f9449d9d5 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/lua
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.136 2009/11/24 17:31:36 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.137 2009/11/26 10:21:04 robbat2 Exp $
+
+*lua-5.1.4-r4 (26 Nov 2009)
+
+ 26 Nov 2009; Robin H. Johnson <robbat2@gentoo.org> +lua-5.1.4-r4.ebuild:
+ jer's earlier fix missed some of the pkgconfig calls for the INSTALL_LIB
+ and libdir settings. Fixup so I can do Lua SWIG bindings.
*lua-5.1.4-r3 (24 Nov 2009)
diff --git a/dev-lang/lua/Manifest b/dev-lang/lua/Manifest
index 9c30fdb8dd07..7e155aa801de 100644
--- a/dev-lang/lua/Manifest
+++ b/dev-lang/lua/Manifest
@@ -24,6 +24,7 @@ DIST lua-5.1.4.tar.gz 216679 RMD160 c867c8364295d3e4fb4e4d8ebb27fa2b2312cdef SHA
EBUILD lua-5.1.4-r1.ebuild 3012 RMD160 e1c82ed3d00d328d252d69e3f8cd2cf87be4deba SHA1 e7a456257f6d8da43cc9df3add3b7cf43558d9db SHA256 e8459fb17fa2dace1e7e06ee730638615e25f952bb7f106ac9605502df5596d5
EBUILD lua-5.1.4-r2.ebuild 3075 RMD160 189a712c32fd3b0f69317dc0228ceaa570f48282 SHA1 a2627e7ae9e801940180d462afd4692ae7740c89 SHA256 df3b33b7b787399fcc038e07d5c007720e1c66744f97c3b7a45eec164575f89c
EBUILD lua-5.1.4-r3.ebuild 3130 RMD160 c666caa144581f6998eb1db440352c655617635a SHA1 8213f0675c61a2feb84e5d27f372cd490c7f945f SHA256 5bc42367d96709851459856f34a4498110bae768ee7572104f98b07f43254152
+EBUILD lua-5.1.4-r4.ebuild 3133 RMD160 d4bbfbff46ebc765f3652cf1b4f5d95177c61412 SHA1 c0d0a0d4cf0262400c64480fd5069c2336e4b006 SHA256 2b31d37f5d4d34093196c665028ee050e37c2d71408517844b3c0552cca9640c
EBUILD lua-5.1.4.ebuild 2994 RMD160 637f425e9ec4034ede44dee36061693f006bee48 SHA1 f1406a740a642647a106f77f22ffa5a4aec45b93 SHA256 d44847b8f322ef735ce8786cba2af466110e30154583a5479bd6029cc9b119bd
-MISC ChangeLog 20337 RMD160 d3dbb88a469619c0949208585993640803aeccb4 SHA1 c25744a9ce1e0e03c1397d10fab148f591ffe632 SHA256 9bdfb444a96a567bdb0f6f92bbb238af837dc972636f5f7715a985f9ae369567
+MISC ChangeLog 20581 RMD160 c10e01447b42fabb10505885a3650f51e5e40fbe SHA1 246ef81aec80566be6edba2dafb035e52e8bce0d SHA256 fdac19f5cd9109c9cd2b4ada9942b0b9b4fdb901b580fa370305bead9ac5ca4b
MISC metadata.xml 339 RMD160 0d536a77658ffb6d8bccff7183a5bf4722d0a82d SHA1 f5bd1085f69b6e9d81e42cd711a7846ccb267e31 SHA256 6b3bedf093395def984b71f7c74ce59742c5df6592ad50f1b96c8a2499f27c8b
diff --git a/dev-lang/lua/lua-5.1.4-r4.ebuild b/dev-lang/lua/lua-5.1.4-r4.ebuild
new file mode 100644
index 000000000000..4b64adaa2191
--- /dev/null
+++ b/dev-lang/lua/lua-5.1.4-r4.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.4-r4.ebuild,v 1.1 2009/11/26 10:21:04 robbat2 Exp $
+
+EAPI="1"
+
+inherit eutils multilib portability toolchain-funcs versionator
+
+DESCRIPTION="A powerful light-weight programming language designed for extending applications"
+HOMEPAGE="http://www.lua.org/"
+SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+deprecated emacs readline static"
+
+DEPEND="readline? ( sys-libs/readline )"
+RDEPEND="${DEPEND}"
+PDEPEND="emacs? ( app-emacs/lua-mode )"
+
+src_unpack() {
+ local PATCH_PV=$(get_version_component_range 1-2)
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make-r1.patch
+ epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
+
+ EPATCH_SOURCE="${FILESDIR}/${PV}" EPATCH_SUFFIX="upstream.patch" epatch
+
+ # correct lua versioning
+ sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:4:1/' src/Makefile
+
+ sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
+
+ if ! use deprecated ; then
+ epatch "${FILESDIR}"/${P}-deprecated.patch
+ epatch "${FILESDIR}"/${P}-test.patch
+ fi
+
+ if ! use readline ; then
+ epatch "${FILESDIR}"/${PN}-${PATCH_PV}-readline.patch
+ fi
+
+ # Using dynamic linked lua is not recommended upstream for performance
+ # reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
+ # Mainly, this is of concern if your arch is poor with GPRs, like x86
+ # Not that this only affects the interpreter binary (named lua), not the lua
+ # compiler (built statically) nor the lua libraries (both shared and static
+ # are installed)
+ if use static ; then
+ epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make_static-r1.patch
+ fi
+
+ # We want packages to find our things...
+ sed -i \
+ -e 's:/usr/local:/usr:' \
+ -e "s:/\<lib\>:/$(get_libdir):g" \
+ etc/lua.pc
+}
+
+src_compile() {
+ tc-export CC
+ myflags=
+ # what to link to liblua
+ liblibs="-lm"
+ liblibs="${liblibs} $(dlopen_lib)"
+
+ # what to link to the executables
+ mylibs=
+ if use readline; then
+ mylibs="-lreadline"
+ fi
+
+ cd src
+ emake CC="${CC}" CFLAGS="-DLUA_USE_LINUX ${CFLAGS}" \
+ RPATH="${ROOT}/usr/$(get_libdir)/" \
+ LUA_LIBS="${mylibs}" \
+ LIB_LIBS="${liblibs}" \
+ V=${PV} \
+ gentoo_all || die "emake failed"
+
+ mv lua_test ../test/lua.static
+}
+
+src_install() {
+ emake INSTALL_TOP="${D}/usr/" INSTALL_LIB="${D}/usr/$(get_libdir)/" \
+ V=${PV} gentoo_install \
+ || die "emake install gentoo_install failed"
+
+ dodoc HISTORY README
+ dohtml doc/*.html doc/*.gif
+
+ insinto /usr/share/pixmaps
+ doins etc/lua.ico
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins etc/lua.pc
+
+ doman doc/lua.1 doc/luac.1
+}
+
+src_test() {
+ local positive="bisect cf echo env factorial fib fibfor hello printf sieve
+ sort trace-calls trace-globals"
+ local negative="readonly"
+ local test
+
+ cd "${S}"
+ for test in ${positive}; do
+ test/lua.static test/${test}.lua || die "test $test failed"
+ done
+
+ for test in ${negative}; do
+ test/lua.static test/${test}.lua && die "test $test failed"
+ done
+}